diff mbox series

[meta-oe,1/2] doxygen: Do not generate #line directive with flex/bison

Message ID 20230528190218.1875233-1-raj.khem@gmail.com
State New
Headers show
Series [meta-oe,1/2] doxygen: Do not generate #line directive with flex/bison | expand

Commit Message

Khem Raj May 28, 2023, 7:02 p.m. UTC
This ensures that buildpaths are not emitted into generated C
sourcefiles fixes.

WARNING: doxygen-1.9.3-r0 do_package_qa: QA Issue: File /usr/src/debug/doxygen/1.9.3-r0/generated_src/xmlcode.cpp in package doxygen-src contains reference to TMPDIR

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-oe/recipes-devtools/doxygen/doxygen_1.9.3.bb | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/doxygen/doxygen_1.9.3.bb b/meta-oe/recipes-devtools/doxygen/doxygen_1.9.3.bb
index 92fea981e1..8bd0992bd6 100644
--- a/meta-oe/recipes-devtools/doxygen/doxygen_1.9.3.bb
+++ b/meta-oe/recipes-devtools/doxygen/doxygen_1.9.3.bb
@@ -14,4 +14,8 @@  SRC_URI[sha256sum] = "f352dbc3221af7012b7b00935f2dfdc9fb67a97d43287d2f6c81c50449
 
 inherit cmake python3native
 
+EXTRA_OECMAKE += "\
+    -DFLEX_TARGET_ARG_COMPILE_FLAGS='--noline' \
+    -DBISON_TARGET_ARG_COMPILE_FLAGS='--no-lines' \
+"
 BBCLASSEXTEND = "native nativesdk"