diff mbox series

[meta-gnome,3/5] ibus: Point python interpreter to target location

Message ID 20230525054712.1593592-3-raj.khem@gmail.com
State New
Headers show
Series [meta-oe,1/5] remmina: Fix buildpaths QA warnings | expand

Commit Message

Khem Raj May 25, 2023, 5:47 a.m. UTC
it encoded PYTHON variable during build which otherwise points to python
on build host which is not correct for cross compiled packages.

Add missing dependency on python3-core which is needed for ibus-setup
script to run

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-gnome/recipes-support/ibus/ibus.bb  | 2 +-
 meta-gnome/recipes-support/ibus/ibus.inc | 3 +++
 2 files changed, 4 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-gnome/recipes-support/ibus/ibus.bb b/meta-gnome/recipes-support/ibus/ibus.bb
index 7156081499..141341e341 100644
--- a/meta-gnome/recipes-support/ibus/ibus.bb
+++ b/meta-gnome/recipes-support/ibus/ibus.bb
@@ -38,4 +38,4 @@  FILES:${PN} += " \
 FILES:${PN}-dev += " \
     ${datadir}/gettext \
 "
-
+RDEPENDS:${PN} += "python3-core"
diff --git a/meta-gnome/recipes-support/ibus/ibus.inc b/meta-gnome/recipes-support/ibus/ibus.inc
index bb662f2ec9..9579404b3e 100644
--- a/meta-gnome/recipes-support/ibus/ibus.inc
+++ b/meta-gnome/recipes-support/ibus/ibus.inc
@@ -31,6 +31,9 @@  EXTRA_OECONF = " \
     --disable-emoji-dict \
     --disable-python2 \
 "
+EXTRA_OECONF:append:class-target = "\
+    --with-python=${bindir}/python3 \
+"
 
 do_configure:prepend() {
     touch ${S}/ChangeLog