diff mbox series

[patchtest,02/11] python3-isort: upgrade 4.2.15 -> 5.12.0

Message ID 20230517202244.1612047-3-tgamblin@baylibre.com
State New
Headers show
Series patchtest: layer updates | expand

Commit Message

Trevor Gamblin May 17, 2023, 8:22 p.m. UTC
Copy the recipe from meta-python to handle the upgrade, so that
patchtest can build it without requiring the layer.

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 .../python/python3-isort_4.2.15.bb            | 10 ----------
 .../python/python3-isort_5.12.0.bb            | 20 +++++++++++++++++++
 2 files changed, 20 insertions(+), 10 deletions(-)
 delete mode 100644 meta-patchtest/recipes-devtools/python/python3-isort_4.2.15.bb
 create mode 100644 meta-patchtest/recipes-devtools/python/python3-isort_5.12.0.bb
diff mbox series

Patch

diff --git a/meta-patchtest/recipes-devtools/python/python3-isort_4.2.15.bb b/meta-patchtest/recipes-devtools/python/python3-isort_4.2.15.bb
deleted file mode 100644
index fc98e7c..0000000
--- a/meta-patchtest/recipes-devtools/python/python3-isort_4.2.15.bb
+++ /dev/null
@@ -1,10 +0,0 @@ 
-SUMMARY = "A Python utility / library to sort Python imports."
-HOMEPAGE = "https://pypi.python.org/pypi/isort"
-LICENSE = "MIT"
-SECTION = "devel/python"
-LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
-
-SRC_URI[md5sum] = "34915a2ce60e6fe3dbcbf5982deef9b4"
-SRC_URI[sha256sum] = "79f46172d3a4e2e53e7016e663cc7a8b538bec525c36675fcfd2767df30b3983"
-
-inherit pypi setuptools3
diff --git a/meta-patchtest/recipes-devtools/python/python3-isort_5.12.0.bb b/meta-patchtest/recipes-devtools/python/python3-isort_5.12.0.bb
new file mode 100644
index 0000000..6d7b20f
--- /dev/null
+++ b/meta-patchtest/recipes-devtools/python/python3-isort_5.12.0.bb
@@ -0,0 +1,20 @@ 
+SUMMARY = "A Python utility / library to sort Python imports."
+HOMEPAGE = "https://pypi.python.org/pypi/isort"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=6;endline=6;md5=8227180126797a0148f94f483f3e1489"
+
+SRC_URI[sha256sum] = "8bef7dde241278824a6d83f44a544709b065191b95b6e50894bdc722fcba0504"
+
+inherit pypi python_poetry_core
+
+RDEPENDS:${PN} += "\
+    ${PYTHON_PN}-datetime \
+    ${PYTHON_PN}-shell \
+    ${PYTHON_PN}-profile \
+    ${PYTHON_PN}-numbers \
+    ${PYTHON_PN}-pprint \
+    ${PYTHON_PN}-difflib \
+"
+
+BBCLASSEXTEND = "native nativesdk"