diff mbox series

[01/11] python3-astroid: upgrade 1.5.3 -> 2.15.4

Message ID 20230517201456.1608917-2-tgamblin@baylibre.com
State New
Headers show
Series patchtest: layer updates | expand

Commit Message

Trevor Gamblin May 17, 2023, 8:14 p.m. UTC
Copy the recipe from meta-python to handle the upgrade, so that
patchtest can build it without needing that layer.

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 .../python/python3-astroid_1.5.3.bb           | 20 -----------
 .../python/python3-astroid_2.15.4.bb          | 35 +++++++++++++++++++
 2 files changed, 35 insertions(+), 20 deletions(-)
 delete mode 100644 meta-patchtest/recipes-devtools/python/python3-astroid_1.5.3.bb
 create mode 100644 meta-patchtest/recipes-devtools/python/python3-astroid_2.15.4.bb
diff mbox series

Patch

diff --git a/meta-patchtest/recipes-devtools/python/python3-astroid_1.5.3.bb b/meta-patchtest/recipes-devtools/python/python3-astroid_1.5.3.bb
deleted file mode 100644
index 104038a..0000000
--- a/meta-patchtest/recipes-devtools/python/python3-astroid_1.5.3.bb
+++ /dev/null
@@ -1,20 +0,0 @@ 
-SUMMARY = "An abstract syntax tree for Python with inference support."
-HOMEPAGE = "https://pypi.python.org/pypi/astroid"
-SECTION = "devel/python"
-LICENSE = "LGPL"
-LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
-
-SRC_URI[md5sum] = "6f65e4ea8290ec032320460905afb828"
-SRC_URI[sha256sum] = "492c2a2044adbf6a84a671b7522e9295ad2f6a7c781b899014308db25312dd35"
-
-inherit pypi setuptools3
-
-RDEPENDS_${PN}_class-target += "\
-    ${PYTHON_PN}-distutils \
-    ${PYTHON_PN}-lazy-object-proxy \
-    ${PYTHON_PN}-six \
-    ${PYTHON_PN}-subprocess \
-    ${PYTHON_PN}-wrapt \
-    ${PYTHON_PN}-re \
-    ${PYTHON_PN}-setuptools \
-"
diff --git a/meta-patchtest/recipes-devtools/python/python3-astroid_2.15.4.bb b/meta-patchtest/recipes-devtools/python/python3-astroid_2.15.4.bb
new file mode 100644
index 0000000..6053728
--- /dev/null
+++ b/meta-patchtest/recipes-devtools/python/python3-astroid_2.15.4.bb
@@ -0,0 +1,35 @@ 
+SUMMARY = "An abstract syntax tree for Python with inference support."
+HOMEPAGE = "https://pypi.python.org/pypi/astroid"
+SECTION = "devel/python"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a70cf540abf41acb644ac3b621b2fad1"
+
+SRC_URI[sha256sum] = "c81e1c7fbac615037744d067a9bb5f9aeb655edf59b63ee8b59585475d6f80d8"
+
+inherit pypi python_setuptools_build_meta
+
+DEPENDS += "\
+    ${PYTHON_PN}-pytest-runner-native \
+    ${PYTHON_PN}-wheel-native \
+"
+
+PACKAGES =+ "${PN}-tests"
+
+FILES:${PN}-tests += " \
+    ${PYTHON_SITEPACKAGES_DIR}/astroid/test* \
+    ${PYTHON_SITEPACKAGES_DIR}/astroid/__pycache__/test* \
+"
+
+RDEPENDS:${PN}:class-target += "\
+    ${PYTHON_PN}-distutils \
+    ${PYTHON_PN}-lazy-object-proxy \
+    ${PYTHON_PN}-logging \
+    ${PYTHON_PN}-six \
+    ${PYTHON_PN}-wrapt \
+    ${PYTHON_PN}-setuptools \
+"
+
+RDEPENDS:${PN}-tests:class-target += "\
+    ${PYTHON_PN}-unittest \
+    ${PYTHON_PN}-xml \
+"