diff mbox series

[06/20] python3-libfdt: new package

Message ID 20230517080639.9336-7-brgl@bgdev.pl
State New
Headers show
Series python3: fix run-time dependencies | expand

Commit Message

Bartosz Golaszewski May 17, 2023, 8:06 a.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

Add a recipe for python bindings for libfdt (spun out of upstream dtc)
fetched from pypi.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 .../python/python3-libfdt_1.7.0.post1.bb      | 20 +++++++++++++++++++
 1 file changed, 20 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb

Comments

Trevor Gamblin May 17, 2023, 4:16 p.m. UTC | #1
On 2023-05-17 04:06, Bartosz Golaszewski wrote:
> From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
>
> Add a recipe for python bindings for libfdt (spun out of upstream dtc)
> fetched from pypi.
>
> Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> ---
>   .../python/python3-libfdt_1.7.0.post1.bb      | 20 +++++++++++++++++++
>   1 file changed, 20 insertions(+)
>   create mode 100644 meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb
>
> diff --git a/meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb b/meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb
> new file mode 100644
> index 0000000000..1ff3decbb9
> --- /dev/null
> +++ b/meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb
> @@ -0,0 +1,20 @@
> +SUMMARY = "Python bindings for libfdt."
> +LICENSE = "GPL-2.0-only | BSD-2-Clause"
> +LIC_FILES_CHKSUM = " \
> +    file://BSD-2-Clause;md5=5d6306d1b08f8df623178dfd81880927 \
> +    file://GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
> +"
> +
> +inherit pypi setuptools3
> +
> +PYPI_PACKAGE = "pylibfdt"
> +
> +SRC_URI[sha256sum] = "2d048f9f8ce9a0527d497f423dea1f1135f9811c05b009cc5d5753771c1f9ba1"
> +
> +BBCLASSEXTEND = "native nativesdk"
> +
> +DEPENDS += " \
> +    python3-pip-native \
> +    python3-setuptools-scm-native \
> +    swig-native \
> +"
Can you also add this recipe to the 
meta/conf/distro/include/maintainers.inc file?
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#181455): https://lists.openembedded.org/g/openembedded-core/message/181455
> Mute This Topic: https://lists.openembedded.org/mt/98944002/7611679
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [tgamblin@baylibre.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Bruce Ashfield May 17, 2023, 4:32 p.m. UTC | #2
I'm not sure if you saw the old threads on this, but we went through this
binding in detail in february:

See the series from TrevorW:

[PATCH v3 1/4] dtc: version bump and add python wrapper

The pypi releases of libfdt bindings are not kept in sync with the dtc
releases and rarely update. Not that they change a lot, but that is
still the case.

The suggestion for the bindings is the same, they'd be better of built
from dtc, versus using pypi.

There may be some issues remaining with the build, as Trevor hasn't
updated his series in a while now.

Bruce


On Wed, May 17, 2023 at 4:06 AM Bartosz Golaszewski <brgl@bgdev.pl> wrote:
>
> From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
>
> Add a recipe for python bindings for libfdt (spun out of upstream dtc)
> fetched from pypi.
>
> Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> ---
>  .../python/python3-libfdt_1.7.0.post1.bb      | 20 +++++++++++++++++++
>  1 file changed, 20 insertions(+)
>  create mode 100644 meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb
>
> diff --git a/meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb b/meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb
> new file mode 100644
> index 0000000000..1ff3decbb9
> --- /dev/null
> +++ b/meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb
> @@ -0,0 +1,20 @@
> +SUMMARY = "Python bindings for libfdt."
> +LICENSE = "GPL-2.0-only | BSD-2-Clause"
> +LIC_FILES_CHKSUM = " \
> +    file://BSD-2-Clause;md5=5d6306d1b08f8df623178dfd81880927 \
> +    file://GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
> +"
> +
> +inherit pypi setuptools3
> +
> +PYPI_PACKAGE = "pylibfdt"
> +
> +SRC_URI[sha256sum] = "2d048f9f8ce9a0527d497f423dea1f1135f9811c05b009cc5d5753771c1f9ba1"
> +
> +BBCLASSEXTEND = "native nativesdk"
> +
> +DEPENDS += " \
> +    python3-pip-native \
> +    python3-setuptools-scm-native \
> +    swig-native \
> +"
> --
> 2.39.2
>


--
- Thou shalt not follow the NULL pointer, for chaos and madness await
thee at its end
- "Use the force Harry" - Gandalf, Star Trek II
Alexandre Belloni May 18, 2023, 3:17 p.m. UTC | #3
On 17/05/2023 12:16:21-0400, Trevor Gamblin wrote:
> 
> On 2023-05-17 04:06, Bartosz Golaszewski wrote:
> > From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> > 
> > Add a recipe for python bindings for libfdt (spun out of upstream dtc)
> > fetched from pypi.
> > 
> > Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> > ---
> >   .../python/python3-libfdt_1.7.0.post1.bb      | 20 +++++++++++++++++++
> >   1 file changed, 20 insertions(+)
> >   create mode 100644 meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb
> > 
> > diff --git a/meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb b/meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb
> > new file mode 100644
> > index 0000000000..1ff3decbb9
> > --- /dev/null
> > +++ b/meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb
> > @@ -0,0 +1,20 @@
> > +SUMMARY = "Python bindings for libfdt."
> > +LICENSE = "GPL-2.0-only | BSD-2-Clause"
> > +LIC_FILES_CHKSUM = " \
> > +    file://BSD-2-Clause;md5=5d6306d1b08f8df623178dfd81880927 \
> > +    file://GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
> > +"
> > +
> > +inherit pypi setuptools3
> > +
> > +PYPI_PACKAGE = "pylibfdt"
> > +
> > +SRC_URI[sha256sum] = "2d048f9f8ce9a0527d497f423dea1f1135f9811c05b009cc5d5753771c1f9ba1"
> > +
> > +BBCLASSEXTEND = "native nativesdk"
> > +
> > +DEPENDS += " \
> > +    python3-pip-native \
> > +    python3-setuptools-scm-native \
> > +    swig-native \
> > +"
> Can you also add this recipe to the meta/conf/distro/include/maintainers.inc
> file?

As stated, this fails on the autobuilders:

The following recipes do not have a maintainer assigned to them. Please add an entry to meta/conf/distro/include/maintainers.inc file.
python3-libfdt (/home/pokybuild/yocto-worker/oe-selftest-ubuntu/build/meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb)

I also got this:

stdio: WARNING: python3-libfdt-1.7.0.post1-r0 do_fetch: QA Issue: Recipe python3-libfdt in /home/pokybuild/yocto-worker/a-full/build/meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb does not contain a HOMEPAGE. Please add an entry. [missing-metadata]
stdio: WARNING: python3-libfdt-1.7.0.post1-r0 do_fetch: QA Issue: Recipe python3-libfdt in /home/pokybuild/yocto-worker/a-full/build/meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb does not have an assigned maintainer. Please add an entry into meta/conf/distro/include/maintainers.inc. [missing-metadata]
stdio: WARNING: python3-libfdt-native-1.7.0.post1-r0 do_fetch: QA Issue: Recipe python3-libfdt in /home/pokybuild/yocto-worker/a-full/build/meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb does not contain a HOMEPAGE. Please add an entry. [missing-metadata]
stdio: WARNING: nativesdk-python3-libfdt-1.7.0.post1-r0 do_fetch: QA Issue: Recipe python3-libfdt in /home/pokybuild/yocto-worker/a-full/build/meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb does not contain a HOMEPAGE. Please add an entry. [missing-metadata]
Ross Burton May 18, 2023, 4:56 p.m. UTC | #4
> On 17 May 2023, at 17:32, Bruce Ashfield via lists.openembedded.org <bruce.ashfield=gmail.com@lists.openembedded.org> wrote:
> 
> I'm not sure if you saw the old threads on this, but we went through this
> binding in detail in february:
> 
> See the series from TrevorW:
> 
> [PATCH v3 1/4] dtc: version bump and add python wrapper
> 
> The pypi releases of libfdt bindings are not kept in sync with the dtc
> releases and rarely update. Not that they change a lot, but that is
> still the case.
> 
> The suggestion for the bindings is the same, they'd be better of built
> from dtc, versus using pypi.
> 
> There may be some issues remaining with the build, as Trevor hasn't
> updated his series in a while now.

Agreed - that series needs to be resurrected as it’s the canonical source of the bindings.

Ross
Bartosz Golaszewski May 19, 2023, 11:37 a.m. UTC | #5
On Thu, May 18, 2023 at 6:56 PM Ross Burton <ross.burton@arm.com> wrote:
>
>
>
> > On 17 May 2023, at 17:32, Bruce Ashfield via lists.openembedded.org <bruce.ashfield=gmail.com@lists.openembedded.org> wrote:
> >
> > I'm not sure if you saw the old threads on this, but we went through this
> > binding in detail in february:
> >
> > See the series from TrevorW:
> >
> > [PATCH v3 1/4] dtc: version bump and add python wrapper
> >
> > The pypi releases of libfdt bindings are not kept in sync with the dtc
> > releases and rarely update. Not that they change a lot, but that is
> > still the case.
> >
> > The suggestion for the bindings is the same, they'd be better of built
> > from dtc, versus using pypi.
> >
> > There may be some issues remaining with the build, as Trevor hasn't
> > updated his series in a while now.
>
> Agreed - that series needs to be resurrected as it’s the canonical source of the bindings.
>
> Ross
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#181527): https://lists.openembedded.org/g/openembedded-core/message/181527
> Mute This Topic: https://lists.openembedded.org/mt/98944002/3618139
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [brgl@bgdev.pl]
> -=-=-=-=-=-=-=-=-=-=-=-
>

In this case I propose to just drop patches 06/20 and 07/20 from this
series for now when applying.

Bart
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb b/meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb
new file mode 100644
index 0000000000..1ff3decbb9
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-libfdt_1.7.0.post1.bb
@@ -0,0 +1,20 @@ 
+SUMMARY = "Python bindings for libfdt."
+LICENSE = "GPL-2.0-only | BSD-2-Clause"
+LIC_FILES_CHKSUM = " \
+    file://BSD-2-Clause;md5=5d6306d1b08f8df623178dfd81880927 \
+    file://GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "pylibfdt"
+
+SRC_URI[sha256sum] = "2d048f9f8ce9a0527d497f423dea1f1135f9811c05b009cc5d5753771c1f9ba1"
+
+BBCLASSEXTEND = "native nativesdk"
+
+DEPENDS += " \
+    python3-pip-native \
+    python3-setuptools-scm-native \
+    swig-native \
+"