diff mbox series

[meta-networking] squid: Remove buildpaths from generated binaries

Message ID 20230514222750.768716-1-raj.khem@gmail.com
State New
Headers show
Series [meta-networking] squid: Remove buildpaths from generated binaries | expand

Commit Message

Khem Raj May 14, 2023, 10:27 p.m. UTC
Compiler invocation and flags are added to SQUID_CONFIGURE_OPTIONS which
is added via generated autoconf.h during configure step. Since OE
encodes sysroot and buildpaths for cross compile, they end up in squid
binary, this patch removes from workdir from them so avoid encoding
build workspace path

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-networking/recipes-daemons/squid/squid_5.7.bb | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/meta-networking/recipes-daemons/squid/squid_5.7.bb b/meta-networking/recipes-daemons/squid/squid_5.7.bb
index a208a2a88f..2a5de1872d 100644
--- a/meta-networking/recipes-daemons/squid/squid_5.7.bb
+++ b/meta-networking/recipes-daemons/squid/squid_5.7.bb
@@ -69,6 +69,10 @@  do_configure:prepend() {
     export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
 }
 
+do_configure:append() {
+   sed -i -e 's|${WORKDIR}||g' ${B}/include/autoconf.h
+}
+
 do_compile_ptest() {
     oe_runmake -C ${TESTDIR} buildtest-TESTS
 }