diff mbox series

[v4,2/4] libtraceevent: fix qa issue reference to tmpdir

Message ID 20230511232214.993328-3-max.oss.09@gmail.com
State Accepted, archived
Commit bb5cffd48513f05bc66c20e91a25e13d3ba1555c
Headers show
Series perf: add libtraceevent packageconfig | expand

Commit Message

Max Krummenacher May 11, 2023, 11:22 p.m. UTC
From: Max Krummenacher <max.krummenacher@toradex.com>

Make sure that the OE provided CFLAGS are passed to the compiler so
that the -fdebug-prefix-map and -fmacro-prefix-map options are
actually active.

Fixes:
| WARNING: libtraceevent-1.7.2-r0 do_package_qa: QA Issue: File /usr/lib/libtraceevent.a in package libtraceevent-staticdev contains reference to TMPDIR [buildpaths]
| WARNING: libtraceevent-1.7.2-r0 do_package_qa: QA Issue: File /usr/lib/.debug/libtraceevent.so.1.7.2 in package libtraceevent-dbg contains reference to TMPDIR [buildpaths]

Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
---
 meta/recipes-kernel/libtraceevent/libtraceevent_1.7.2.bb | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-kernel/libtraceevent/libtraceevent_1.7.2.bb b/meta/recipes-kernel/libtraceevent/libtraceevent_1.7.2.bb
index 089b6814c7..b5c0834d89 100644
--- a/meta/recipes-kernel/libtraceevent/libtraceevent_1.7.2.bb
+++ b/meta/recipes-kernel/libtraceevent/libtraceevent_1.7.2.bb
@@ -14,6 +14,8 @@  SRC_URI = "git://git.kernel.org/pub/scm/libs/libtrace/libtraceevent.git;branch=$
 
 S = "${WORKDIR}/git"
 
+export EXTRA_CFLAGS = "${CFLAGS}"
+
 inherit pkgconfig
 
 do_install() {