diff mbox series

[meta-oe,mickledore,13/16] libtomcrypt: pass LIBPATH to fix installed-vs-shipped with multilib

Message ID 20230509070655.70784-13-Martin.Jansa@gmail.com
State New
Headers show
Series [meta-oe,mickledore,01/16] lirc: fix do_install with multilib | expand

Commit Message

Martin Jansa May 9, 2023, 7:06 a.m. UTC
* fixes:
  ERROR: QA Issue: libtomcrypt: Files/directories were installed but not shipped in any package:
    /usr/lib
    /usr/lib/libtomcrypt.so.1.0.1
    /usr/lib/libtomcrypt.so.1
    /usr/lib/libtomcrypt.so
    /usr/lib/pkgconfig
    /usr/lib/pkgconfig/libtomcrypt.pc
  Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
  libtomcrypt: 6 installed and not shipped files. [installed-vs-shipped]

  when libdir is /usr/lib64 with multilib

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
 meta-oe/recipes-crypto/libtomcrypt/libtomcrypt_1.18.2.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-crypto/libtomcrypt/libtomcrypt_1.18.2.bb b/meta-oe/recipes-crypto/libtomcrypt/libtomcrypt_1.18.2.bb
index 357fd0ab8d..b144338921 100644
--- a/meta-oe/recipes-crypto/libtomcrypt/libtomcrypt_1.18.2.bb
+++ b/meta-oe/recipes-crypto/libtomcrypt/libtomcrypt_1.18.2.bb
@@ -17,5 +17,5 @@  do_compile() {
 }
 
 do_install() {
-    oe_runmake -f makefile.shared 'PREFIX=${prefix}' 'DESTDIR=${D}' install
+    oe_runmake -f makefile.shared 'PREFIX=${prefix}' 'DESTDIR=${D}' 'LIBPATH=${libdir}' install
 }