systemd: Avoid a Python deprecation warning

Message ID 20220113031850.3350-1-pkj@axis.com
State Accepted, archived
Commit 427ca80eb4ea6c607b00028adcc9302e29db1368
Headers show
Series systemd: Avoid a Python deprecation warning | expand

Commit Message

Peter Kjellerstedt Jan. 13, 2022, 3:18 a.m. UTC
This avoids the following warning:

  WARNING: .../meta/recipes-core/systemd/systemd_250.1.bb: Var
  <do_install>:1: DeprecationWarning: invalid escape sequence \$

seen when doing `devtool finish --force-patch-refresh systemd meta`.

Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
---

I have no idea why the warning is only seen when doing `devtool 
finish`...

 meta/recipes-core/systemd/systemd_250.1.bb | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Patch

diff --git a/meta/recipes-core/systemd/systemd_250.1.bb b/meta/recipes-core/systemd/systemd_250.1.bb
index b05905b764..4dd668833a 100644
--- a/meta/recipes-core/systemd/systemd_250.1.bb
+++ b/meta/recipes-core/systemd/systemd_250.1.bb
@@ -297,8 +297,9 @@  do_install() {
 
 	# this file is needed to exist if networkd is disabled but timesyncd is still in use since timesyncd checks it
 	# for existence else it fails
-	if [ -s ${D}${exec_prefix}/lib/tmpfiles.d/systemd.conf ]; then
-		${@bb.utils.contains('PACKAGECONFIG', 'networkd', ':', 'sed -i -e "\$ad /run/systemd/netif/links 0755 root root -" ${D}${exec_prefix}/lib/tmpfiles.d/systemd.conf', d)}
+	if [ -s ${D}${exec_prefix}/lib/tmpfiles.d/systemd.conf ] &&
+	   ! ${@bb.utils.contains('PACKAGECONFIG', 'networkd', 'true', 'false', d)}; then
+		echo 'd /run/systemd/netif/links 0755 root root -' >>${D}${exec_prefix}/lib/tmpfiles.d/systemd.conf
 	fi
 	if ! ${@bb.utils.contains('PACKAGECONFIG', 'resolved', 'true', 'false', d)}; then
 		echo 'L! ${sysconfdir}/resolv.conf - - - - ../run/systemd/resolve/resolv.conf' >>${D}${exec_prefix}/lib/tmpfiles.d/etc.conf