diff mbox series

[meta-oe,5/5] lvgl: Upgrade lvgl-demo-fb to 8.3 and decouple from submodules

Message ID 20230507132349.10674-5-marex@denx.de
State Under Review
Headers show
Series [meta-oe,1/5] lvgl: Upgrade lvgl to 8.3.7 and lv-driver to 8.3.0 | expand

Commit Message

Marek Vasut May 7, 2023, 1:23 p.m. UTC
The lvgl-demo-fb really contains its own copy of lvgl and lv-drivers,
for which meta-openembedded already contains its own recipes. Stop
pulling those as git submodules and instead only pull the example
application, and compile it against the lvgl and lv-drivers from
local recipes.

Upgrade the lvgl-demo-fb to 8.3.0 to match the lvgl and lv-drivers too.

Signed-off-by: Marek Vasut <marex@denx.de>
---
Cc: Fabio Estevam <festevam@denx.de>
Cc: Khem Raj <raj.khem@gmail.com>
Cc: Martin Jansa <martin.jansa@gmail.com>
Cc: Philippe Coval <philippe.coval.ext@huawei.com>
Cc: Philippe Coval <philippe.coval@huawei.com>
---
 .../lvgl/{lvgl-demo-fb.bb => lvgl-demo-fb_8.3.0.bb}         | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)
 rename meta-oe/recipes-graphics/lvgl/{lvgl-demo-fb.bb => lvgl-demo-fb_8.3.0.bb} (72%)

Comments

Khem Raj May 8, 2023, 4:13 p.m. UTC | #1
there is license mismatch perhaps as seen in this build

https://autobuilder.yoctoproject.org/typhoon/#/builders/88/builds/2727

On Sun, May 7, 2023 at 6:24 AM Marek Vasut <marex@denx.de> wrote:
>
> The lvgl-demo-fb really contains its own copy of lvgl and lv-drivers,
> for which meta-openembedded already contains its own recipes. Stop
> pulling those as git submodules and instead only pull the example
> application, and compile it against the lvgl and lv-drivers from
> local recipes.
>
> Upgrade the lvgl-demo-fb to 8.3.0 to match the lvgl and lv-drivers too.
>
> Signed-off-by: Marek Vasut <marex@denx.de>
> ---
> Cc: Fabio Estevam <festevam@denx.de>
> Cc: Khem Raj <raj.khem@gmail.com>
> Cc: Martin Jansa <martin.jansa@gmail.com>
> Cc: Philippe Coval <philippe.coval.ext@huawei.com>
> Cc: Philippe Coval <philippe.coval@huawei.com>
> ---
>  .../lvgl/{lvgl-demo-fb.bb => lvgl-demo-fb_8.3.0.bb}         | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)
>  rename meta-oe/recipes-graphics/lvgl/{lvgl-demo-fb.bb => lvgl-demo-fb_8.3.0.bb} (72%)
>
> diff --git a/meta-oe/recipes-graphics/lvgl/lvgl-demo-fb.bb b/meta-oe/recipes-graphics/lvgl/lvgl-demo-fb_8.3.0.bb
> similarity index 72%
> rename from meta-oe/recipes-graphics/lvgl/lvgl-demo-fb.bb
> rename to meta-oe/recipes-graphics/lvgl/lvgl-demo-fb_8.3.0.bb
> index 3430c2491..6d9ff89f5 100644
> --- a/meta-oe/recipes-graphics/lvgl/lvgl-demo-fb.bb
> +++ b/meta-oe/recipes-graphics/lvgl/lvgl-demo-fb_8.3.0.bb
> @@ -5,8 +5,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=802d3d83ae80ef5f343050bf96cce3a4 \
>                      file://lv_drivers/LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2 \
>                      file://lvgl/LICENCE.txt;md5=bf1198c89ae87f043108cea62460b03a"
>
> -SRC_URI = "gitsm://github.com/lvgl/lv_port_linux_frame_buffer.git;branch=master;protocol=https"
> -SRCREV = "dd010430b959f40b8f25a51c76bc920cbc2550cc"
> +DEPENDS = "lvgl lv-drivers"
> +
> +SRC_URI = "git://github.com/lvgl/lv_port_linux_frame_buffer.git;branch=master;protocol=https"
> +SRCREV = "adf2c4490e17a1b9ec1902cc412a24b3b8235c8e"
>
>  S = "${WORKDIR}/git"
>
> --
> 2.39.2
>
Marek Vasut May 9, 2023, 2:02 a.m. UTC | #2
On 5/8/23 18:13, Khem Raj wrote:
> there is license mismatch perhaps as seen in this build
> 
> https://autobuilder.yoctoproject.org/typhoon/#/builders/88/builds/2727

I just sent a bunch of additional patches, sorry for the mess.

I managed to fix the dialog-lvgl , but that code seems unmaintained, so 
maybe we should drop it.

I partly rolled back the lvgl-demo-fb switch away from submodules, as I 
don't really know how to deal with this one quickly. It basically 
requires custom configuration of LVGL only for the sake of pulling in 
example widgets, which used to be in (now unmaintained) repo, but now 
are in LVGL proper, except they need to be enabled and built in, which 
for regular LVGL applications seem like the wrong default.
diff mbox series

Patch

diff --git a/meta-oe/recipes-graphics/lvgl/lvgl-demo-fb.bb b/meta-oe/recipes-graphics/lvgl/lvgl-demo-fb_8.3.0.bb
similarity index 72%
rename from meta-oe/recipes-graphics/lvgl/lvgl-demo-fb.bb
rename to meta-oe/recipes-graphics/lvgl/lvgl-demo-fb_8.3.0.bb
index 3430c2491..6d9ff89f5 100644
--- a/meta-oe/recipes-graphics/lvgl/lvgl-demo-fb.bb
+++ b/meta-oe/recipes-graphics/lvgl/lvgl-demo-fb_8.3.0.bb
@@ -5,8 +5,10 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=802d3d83ae80ef5f343050bf96cce3a4 \
                     file://lv_drivers/LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2 \
                     file://lvgl/LICENCE.txt;md5=bf1198c89ae87f043108cea62460b03a"
 
-SRC_URI = "gitsm://github.com/lvgl/lv_port_linux_frame_buffer.git;branch=master;protocol=https"
-SRCREV = "dd010430b959f40b8f25a51c76bc920cbc2550cc"
+DEPENDS = "lvgl lv-drivers"
+
+SRC_URI = "git://github.com/lvgl/lv_port_linux_frame_buffer.git;branch=master;protocol=https"
+SRCREV = "adf2c4490e17a1b9ec1902cc412a24b3b8235c8e"
 
 S = "${WORKDIR}/git"