diff mbox series

[2/3] python3: clean up PACKAGECONFIG

Message ID 20230505132144.2951723-2-ross.burton@arm.com
State Accepted, archived
Commit 52232f8a6afef20ff4ef70367ecce74043210a46
Headers show
Series [1/3] python3: use libedit instead of readline | expand

Commit Message

Ross Burton May 5, 2023, 1:21 p.m. UTC
From: Ross Burton <ross.burton@arm.com>

There's no need to define the PACKAGECONFIG for each class when they're
all identical (as native DISTRO_FEATURES are pruned before use).

Also add a disabled case to the LTO configuration to be explicit.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-devtools/python/python3_3.11.2.bb | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3_3.11.2.bb b/meta/recipes-devtools/python/python3_3.11.2.bb
index 4a9aa9306bc..810f0c2e009 100644
--- a/meta/recipes-devtools/python/python3_3.11.2.bb
+++ b/meta/recipes-devtools/python/python3_3.11.2.bb
@@ -95,9 +95,7 @@  CACHED_CONFIGUREVARS = " \
 "
 
 # PGO currently causes builds to not be reproducible so disable by default, see YOCTO #13407
-PACKAGECONFIG:class-target ??= "editline gdbm ${@bb.utils.filter('DISTRO_FEATURES', 'lto', d)}"
-PACKAGECONFIG:class-native ??= "editline gdbm"
-PACKAGECONFIG:class-nativesdk ??= "readline gdbm"
+PACKAGECONFIG ??= "editline gdbm ${@bb.utils.filter('DISTRO_FEATURES', 'lto', d)}"
 PACKAGECONFIG[readline] = "--with-readline=readline,,readline,,,editline"
 PACKAGECONFIG[editline] = "--with-readline=editline,,libedit,,,readline"
 # Use profile guided optimisation by running PyBench inside qemu-user
@@ -105,7 +103,7 @@  PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native"
 PACKAGECONFIG[tk] = ",,tk"
 PACKAGECONFIG[tcl] = ",,tcl"
 PACKAGECONFIG[gdbm] = ",,gdbm"
-PACKAGECONFIG[lto] = "--with-lto,,"
+PACKAGECONFIG[lto] = "--with-lto,--without-lto"
 
 do_configure:prepend () {
     mkdir -p ${B}/Modules