diff mbox series

[1/3] python3: use libedit instead of readline

Message ID 20230505132144.2951723-1-ross.burton@arm.com
State Accepted, archived
Commit 685df78325435db2d67ceb1a96839e0adbb568d0
Headers show
Series [1/3] python3: use libedit instead of readline | expand

Commit Message

Ross Burton May 5, 2023, 1:21 p.m. UTC
From: Ross Burton <ross.burton@arm.com>

libedit has feature parity with readline but is more permissively
licensed (BSD verses GPLv3), so switch to libedit by default.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-devtools/python/python3_3.11.2.bb | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3_3.11.2.bb b/meta/recipes-devtools/python/python3_3.11.2.bb
index 5bd8d32b140..4a9aa9306bc 100644
--- a/meta/recipes-devtools/python/python3_3.11.2.bb
+++ b/meta/recipes-devtools/python/python3_3.11.2.bb
@@ -95,10 +95,10 @@  CACHED_CONFIGUREVARS = " \
 "
 
 # PGO currently causes builds to not be reproducible so disable by default, see YOCTO #13407
-PACKAGECONFIG:class-target ??= "readline gdbm ${@bb.utils.filter('DISTRO_FEATURES', 'lto', d)}"
-PACKAGECONFIG:class-native ??= "readline gdbm"
+PACKAGECONFIG:class-target ??= "editline gdbm ${@bb.utils.filter('DISTRO_FEATURES', 'lto', d)}"
+PACKAGECONFIG:class-native ??= "editline gdbm"
 PACKAGECONFIG:class-nativesdk ??= "readline gdbm"
-PACKAGECONFIG[readline] = ",,readline"
+PACKAGECONFIG[readline] = "--with-readline=readline,,readline,,,editline"
 PACKAGECONFIG[editline] = "--with-readline=editline,,libedit,,,readline"
 # Use profile guided optimisation by running PyBench inside qemu-user
 PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native"