diff mbox series

[meta-oe,5/7] ostree: fix build without gobject-introspection-data

Message ID 20230503172354.1439352-5-Martin.Jansa@gmail.com
State Under Review
Headers show
Series [meta-oe,1/7] libreport: add dependency on libarchive | expand

Commit Message

Martin Jansa May 3, 2023, 5:23 p.m. UTC
* add --disable-introspection to UNKNOWN_CONFIGURE_OPT_IGNORE to fix:
  http://errors.yoctoproject.org/Errors/Details/702779/
  ERROR: QA Issue: ostree: configure was passed unrecognised options: --disable-introspection [unknown-configure-option]

* add glib-2.0-native to DEPENDS to fix:
  http://errors.yoctoproject.org/Errors/Details/702787/
  glib-mkenums \
    --template ../libostree-2023.2/src/libostree/ostree-enumtypes.h.template \
    ../libostree-2023.2/src/libostree/ostree-fetcher.h > src/libostree/ostree-enumtypes.h.tmp && mv src/libostree/ostree-enumtypes.h.tmp src/libostree/ostree-enumtypes.h
  /bin/bash: line 2: glib-mkenums: command not found
  make: *** [Makefile:9990: src/libostree/ostree-enumtypes.h] Error 127

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
 meta-oe/recipes-extended/ostree/ostree_2023.2.bb | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/ostree/ostree_2023.2.bb b/meta-oe/recipes-extended/ostree/ostree_2023.2.bb
index 2990122959..7eeb77474f 100644
--- a/meta-oe/recipes-extended/ostree/ostree_2023.2.bb
+++ b/meta-oe/recipes-extended/ostree/ostree_2023.2.bb
@@ -9,6 +9,7 @@  LICENSE = "LGPL-2.1-only"
 LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
 
 DEPENDS = " \
+    glib-2.0-native \
     glib-2.0 \
     e2fsprogs \
     libcap \
@@ -28,6 +29,8 @@  S = "${WORKDIR}/libostree-${PV}"
 
 inherit autotools bash-completion gobject-introspection github-releases gtk-doc manpages pkgconfig ptest-gnome systemd
 
+UNKNOWN_CONFIGURE_OPT_IGNORE = "--disable-introspection --enable-introspection"
+
 # Workaround compile failure:
 # |../git/src/libotutil/zbase32.c:37:1: error: function returns an aggregate [-Werror=aggregate-return]
 # so remove -Og and use -O2 as workaround