diff mbox series

[meta-python,5/6] python3-pylint: add ptest

Message ID 20230502165005.880470-6-tgamblin@baylibre.com
State Under Review
Headers show
Series Support updated python3-pylint | expand

Commit Message

Trevor Gamblin May 2, 2023, 4:50 p.m. UTC
Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 ....toml-Remove-hard-coded-dependencies.patch | 10 ++-----
 .../python/python3-pylint/run-ptest           |  3 ++
 .../python/python3-pylint_2.17.3.bb           | 30 +++++++++++++++++--
 3 files changed, 32 insertions(+), 11 deletions(-)
 create mode 100644 meta-python/recipes-devtools/python/python3-pylint/run-ptest

Comments

Khem Raj May 4, 2023, 11:54 p.m. UTC | #1
The ptests fail on musl/qemux86-64

==============================================================================================================
Failed test cases (sorted by testseries, ID)
==============================================================================================================
--------------------------------------------------------------------------------------------------------------
testseries | result_id : oeqa |
runtime_meta-python-ptest-image-python3-pylint_qemux86-64_20230504233302
    ptestresult.python3-pylint.tests/benchmark/test_baseline_benchmarks.py::TestEstablishBaselineBenchmarks::test_baseline_benchmark_j1_all_checks_single_file
    ptestresult.python3-pylint.tests/config/pylint_config/test_pylint_config_generate.py::test_format_of_output
    ptestresult.python3-pylint.tests/config/pylint_config/test_pylint_config_generate.py::test_generate_interactive_exitcode
    ptestresult.python3-pylint.tests/config/pylint_config/test_pylint_config_generate.py::test_writing_minimal_file
    ptestresult.python3-pylint.tests/config/pylint_config/test_pylint_config_generate.py::test_writing_to_output_file
    ptestresult.python3-pylint.tests/test_check_parallel.py::TestCheckParallelFramework::test_linter_with_unpickleable_plugins_is_pickleable
    ptestresult.python3-pylint.tests/test_functional.py::test_functional[mccabe]
    ptestresult.python3-pylint.tests/test_functional.py::test_functional[missing_timeout]
    ptestresult.python3-pylint.tests/test_functional.py::test_functional[regression_3976]
    ptestresult.python3-pylint.tests/test_functional.py::test_functional[super_init_not_called_extensions_py310]
    ptestresult.python3-pylint.tests/test_functional.py::test_functional[typevar_naming_style_default]
    ptestresult.python3-pylint.tests/test_functional.py::test_functional[typevar_naming_style_rgx]
    ptestresult.python3-pylint.tests/test_functional.py::test_functional[typing_broken_noreturn]
    ptestresult.python3-pylint.tests/test_functional.py::test_functional[typing_broken_noreturn_future_import]
    ptestresult.python3-pylint.tests/test_functional.py::test_functional[typing_broken_noreturn_py372]
    ptestresult.python3-pylint.tests/test_functional.py::test_functional[undefined_loop_variable]
    ptestresult.python3-pylint.tests/test_self.py::TestCallbackOptions::test_generate_toml_config
    ptestresult.python3-pylint.tests/test_self.py::TestCallbackOptions::test_generate_toml_config_disable_symbolic_names
--------------------------------------------------------------------------------------------------------------

On Tue, May 2, 2023 at 9:50 AM Trevor Gamblin <tgamblin@baylibre.com> wrote:
>
> Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> ---
>  ....toml-Remove-hard-coded-dependencies.patch | 10 ++-----
>  .../python/python3-pylint/run-ptest           |  3 ++
>  .../python/python3-pylint_2.17.3.bb           | 30 +++++++++++++++++--
>  3 files changed, 32 insertions(+), 11 deletions(-)
>  create mode 100644 meta-python/recipes-devtools/python/python3-pylint/run-ptest
>
> diff --git a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch b/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
> index 55d42b101..267e4c30d 100644
> --- a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
> +++ b/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
> @@ -1,21 +1,15 @@
> -From 843d050f1bf889b81fa8fc3e7a1350385c8348ec Mon Sep 17 00:00:00 2001
> +From c5c415a240189ac6730ba95de0bb5883dfb53609 Mon Sep 17 00:00:00 2001
>  From: Trevor Gamblin <tgamblin@baylibre.com>
>  Date: Mon, 1 May 2023 11:32:24 -0400
>  Subject: [PATCH] pyproject.toml: Remove hard-coded dependencies
>
> -The upstream pyproject.toml has hard-coded dependencies on specific
> -versions of wheel and setuptools. This breaks builds of pylint
> -2.17.3, so patch it to remove the pinned versions.
> -
> -Upstream-Status: Pending
> -
>  Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
>  ---
>   pyproject.toml | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
>  diff --git a/pyproject.toml b/pyproject.toml
> -index e4b63c660..0ee21e0eb 100644
> +index bd542646b..2c0ed9485 100644
>  --- a/pyproject.toml
>  +++ b/pyproject.toml
>  @@ -1,5 +1,5 @@
> diff --git a/meta-python/recipes-devtools/python/python3-pylint/run-ptest b/meta-python/recipes-devtools/python/python3-pylint/run-ptest
> new file mode 100644
> index 000000000..b63c4de0d
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-pylint/run-ptest
> @@ -0,0 +1,3 @@
> +#!/bin/sh
> +
> +pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
> diff --git a/meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb b/meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb
> index b85f77503..58f0616fc 100644
> --- a/meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb
> +++ b/meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb
> @@ -3,10 +3,14 @@ HOMEPAGE= "http://www.pylint.org/"
>  LICENSE = "GPL-2.0-only"
>  LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9"
>
> -SRC_URI += "file://0001-pyproject.toml-Remove-hard-coded-dependencies.patch"
> -SRC_URI[sha256sum] = "761907349e699f8afdcd56c4fe02f3021ab5b3a0fc26d19a9bfdc66c7d0d5cd5"
> +SRC_URI += " \
> +        git://github.com/pylint-dev/pylint;branch=main;protocol=https \
> +        file://run-ptest \
> +        file://0001-pyproject.toml-Remove-hard-coded-dependencies.patch \
> +        "
> +SRCREV ?= "389e14c36819cb87190fd412d3f366a3283f0078"
>
> -inherit pypi python_setuptools_build_meta
> +inherit python_setuptools_build_meta ptest
>
>  RDEPENDS:${PN} += "${PYTHON_PN}-astroid \
>                     ${PYTHON_PN}-isort \
> @@ -17,3 +21,23 @@ RDEPENDS:${PN} += "${PYTHON_PN}-astroid \
>                     ${PYTHON_PN}-difflib \
>                     ${PYTHON_PN}-netserver \
>                    "
> +
> +RDEPENDS:${PN}-ptest += " \
> +        ${PYTHON_PN}-core \
> +        ${PYTHON_PN}-dill \
> +        ${PYTHON_PN}-git \
> +        ${PYTHON_PN}-platformdirs \
> +        ${PYTHON_PN}-pytest \
> +        ${PYTHON_PN}-pytest-benchmark \
> +        ${PYTHON_PN}-statistics \
> +        ${PYTHON_PN}-tomlkit \
> +        ${PYTHON_PN}-tomllib \
> +        "
> +
> +S = "${WORKDIR}/git"
> +
> +do_install_ptest() {
> +    install -d ${D}${PTEST_PATH}/tests
> +    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
> +    sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript
> +}
> --
> 2.40.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#102270): https://lists.openembedded.org/g/openembedded-devel/message/102270
> Mute This Topic: https://lists.openembedded.org/mt/98643295/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj May 5, 2023, 7:22 a.m. UTC | #2
this patch reduces the failure number but these remaining ones need to
be checked and see why they fail - http://sprunge.us/kfu3Ak

Failed ptests:
{'python3-pylint':
['tests/test_check_parallel.py::TestCheckParallelFramework::test_linter_with_unpickleable_plugins_is_pickleable',

'tests/test_self.py::TestCallbackOptions::test_generate_toml_config',

'tests/test_self.py::TestCallbackOptions::test_generate_toml_config_disable_symbolic_names',

'tests/config/pylint_config/test_pylint_config_generate.py::test_generate_interactive_exitcode',

'tests/config/pylint_config/test_pylint_config_generate.py::test_format_of_output',

'tests/config/pylint_config/test_pylint_config_generate.py::test_writing_to_output_file',

'tests/config/pylint_config/test_pylint_config_generate.py::test_writing_minimal_file']}

On Thu, May 4, 2023 at 4:54 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> The ptests fail on musl/qemux86-64
>
> ==============================================================================================================
> Failed test cases (sorted by testseries, ID)
> ==============================================================================================================
> --------------------------------------------------------------------------------------------------------------
> testseries | result_id : oeqa |
> runtime_meta-python-ptest-image-python3-pylint_qemux86-64_20230504233302
>     ptestresult.python3-pylint.tests/benchmark/test_baseline_benchmarks.py::TestEstablishBaselineBenchmarks::test_baseline_benchmark_j1_all_checks_single_file
>     ptestresult.python3-pylint.tests/config/pylint_config/test_pylint_config_generate.py::test_format_of_output
>     ptestresult.python3-pylint.tests/config/pylint_config/test_pylint_config_generate.py::test_generate_interactive_exitcode
>     ptestresult.python3-pylint.tests/config/pylint_config/test_pylint_config_generate.py::test_writing_minimal_file
>     ptestresult.python3-pylint.tests/config/pylint_config/test_pylint_config_generate.py::test_writing_to_output_file
>     ptestresult.python3-pylint.tests/test_check_parallel.py::TestCheckParallelFramework::test_linter_with_unpickleable_plugins_is_pickleable
>     ptestresult.python3-pylint.tests/test_functional.py::test_functional[mccabe]
>     ptestresult.python3-pylint.tests/test_functional.py::test_functional[missing_timeout]
>     ptestresult.python3-pylint.tests/test_functional.py::test_functional[regression_3976]
>     ptestresult.python3-pylint.tests/test_functional.py::test_functional[super_init_not_called_extensions_py310]
>     ptestresult.python3-pylint.tests/test_functional.py::test_functional[typevar_naming_style_default]
>     ptestresult.python3-pylint.tests/test_functional.py::test_functional[typevar_naming_style_rgx]
>     ptestresult.python3-pylint.tests/test_functional.py::test_functional[typing_broken_noreturn]
>     ptestresult.python3-pylint.tests/test_functional.py::test_functional[typing_broken_noreturn_future_import]
>     ptestresult.python3-pylint.tests/test_functional.py::test_functional[typing_broken_noreturn_py372]
>     ptestresult.python3-pylint.tests/test_functional.py::test_functional[undefined_loop_variable]
>     ptestresult.python3-pylint.tests/test_self.py::TestCallbackOptions::test_generate_toml_config
>     ptestresult.python3-pylint.tests/test_self.py::TestCallbackOptions::test_generate_toml_config_disable_symbolic_names
> --------------------------------------------------------------------------------------------------------------
>
> On Tue, May 2, 2023 at 9:50 AM Trevor Gamblin <tgamblin@baylibre.com> wrote:
> >
> > Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> > ---
> >  ....toml-Remove-hard-coded-dependencies.patch | 10 ++-----
> >  .../python/python3-pylint/run-ptest           |  3 ++
> >  .../python/python3-pylint_2.17.3.bb           | 30 +++++++++++++++++--
> >  3 files changed, 32 insertions(+), 11 deletions(-)
> >  create mode 100644 meta-python/recipes-devtools/python/python3-pylint/run-ptest
> >
> > diff --git a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch b/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
> > index 55d42b101..267e4c30d 100644
> > --- a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
> > +++ b/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
> > @@ -1,21 +1,15 @@
> > -From 843d050f1bf889b81fa8fc3e7a1350385c8348ec Mon Sep 17 00:00:00 2001
> > +From c5c415a240189ac6730ba95de0bb5883dfb53609 Mon Sep 17 00:00:00 2001
> >  From: Trevor Gamblin <tgamblin@baylibre.com>
> >  Date: Mon, 1 May 2023 11:32:24 -0400
> >  Subject: [PATCH] pyproject.toml: Remove hard-coded dependencies
> >
> > -The upstream pyproject.toml has hard-coded dependencies on specific
> > -versions of wheel and setuptools. This breaks builds of pylint
> > -2.17.3, so patch it to remove the pinned versions.
> > -
> > -Upstream-Status: Pending
> > -
> >  Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> >  ---
> >   pyproject.toml | 2 +-
> >   1 file changed, 1 insertion(+), 1 deletion(-)
> >
> >  diff --git a/pyproject.toml b/pyproject.toml
> > -index e4b63c660..0ee21e0eb 100644
> > +index bd542646b..2c0ed9485 100644
> >  --- a/pyproject.toml
> >  +++ b/pyproject.toml
> >  @@ -1,5 +1,5 @@
> > diff --git a/meta-python/recipes-devtools/python/python3-pylint/run-ptest b/meta-python/recipes-devtools/python/python3-pylint/run-ptest
> > new file mode 100644
> > index 000000000..b63c4de0d
> > --- /dev/null
> > +++ b/meta-python/recipes-devtools/python/python3-pylint/run-ptest
> > @@ -0,0 +1,3 @@
> > +#!/bin/sh
> > +
> > +pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
> > diff --git a/meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb b/meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb
> > index b85f77503..58f0616fc 100644
> > --- a/meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb
> > +++ b/meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb
> > @@ -3,10 +3,14 @@ HOMEPAGE= "http://www.pylint.org/"
> >  LICENSE = "GPL-2.0-only"
> >  LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9"
> >
> > -SRC_URI += "file://0001-pyproject.toml-Remove-hard-coded-dependencies.patch"
> > -SRC_URI[sha256sum] = "761907349e699f8afdcd56c4fe02f3021ab5b3a0fc26d19a9bfdc66c7d0d5cd5"
> > +SRC_URI += " \
> > +        git://github.com/pylint-dev/pylint;branch=main;protocol=https \
> > +        file://run-ptest \
> > +        file://0001-pyproject.toml-Remove-hard-coded-dependencies.patch \
> > +        "
> > +SRCREV ?= "389e14c36819cb87190fd412d3f366a3283f0078"
> >
> > -inherit pypi python_setuptools_build_meta
> > +inherit python_setuptools_build_meta ptest
> >
> >  RDEPENDS:${PN} += "${PYTHON_PN}-astroid \
> >                     ${PYTHON_PN}-isort \
> > @@ -17,3 +21,23 @@ RDEPENDS:${PN} += "${PYTHON_PN}-astroid \
> >                     ${PYTHON_PN}-difflib \
> >                     ${PYTHON_PN}-netserver \
> >                    "
> > +
> > +RDEPENDS:${PN}-ptest += " \
> > +        ${PYTHON_PN}-core \
> > +        ${PYTHON_PN}-dill \
> > +        ${PYTHON_PN}-git \
> > +        ${PYTHON_PN}-platformdirs \
> > +        ${PYTHON_PN}-pytest \
> > +        ${PYTHON_PN}-pytest-benchmark \
> > +        ${PYTHON_PN}-statistics \
> > +        ${PYTHON_PN}-tomlkit \
> > +        ${PYTHON_PN}-tomllib \
> > +        "
> > +
> > +S = "${WORKDIR}/git"
> > +
> > +do_install_ptest() {
> > +    install -d ${D}${PTEST_PATH}/tests
> > +    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
> > +    sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript
> > +}
> > --
> > 2.40.0
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#102270): https://lists.openembedded.org/g/openembedded-devel/message/102270
> > Mute This Topic: https://lists.openembedded.org/mt/98643295/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch b/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
index 55d42b101..267e4c30d 100644
--- a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
+++ b/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
@@ -1,21 +1,15 @@ 
-From 843d050f1bf889b81fa8fc3e7a1350385c8348ec Mon Sep 17 00:00:00 2001
+From c5c415a240189ac6730ba95de0bb5883dfb53609 Mon Sep 17 00:00:00 2001
 From: Trevor Gamblin <tgamblin@baylibre.com>
 Date: Mon, 1 May 2023 11:32:24 -0400
 Subject: [PATCH] pyproject.toml: Remove hard-coded dependencies
 
-The upstream pyproject.toml has hard-coded dependencies on specific
-versions of wheel and setuptools. This breaks builds of pylint 
-2.17.3, so patch it to remove the pinned versions.
-
-Upstream-Status: Pending
-
 Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
 ---
  pyproject.toml | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
 diff --git a/pyproject.toml b/pyproject.toml
-index e4b63c660..0ee21e0eb 100644
+index bd542646b..2c0ed9485 100644
 --- a/pyproject.toml
 +++ b/pyproject.toml
 @@ -1,5 +1,5 @@
diff --git a/meta-python/recipes-devtools/python/python3-pylint/run-ptest b/meta-python/recipes-devtools/python/python3-pylint/run-ptest
new file mode 100644
index 000000000..b63c4de0d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pylint/run-ptest
@@ -0,0 +1,3 @@ 
+#!/bin/sh
+
+pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb b/meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb
index b85f77503..58f0616fc 100644
--- a/meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb
@@ -3,10 +3,14 @@  HOMEPAGE= "http://www.pylint.org/"
 LICENSE = "GPL-2.0-only"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9"
 
-SRC_URI += "file://0001-pyproject.toml-Remove-hard-coded-dependencies.patch"
-SRC_URI[sha256sum] = "761907349e699f8afdcd56c4fe02f3021ab5b3a0fc26d19a9bfdc66c7d0d5cd5"
+SRC_URI += " \
+        git://github.com/pylint-dev/pylint;branch=main;protocol=https \
+        file://run-ptest \
+        file://0001-pyproject.toml-Remove-hard-coded-dependencies.patch \
+        "
+SRCREV ?= "389e14c36819cb87190fd412d3f366a3283f0078"
 
-inherit pypi python_setuptools_build_meta
+inherit python_setuptools_build_meta ptest
 
 RDEPENDS:${PN} += "${PYTHON_PN}-astroid \
                    ${PYTHON_PN}-isort \
@@ -17,3 +21,23 @@  RDEPENDS:${PN} += "${PYTHON_PN}-astroid \
                    ${PYTHON_PN}-difflib \
                    ${PYTHON_PN}-netserver \
                   "
+
+RDEPENDS:${PN}-ptest += " \
+        ${PYTHON_PN}-core \
+        ${PYTHON_PN}-dill \
+        ${PYTHON_PN}-git \
+        ${PYTHON_PN}-platformdirs \
+        ${PYTHON_PN}-pytest \
+        ${PYTHON_PN}-pytest-benchmark \
+        ${PYTHON_PN}-statistics \
+        ${PYTHON_PN}-tomlkit \
+        ${PYTHON_PN}-tomllib \
+        "
+
+S = "${WORKDIR}/git"
+
+do_install_ptest() {
+    install -d ${D}${PTEST_PATH}/tests
+    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+    sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript
+}