diff mbox series

cryptodev: upgrade to 1.13

Message ID 20230501103412.1151195-1-andrey.z@gmail.com
State Accepted, archived
Commit dc85b747af14f5262590e72e55d2c49670cf09a7
Headers show
Series cryptodev: upgrade to 1.13 | expand

Commit Message

Andrey Zhizhikin May 1, 2023, 10:34 a.m. UTC
Upgrade cryptodev to new release 1.13. This resoves the Kernel build
issues for 6.3.y, where Crypto API has been updated, see [1].

Refresh all layer patches with `devtool` to resolve hunks.

Link: [1]: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=255e48eb17684157336bd6dd98d22c1b2d9e3f43
Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
---
 ...-linux_1.12.bb => cryptodev-linux_1.13.bb} |  0
 ...odule_1.12.bb => cryptodev-module_1.13.bb} |  0
 ...-tests_1.12.bb => cryptodev-tests_1.13.bb} |  0
 meta/recipes-kernel/cryptodev/cryptodev.inc   |  2 +-
 ...and-install-rules-for-cryptodev-test.patch | 38 +++++++++----------
 ...ng-header-file-provided-by-another-p.patch | 11 +++---
 ...001-tests-Makefile-do-not-use-Werror.patch |  3 +-
 7 files changed, 28 insertions(+), 26 deletions(-)
 rename meta/recipes-kernel/cryptodev/{cryptodev-linux_1.12.bb => cryptodev-linux_1.13.bb} (100%)
 rename meta/recipes-kernel/cryptodev/{cryptodev-module_1.12.bb => cryptodev-module_1.13.bb} (100%)
 rename meta/recipes-kernel/cryptodev/{cryptodev-tests_1.12.bb => cryptodev-tests_1.13.bb} (100%)
diff mbox series

Patch

diff --git a/meta/recipes-kernel/cryptodev/cryptodev-linux_1.12.bb b/meta/recipes-kernel/cryptodev/cryptodev-linux_1.13.bb
similarity index 100%
rename from meta/recipes-kernel/cryptodev/cryptodev-linux_1.12.bb
rename to meta/recipes-kernel/cryptodev/cryptodev-linux_1.13.bb
diff --git a/meta/recipes-kernel/cryptodev/cryptodev-module_1.12.bb b/meta/recipes-kernel/cryptodev/cryptodev-module_1.13.bb
similarity index 100%
rename from meta/recipes-kernel/cryptodev/cryptodev-module_1.12.bb
rename to meta/recipes-kernel/cryptodev/cryptodev-module_1.13.bb
diff --git a/meta/recipes-kernel/cryptodev/cryptodev-tests_1.12.bb b/meta/recipes-kernel/cryptodev/cryptodev-tests_1.13.bb
similarity index 100%
rename from meta/recipes-kernel/cryptodev/cryptodev-tests_1.12.bb
rename to meta/recipes-kernel/cryptodev/cryptodev-tests_1.13.bb
diff --git a/meta/recipes-kernel/cryptodev/cryptodev.inc b/meta/recipes-kernel/cryptodev/cryptodev.inc
index ef342a157c..61c688f1d0 100644
--- a/meta/recipes-kernel/cryptodev/cryptodev.inc
+++ b/meta/recipes-kernel/cryptodev/cryptodev.inc
@@ -10,7 +10,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
 
 SRC_URI = "git://github.com/cryptodev-linux/cryptodev-linux;branch=master;protocol=https \
            "
-SRCREV = "e0c25e289d6baf1d83c2b9cb523d3bc237d0c0c9"
+SRCREV = "795f5fda1485d447cdbad342e8304be317d4f7e8"
 
 S = "${WORKDIR}/git"
 
diff --git a/meta/recipes-kernel/cryptodev/files/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch b/meta/recipes-kernel/cryptodev/files/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch
index 84fd27e681..8c40e62389 100644
--- a/meta/recipes-kernel/cryptodev/files/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch
+++ b/meta/recipes-kernel/cryptodev/files/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch
@@ -1,4 +1,4 @@ 
-From 1980a8f4779a955e73285e7a0d86549b69bea5c8 Mon Sep 17 00:00:00 2001
+From 3ba8ba9410464d0986bc6cc5ddb1819745af1eb2 Mon Sep 17 00:00:00 2001
 From: Yu Zongchun <b40527@freescale.com>
 Date: Sun, 28 Apr 2013 14:39:22 +0800
 Subject: [PATCH] Add the compile and install rules for cryptodev tests folder
@@ -10,27 +10,27 @@  Signed-off-by: Yu Zongchun <b40527@freescale.com>
 Upstream-Status: Pending
 
 ---
- Makefile       |    6 ++++++
- tests/Makefile |    8 ++++++++
- 2 files changed, 14 insertions(+), 0 deletions(-)
+ Makefile       | 6 ++++++
+ tests/Makefile | 8 ++++++++
+ 2 files changed, 14 insertions(+)
 
-Index: git/Makefile
-===================================================================
---- git.orig/Makefile
-+++ git/Makefile
-@@ -35,6 +35,9 @@ modules_install:
- 	$(MAKE) $(KERNEL_MAKE_OPTS) modules_install
- 	install -m 644 -D crypto/cryptodev.h $(DESTDIR)/$(includedir)/crypto/cryptodev.h
+diff --git a/Makefile b/Makefile
+index d83aee6..3a750a1 100644
+--- a/Makefile
++++ b/Makefile
+@@ -41,6 +41,9 @@ modules_install:
+ install_tests: tests
+ 	$(MAKE) -C tests install DESTDIR=$(PREFIX)
  
 +install_tests:
 +	make -C tests install DESTDIR=$(PREFIX)
 +
  clean:
  	$(MAKE) $(KERNEL_MAKE_OPTS) clean
- 	rm -f $(hostprogs) *~
-@@ -43,6 +46,9 @@ clean:
- check:
- 	CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests check
+ 	CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests clean
+@@ -54,6 +57,9 @@ tests:
+ 
+ .PHONY: install modules_install tests install_tests
  
 +testprogs:
 +	KERNEL_DIR=$(KERNEL_DIR) make -C tests testprogs
@@ -38,10 +38,10 @@  Index: git/Makefile
  CPOPTS =
  ifneq ($(SHOW_TYPES),)
  CPOPTS += --show-types
-Index: git/tests/Makefile
-===================================================================
---- git.orig/tests/Makefile
-+++ git/tests/Makefile
+diff --git a/tests/Makefile b/tests/Makefile
+index 2502f32..2fb7a9a 100644
+--- a/tests/Makefile
++++ b/tests/Makefile
 @@ -23,6 +23,12 @@ bindir = $(execprefix)/bin
  
  all: $(hostprogs)
diff --git a/meta/recipes-kernel/cryptodev/files/0001-Disable-installing-header-file-provided-by-another-p.patch b/meta/recipes-kernel/cryptodev/files/0001-Disable-installing-header-file-provided-by-another-p.patch
index 885b5823e4..c7fdef4da4 100644
--- a/meta/recipes-kernel/cryptodev/files/0001-Disable-installing-header-file-provided-by-another-p.patch
+++ b/meta/recipes-kernel/cryptodev/files/0001-Disable-installing-header-file-provided-by-another-p.patch
@@ -1,4 +1,4 @@ 
-From 8a884f55bd1527baa82fab68c186ba546273860c Mon Sep 17 00:00:00 2001
+From 66d85d3f26e21cf7c38b27de0dcc42376f5d853e Mon Sep 17 00:00:00 2001
 From: Denys Dmytriyenko <denys@ti.com>
 Date: Sun, 6 Apr 2014 19:51:39 -0400
 Subject: [PATCH] Disable installing header file provided by another package
@@ -6,19 +6,20 @@  Subject: [PATCH] Disable installing header file provided by another package
 Signed-off-by: Denys Dmytriyenko <denys@ti.com>
 
 Upstream-Status: Inappropriate [ OE specific ]
+
 ---
  Makefile | 1 -
  1 file changed, 1 deletion(-)
 
 diff --git a/Makefile b/Makefile
-index 5a080e0..bf02396 100644
+index d83aee6..c8d8ae5 100644
 --- a/Makefile
 +++ b/Makefile
-@@ -33,7 +33,6 @@ install: modules_install
+@@ -36,7 +36,6 @@ install: modules_install
  
  modules_install:
  	$(MAKE) $(KERNEL_MAKE_OPTS) modules_install
 -	install -m 644 -D crypto/cryptodev.h $(DESTDIR)/$(includedir)/crypto/cryptodev.h
  
- clean:
- 	$(MAKE) $(KERNEL_MAKE_OPTS) clean
+ install_tests: tests
+ 	$(MAKE) -C tests install DESTDIR=$(PREFIX)
diff --git a/meta/recipes-kernel/cryptodev/files/0001-tests-Makefile-do-not-use-Werror.patch b/meta/recipes-kernel/cryptodev/files/0001-tests-Makefile-do-not-use-Werror.patch
index 347a4aef0f..3285548a57 100644
--- a/meta/recipes-kernel/cryptodev/files/0001-tests-Makefile-do-not-use-Werror.patch
+++ b/meta/recipes-kernel/cryptodev/files/0001-tests-Makefile-do-not-use-Werror.patch
@@ -1,4 +1,4 @@ 
-From e2c2895d52761ddc6384a31364236dd13f677c34 Mon Sep 17 00:00:00 2001
+From 47438e53e1156db0916c0f4683a24fe4d82152f2 Mon Sep 17 00:00:00 2001
 From: Alexander Kanavin <alex@linutronix.de>
 Date: Fri, 10 Sep 2021 10:44:42 +0200
 Subject: [PATCH] tests/Makefile: do not use -Werror
@@ -8,6 +8,7 @@  Reported at https://github.com/cryptodev-linux/cryptodev-linux/issues/67
 
 Upstream-Status: Inappropriate [upstream needs to update the code]
 Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+
 ---
  tests/Makefile | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)