[meta-python,1/3] python3-matplotlib: Do not use setuptools_scm_git_archive

Message ID 20220111202225.1526283-1-raj.khem@gmail.com
State New
Headers show
Series [meta-python,1/3] python3-matplotlib: Do not use setuptools_scm_git_archive | expand

Commit Message

Khem Raj Jan. 11, 2022, 8:22 p.m. UTC
this gets invoked during compile task which is not disabling network
access, any network activity should be explicitly enabled except during
do_fetch

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../matplotlib-disable-download.patch         | 20 ++++++++++++++-----
 1 file changed, 15 insertions(+), 5 deletions(-)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
index e032ceb2c9..42ffeb8970 100644
--- a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
+++ b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
@@ -4,9 +4,19 @@  Upstream-Status: Inappropriate [disable feature]
 
 Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
 
---- a/setupext.py.orig 2021-12-14 09:44:33.499041044 -0800
-+++ a/setupext.py      2021-12-14 09:45:00.447041706 -0800
-@@ -64,40 +64,7 @@
+--- a/setup.py
++++ b/setup.py
+@@ -317,7 +317,6 @@ setup(  # Finally, pass this all along t
+         "certifi>=2020.06.20",
+         "numpy>=1.17",
+         "setuptools_scm>=4",
+-        "setuptools_scm_git_archive",
+     ],
+     install_requires=[
+         "cycler>=0.10",
+--- a/setupext.py
++++ b/setupext.py
+@@ -64,40 +64,7 @@ def get_from_cache_or_download(url, sha)
      BytesIO
          The file loaded into memory.
      """
@@ -45,6 +55,6 @@  Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
 -
 -    return BytesIO(data)
 +    raise IOError(f"Automatic downloading is disabled.")
-
-
+ 
+ 
  def get_and_extract_tarball(urls, sha, dirname):