diff mbox series

[meta-arago,master/kirkstone,3/6] qtwayland: drop the fix-wayland-texture-sharing patch

Message ID 20230426213214.3501230-4-rs@ti.com
State Superseded
Delegated to: Ryan Eatmon
Headers show
Series Vulkan prep and some cleanup | expand

Commit Message

Randolph Sapp April 26, 2023, 9:32 p.m. UTC
From: Randolph Sapp <rs@ti.com>

Meta-qt is now providing a version of qtwayland that already has this
patch applied.

Signed-off-by: Randolph Sapp <rs@ti.com>
---
 ...land-texture-sharing-custom-composit.patch | 52 -------------------
 .../recipes-qt/qt5/qtwayland_git.bbappend     |  1 -
 2 files changed, 53 deletions(-)
 delete mode 100644 meta-arago-distro/recipes-qt/qt5/qtwayland/0001-examples-fix-wayland-texture-sharing-custom-composit.patch
diff mbox series

Patch

diff --git a/meta-arago-distro/recipes-qt/qt5/qtwayland/0001-examples-fix-wayland-texture-sharing-custom-composit.patch b/meta-arago-distro/recipes-qt/qt5/qtwayland/0001-examples-fix-wayland-texture-sharing-custom-composit.patch
deleted file mode 100644
index c209dfc4..00000000
--- a/meta-arago-distro/recipes-qt/qt5/qtwayland/0001-examples-fix-wayland-texture-sharing-custom-composit.patch
+++ /dev/null
@@ -1,52 +0,0 @@ 
-From 1d18591d9e7ed9b3580e06c37be23bfde24bc30c Mon Sep 17 00:00:00 2001
-From: Peter Seiderer <ps.report@gmx.net>
-Date: Fri, 3 Apr 2020 22:40:29 +0200
-Subject: [PATCH] examples: fix wayland/texture-sharing/custom-compositor
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fixes:
-
-  main.cpp:83:33: error: ‘GL_RGBA8’ was not declared in this scope; did you mean ‘GL_RGBA4’?
-     83 |             *glInternalFormat = GL_RGBA8;
-        |                                 ^~~~~~~~
-        |                                 GL_RGBA4
-  main.cpp:120:33: error: ‘GL_RGBA8’ was not declared in this scope; did you mean ‘GL_RGBA4’?
-    120 |             *glInternalFormat = GL_RGBA8;
-        |                                 ^~~~~~~~
-        |                                 GL_RGBA4
-
-Task-number: QTBUG-83304
-Change-Id: I0515f3303b08c405d162986e280e9a7bd35e28f7
-Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io>
-Reviewed-by: Eskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@qt.io>
-
-Upstream-Status: Backport [1d18591d9e7ed9b3580e06c37be23bfde24bc30c]
-
-The patch is backport from upstream commit -
-1d18591d9e7ed9b3580e06c37be23bfde24bc30c
-
-Signed-off-by: Gowtham Tammana <g-tammana@ti.com>
----
- examples/wayland/texture-sharing/custom-compositor/main.cpp | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/examples/wayland/texture-sharing/custom-compositor/main.cpp b/examples/wayland/texture-sharing/custom-compositor/main.cpp
-index a39c8c38..af375024 100644
---- a/examples/wayland/texture-sharing/custom-compositor/main.cpp
-+++ b/examples/wayland/texture-sharing/custom-compositor/main.cpp
-@@ -63,6 +63,10 @@
- 
- #include "QtWaylandCompositor/private/qwltexturesharingextension_p.h"
- 
-+#ifndef GL_RGBA8
-+#define GL_RGBA8 0x8058
-+#endif
-+
- class CustomSharingExtension : public QWaylandTextureSharingExtension
- {
-     Q_OBJECT
--- 
-2.17.1
-
diff --git a/meta-arago-distro/recipes-qt/qt5/qtwayland_git.bbappend b/meta-arago-distro/recipes-qt/qt5/qtwayland_git.bbappend
index 25b5fc42..df8b5eff 100644
--- a/meta-arago-distro/recipes-qt/qt5/qtwayland_git.bbappend
+++ b/meta-arago-distro/recipes-qt/qt5/qtwayland_git.bbappend
@@ -3,7 +3,6 @@  PR:append = ".arago2"
 
 SRC_URI += " \
     file://0001-plugins-decorations-bradient-display-window-icon-onl.patch \
-    file://0001-examples-fix-wayland-texture-sharing-custom-composit.patch \
 "
 
 PACKAGECONFIG:remove = "xcomposite-egl xcomposite-glx"