diff mbox series

[meta-oe,kirkstone] zsh: fix installed-vs-shipped with multilib

Message ID 20230412051420.10545-1-Martin.Jansa@gmail.com
State New
Headers show
Series [meta-oe,kirkstone] zsh: fix installed-vs-shipped with multilib | expand

Commit Message

Martin Jansa April 12, 2023, 5:14 a.m. UTC
From: Martin Jansa <martin.jansa@gmail.com>

* fixes:
lib32-zsh-5.8: lib32-zsh: Files/directories were installed but not shipped in any package:
  /usr/share/lib32-zsh
  /usr/share/lib32-zsh/5.8
  /usr/share/lib32-zsh/site-functions
  /usr/share/lib32-zsh/5.8/functions
  /usr/share/lib32-zsh/5.8/functions/_selinux_users
... 1000+ lines ...
  /usr/share/lib32-zsh/5.8/functions/VCS_INFO_bydir_detect
Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
lib32-zsh: 1116 installed and not shipped files. [installed-vs-shipped]

* they will clash if someone is trying to install both zsh
  and lib32-zsh, but it's not very likely as nobody sane
  was building lib32-zsh with 1000+ line warning regularly

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-oe/recipes-shells/zsh/zsh_5.8.bb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-shells/zsh/zsh_5.8.bb b/meta-oe/recipes-shells/zsh/zsh_5.8.bb
index b023e8d297..7602ff9f64 100644
--- a/meta-oe/recipes-shells/zsh/zsh_5.8.bb
+++ b/meta-oe/recipes-shells/zsh/zsh_5.8.bb
@@ -22,8 +22,8 @@  inherit autotools-brokensep gettext update-alternatives manpages
 EXTRA_OECONF = " \
     --bindir=${base_bindir} \
     --enable-etcdir=${sysconfdir} \
-    --enable-fndir=${datadir}/${PN}/${PV}/functions \
-    --enable-site-fndir=${datadir}/${PN}/site-functions \
+    --enable-fndir=${datadir}/${BPN}/${PV}/functions \
+    --enable-site-fndir=${datadir}/${BPN}/site-functions \
     --with-term-lib='ncursesw ncurses' \
     --with-tcsetpgrp \
     --enable-cap \