diff mbox series

[meta-parsec,1/2] parsec-tool: update SRC_URI hash

Message ID 20230409161619.120499-1-akuster808@gmail.com
State New
Headers show
Series [meta-parsec,1/2] parsec-tool: update SRC_URI hash | expand

Commit Message

akuster808 April 9, 2023, 4:16 p.m. UTC
FIxes:

ERROR: Missing SRC_URI checksum, please add those to the recipe:
SRC_URI[parsec-tool-0.6.0.sha256sum] = "f51d5d7f0caca1c335324b52482fa5edbf6c9cfd2e6865e5cb22716d52dcb367"

Needed to have the package version included in the name.

Fixes:
ERROR: parsec-tool-0.6.0-r0 do_populate_lic: QA Issue: parsec-tool: LIC_FILES_CHKSUM points to an invalid file:
and
error: manifest path `/home/akuster/oss/clean/poky/build/tmp/work/cortexa53-poky-linux/parsec-tool/0.6.0-r0/parsec-tool-0.6.0//Cargo.toml` does not exist

Set S to CARGO_VENDORING_DIRECTORY/BP to fix the LIC_FILES_CHKSUM and compile errors.

Signed-off-by: Armin Kuster <akuster808@gmail.com>
---
 meta-parsec/recipes-parsec/parsec-tool/parsec-tool_0.6.0.bb | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

akuster808 April 9, 2023, 4:22 p.m. UTC | #1
Ignore.

Found another build issus

On 4/9/23 12:16 PM, Armin Kuster via lists.yoctoproject.org wrote:
> Fixes:
> ERROR: Missing SRC_URI checksum, please add those to the recipe:
> SRC_URI[parsec-service-1.2.0.sha256sum] = "f58e7ba859c22cc1904dc8298b1a7d94ee1ba3b4d4808f28e4cc0c96ddb149c9"
>
> Signed-off-by: Armin Kuster <akuster808@gmail.com>
> ---
>   .../recipes-parsec/parsec-service/parsec-service_1.2.0.bb       | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta-parsec/recipes-parsec/parsec-service/parsec-service_1.2.0.bb b/meta-parsec/recipes-parsec/parsec-service/parsec-service_1.2.0.bb
> index 5f4ad5b..bb78f78 100644
> --- a/meta-parsec/recipes-parsec/parsec-service/parsec-service_1.2.0.bb
> +++ b/meta-parsec/recipes-parsec/parsec-service/parsec-service_1.2.0.bb
> @@ -12,7 +12,7 @@ SRC_URI += "crate://crates.io/parsec-service/${PV} \
>               file://systemd.patch \
>               file://parsec-tmpfiles.conf \
>   "
> -SRC_URI[parsec-service.sha256sum] = "f58e7ba859c22cc1904dc8298b1a7d94ee1ba3b4d4808f28e4cc0c96ddb149c9"
> +SRC_URI[parsec-service-1.2.0.sha256sum] = "f58e7ba859c22cc1904dc8298b1a7d94ee1ba3b4d4808f28e4cc0c96ddb149c9"
>   
>   PACKAGECONFIG ??= "PKCS11 MBED-CRYPTO"
>   have_TPM = "${@bb.utils.contains('DISTRO_FEATURES', 'tpm2', 'TPM', '', d)}"
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#59647): https://lists.yoctoproject.org/g/yocto/message/59647
> Mute This Topic: https://lists.yoctoproject.org/mt/98161276/3616698
> Group Owner: yocto+owner@lists.yoctoproject.org
> Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [akuster808@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-parsec/recipes-parsec/parsec-tool/parsec-tool_0.6.0.bb b/meta-parsec/recipes-parsec/parsec-tool/parsec-tool_0.6.0.bb
index c729406..6095ae1 100644
--- a/meta-parsec/recipes-parsec/parsec-tool/parsec-tool_0.6.0.bb
+++ b/meta-parsec/recipes-parsec/parsec-tool/parsec-tool_0.6.0.bb
@@ -7,9 +7,9 @@  inherit cargo cargo-update-recipe-crates
 
 SRC_URI += "crate://crates.io/parsec-tool/${PV} \
 "
-SRC_URI[parsec-tool.sha256sum] = "f51d5d7f0caca1c335324b52482fa5edbf6c9cfd2e6865e5cb22716d52dcb367"
+SRC_URI[parsec-tool-0.6.0.sha256sum] = "f51d5d7f0caca1c335324b52482fa5edbf6c9cfd2e6865e5cb22716d52dcb367"
 
-RDEPENDS:${PN} = "openssl-bin"
+S = "${CARGO_VENDORING_DIRECTORY}/${BP}"
 
 do_install() {
   install -d ${D}/${bindir}
@@ -19,6 +19,8 @@  do_install() {
 
 require parsec-tool-crates.inc
 
+RDEPENDS:${PN} = "openssl-bin"
+
 # The QA check has been temporarily disabled. An issue has been created
 # upstream to fix this.
 # https://github.com/parallaxsecond/parsec-tool/issues/94