diff mbox series

reboot-mode: put the build artifacts in ${B}

Message ID 20230331123153.292738-1-brgl@bgdev.pl
State Under Review
Headers show
Series reboot-mode: put the build artifacts in ${B} | expand

Commit Message

Bartosz Golaszewski March 31, 2023, 12:31 p.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

We should output the compiled executables into ${B} and install them
from it as well. Currently we put the build objects in the source
directory. While at it: don't assume we're already in the source
directory and instead prepend the source file with ${S}.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Ross Burton March 31, 2023, 1:10 p.m. UTC | #1
On 31 Mar 2023, at 13:31, Bartosz Golaszewski via lists.openembedded.org <brgl=bgdev.pl@lists.openembedded.org> wrote:
> 
> From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> 
> We should output the compiled executables into ${B} and install them
> from it as well. Currently we put the build objects in the source
> directory. While at it: don't assume we're already in the source
> directory and instead prepend the source file with ${S}.

By default B=${S}, so this hasn’t changed anything.

Ross
Bartosz Golaszewski March 31, 2023, 2:10 p.m. UTC | #2
On Fri, Mar 31, 2023 at 3:11 PM Ross Burton <Ross.Burton@arm.com> wrote:
>
> On 31 Mar 2023, at 13:31, Bartosz Golaszewski via lists.openembedded.org <brgl=bgdev.pl@lists.openembedded.org> wrote:
> >
> > From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> >
> > We should output the compiled executables into ${B} and install them
> > from it as well. Currently we put the build objects in the source
> > directory. While at it: don't assume we're already in the source
> > directory and instead prepend the source file with ${S}.
>
> By default B=${S}, so this hasn’t changed anything.
>
> Ross

I'd say it's still more semantically correct, no?

Bart
Ross Burton March 31, 2023, 2:13 p.m. UTC | #3
On 31 Mar 2023, at 15:10, Bartosz Golaszewski <brgl@bgdev.pl> wrote:
> 
> On Fri, Mar 31, 2023 at 3:11 PM Ross Burton <Ross.Burton@arm.com> wrote:
>> 
>> On 31 Mar 2023, at 13:31, Bartosz Golaszewski via lists.openembedded.org <brgl=bgdev.pl@lists.openembedded.org> wrote:
>>> 
>>> From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
>>> 
>>> We should output the compiled executables into ${B} and install them
>>> from it as well. Currently we put the build objects in the source
>>> directory. While at it: don't assume we're already in the source
>>> directory and instead prepend the source file with ${S}.
>> 
>> By default B=${S}, so this hasn’t changed anything.
>> 
>> Ross
> 
> I'd say it's still more semantically correct, no?

Personally, I prefer to use S/B only in the case where they’re actually different directories and the latter has been wiped clean on every build.

Ross
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb b/meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb
index 20e77c63d..4c3436823 100644
--- a/meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb
+++ b/meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb
@@ -10,9 +10,9 @@  SRCREV = "84831b20512abd9033414ca5f5a023f333525335"
 S = "${WORKDIR}/git"
 
 do_compile() {
-    ${CC} ${CFLAGS} ${LDFLAGS} reboot-mode.c -o reboot-mode
+    ${CC} ${CFLAGS} ${LDFLAGS} ${S}/reboot-mode.c -o ${B}/reboot-mode
 }
 
 do_install() {
-    install -D -m 0755 ${S}/reboot-mode ${D}${bindir}/reboot-mode
+    install -D -m 0755 ${B}/reboot-mode ${D}${bindir}/reboot-mode
 }