diff mbox series

[meta-python,4/4] python3-ipython: Add missing dependency

Message ID 20230327125002.90472-4-zboszor@gmail.com
State Under Review
Headers show
Series [meta-python,1/4] python3-executing: New recipe | expand

Commit Message

Böszörményi Zoltán March 27, 2023, 12:50 p.m. UTC
This fixes the error:

Python 3.11.2 (main, Feb  7 2023, 13:52:42) [GCC 12.2.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import IPython
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python3.11/site-packages/IPython/__init__.py", line 52, in <module>
    from .core.application import Application
  File "/usr/lib/python3.11/site-packages/IPython/core/application.py", line 26, in <module>
    from IPython.core import release, crashhandler
  File "/usr/lib/python3.11/site-packages/IPython/core/crashhandler.py", line 27, in <module>
    from IPython.core import ultratb
  File "/usr/lib/python3.11/site-packages/IPython/core/ultratb.py", line 101, in <module>
    import stack_data
ModuleNotFoundError: No module named 'stack_data'

Signed-off-by: Zoltán Böszörményi <zboszor@gmail.com>
---
 meta-python/recipes-devtools/python/python3-ipython_8.11.0.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Tim Orling March 27, 2023, 4:39 p.m. UTC | #1
On Mon, Mar 27, 2023 at 5:50 AM Zoltan Boszormenyi <zboszor@gmail.com>
wrote:

> This fixes the error:
>
> Python 3.11.2 (main, Feb  7 2023, 13:52:42) [GCC 12.2.0] on linux
> Type "help", "copyright", "credits" or "license" for more information.
> >>> import IPython
> Traceback (most recent call last):
>   File "<stdin>", line 1, in <module>
>   File "/usr/lib/python3.11/site-packages/IPython/__init__.py", line 52,
> in <module>
>     from .core.application import Application
>   File "/usr/lib/python3.11/site-packages/IPython/core/application.py",
> line 26, in <module>
>     from IPython.core import release, crashhandler
>   File "/usr/lib/python3.11/site-packages/IPython/core/crashhandler.py",
> line 27, in <module>
>     from IPython.core import ultratb
>   File "/usr/lib/python3.11/site-packages/IPython/core/ultratb.py", line
> 101, in <module>
>     import stack_data
> ModuleNotFoundError: No module named 'stack_data'
>
> It appears `stack_data` was added in 8.0.0
https://github.com/ipython/ipython/commit/77651b7a7331b1b030f1c2c03310bf7ebb242488

So we've been missing it for quite some time. This highlights the need for
runtime testing vs. just "it builds".

Thank you for the contribution.


> Signed-off-by: Zoltán Böszörményi <zboszor@gmail.com>
> ---
>  meta-python/recipes-devtools/python/python3-ipython_8.11.0.bb | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/meta-python/recipes-devtools/python/python3-ipython_8.11.0.bb
> b/meta-python/recipes-devtools/python/python3-ipython_8.11.0.bb
> index 4d21afd6f..875e89abe 100644
> --- a/meta-python/recipes-devtools/python/python3-ipython_8.11.0.bb
> +++ b/meta-python/recipes-devtools/python/python3-ipython_8.11.0.bb
> @@ -23,6 +23,7 @@ RDEPENDS:${PN} = "\
>      ${PYTHON_PN}-unixadmin \
>      ${PYTHON_PN}-misc \
>      ${PYTHON_PN}-sqlite3 \
> +    ${PYTHON_PN}-stack-data \
>  "
>
>  inherit setuptools3 pypi
> --
> 2.39.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#101782):
> https://lists.openembedded.org/g/openembedded-devel/message/101782
> Mute This Topic: https://lists.openembedded.org/mt/97881025/924729
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Khem Raj March 27, 2023, 7:04 p.m. UTC | #2
On Mon, Mar 27, 2023 at 9:39 AM Tim Orling <ticotimo@gmail.com> wrote:
>
>
>
> On Mon, Mar 27, 2023 at 5:50 AM Zoltan Boszormenyi <zboszor@gmail.com> wrote:
>>
>> This fixes the error:
>>
>> Python 3.11.2 (main, Feb  7 2023, 13:52:42) [GCC 12.2.0] on linux
>> Type "help", "copyright", "credits" or "license" for more information.
>> >>> import IPython
>> Traceback (most recent call last):
>>   File "<stdin>", line 1, in <module>
>>   File "/usr/lib/python3.11/site-packages/IPython/__init__.py", line 52, in <module>
>>     from .core.application import Application
>>   File "/usr/lib/python3.11/site-packages/IPython/core/application.py", line 26, in <module>
>>     from IPython.core import release, crashhandler
>>   File "/usr/lib/python3.11/site-packages/IPython/core/crashhandler.py", line 27, in <module>
>>     from IPython.core import ultratb
>>   File "/usr/lib/python3.11/site-packages/IPython/core/ultratb.py", line 101, in <module>
>>     import stack_data
>> ModuleNotFoundError: No module named 'stack_data'
>>
> It appears `stack_data` was added in 8.0.0
> https://github.com/ipython/ipython/commit/77651b7a7331b1b030f1c2c03310bf7ebb242488
>
> So we've been missing it for quite some time. This highlights the need for runtime testing vs. just "it builds".
>

Tim you are listed as one of meta-python maintainers, do you have
plans to implement runtime testing? or for that matter
anyone else in the community wants to volunteer to do this?
I am happy to insert that into upstreaming process and wait for
relevant ACK on meta-python submissions

> Thank you for the contribution.
>
>>
>> Signed-off-by: Zoltán Böszörményi <zboszor@gmail.com>
>> ---
>>  meta-python/recipes-devtools/python/python3-ipython_8.11.0.bb | 1 +
>>  1 file changed, 1 insertion(+)
>>
>> diff --git a/meta-python/recipes-devtools/python/python3-ipython_8.11.0.bb b/meta-python/recipes-devtools/python/python3-ipython_8.11.0.bb
>> index 4d21afd6f..875e89abe 100644
>> --- a/meta-python/recipes-devtools/python/python3-ipython_8.11.0.bb
>> +++ b/meta-python/recipes-devtools/python/python3-ipython_8.11.0.bb
>> @@ -23,6 +23,7 @@ RDEPENDS:${PN} = "\
>>      ${PYTHON_PN}-unixadmin \
>>      ${PYTHON_PN}-misc \
>>      ${PYTHON_PN}-sqlite3 \
>> +    ${PYTHON_PN}-stack-data \
>>  "
>>
>>  inherit setuptools3 pypi
>> --
>> 2.39.2
>>
>>
>>
>>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#101789): https://lists.openembedded.org/g/openembedded-devel/message/101789
> Mute This Topic: https://lists.openembedded.org/mt/97881025/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-ipython_8.11.0.bb b/meta-python/recipes-devtools/python/python3-ipython_8.11.0.bb
index 4d21afd6f..875e89abe 100644
--- a/meta-python/recipes-devtools/python/python3-ipython_8.11.0.bb
+++ b/meta-python/recipes-devtools/python/python3-ipython_8.11.0.bb
@@ -23,6 +23,7 @@  RDEPENDS:${PN} = "\
     ${PYTHON_PN}-unixadmin \
     ${PYTHON_PN}-misc \
     ${PYTHON_PN}-sqlite3 \
+    ${PYTHON_PN}-stack-data \
 "
 
 inherit setuptools3 pypi