diff mbox series

[kirkstone/master,1/4] irqbalance: Move to the latest tip v1.9.2+

Message ID 20230321190428.2818600-1-denis@denix.org
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [kirkstone/master,1/4] irqbalance: Move to the latest tip v1.9.2+ | expand

Commit Message

Denys Dmytriyenko March 21, 2023, 7:04 p.m. UTC
From: Vignesh Raghavendra <vigneshr@ti.com>

This fixes timeouts seen on daemon stop during reboot
Switches to using irqbalance provide irqbalance.service instead of
custom one
Fixes some IRQs not being classified and thus not balanced.

Signed-off-by: Vignesh Raghavendra <vigneshr@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
---
 .../recipes-extended/irqbalance/irqbalance_git.bbappend   | 8 ++++++++
 1 file changed, 8 insertions(+)
 create mode 100644 meta-arago-distro/recipes-extended/irqbalance/irqbalance_git.bbappend

Comments

Denys Dmytriyenko March 21, 2023, 10:10 p.m. UTC | #1
Please use v2 of this patch.


On Tue, Mar 21, 2023 at 07:04:28PM +0000, Denys Dmytriyenko wrote:
> From: Denys Dmytriyenko <denys@konsulko.com>
> 
> OPTEEOUTPUTMACHINE usage was removed from K3 platforms in meta-ti. Since K3
> platforms all use optee, include corresponding components unconditionally.
> 
> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
> ---
>  .../packagegroups/packagegroup-arago-base-tisdk.bb            | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-base-tisdk.bb b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-base-tisdk.bb
> index 292676c1..1c63fe89 100644
> --- a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-base-tisdk.bb
> +++ b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-base-tisdk.bb
> @@ -27,5 +27,7 @@ RDEPENDS:${PN} = "\
>      nfs-utils-client \
>      cifs-utils \
>      phytool \
> -    ${@bb.utils.contains_any('OPTEEOUTPUTMACHINE', 'ti k3', "${OPTEE_PKGS}", "", d)} \
> +    ${@bb.utils.contains_any('OPTEEOUTPUTMACHINE', 'ti', "${OPTEE_PKGS}", "", d)} \
>  "
> +
> +RDEPENDS:${PN}:append:k3 = "${OPTEE_PKGS}"
> -- 
> 2.25.1
Andrew Davis March 22, 2023, 6:20 p.m. UTC | #2
On 3/21/23 2:04 PM, Denys Dmytriyenko wrote:
> From: Vignesh Raghavendra <vigneshr@ti.com>
> 
> This fixes timeouts seen on daemon stop during reboot
> Switches to using irqbalance provide irqbalance.service instead of
> custom one
> Fixes some IRQs not being classified and thus not balanced.
> 
> Signed-off-by: Vignesh Raghavendra <vigneshr@ti.com>
> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
> ---
>   .../recipes-extended/irqbalance/irqbalance_git.bbappend   | 8 ++++++++
>   1 file changed, 8 insertions(+)
>   create mode 100644 meta-arago-distro/recipes-extended/irqbalance/irqbalance_git.bbappend
> 
> diff --git a/meta-arago-distro/recipes-extended/irqbalance/irqbalance_git.bbappend b/meta-arago-distro/recipes-extended/irqbalance/irqbalance_git.bbappend
> new file mode 100644
> index 00000000..3ba30b5d
> --- /dev/null
> +++ b/meta-arago-distro/recipes-extended/irqbalance/irqbalance_git.bbappend
> @@ -0,0 +1,8 @@
> +SRCREV = "c24ed221e9e82faf1ad22de133c3c97a0117c5d7"
> +PV = "1.9.2"
> +
> +do_install_append () {

Old override syntax here and below.

Andrew

> +         install -m 0644 ${S}/misc/irqbalance.service ${D}${systemd_unitdir}/system/irqbalanced.service
> +}
> +
> +PR_append = ".arago3"
Denys Dmytriyenko March 22, 2023, 7:29 p.m. UTC | #3
On Wed, Mar 22, 2023 at 01:20:17PM -0500, Andrew Davis wrote:
> On 3/21/23 2:04 PM, Denys Dmytriyenko wrote:
> >From: Vignesh Raghavendra <vigneshr@ti.com>
> >
> >This fixes timeouts seen on daemon stop during reboot
> >Switches to using irqbalance provide irqbalance.service instead of
> >custom one
> >Fixes some IRQs not being classified and thus not balanced.
> >
> >Signed-off-by: Vignesh Raghavendra <vigneshr@ti.com>
> >Signed-off-by: Ryan Eatmon <reatmon@ti.com>
> >Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
> >---
> >  .../recipes-extended/irqbalance/irqbalance_git.bbappend   | 8 ++++++++
> >  1 file changed, 8 insertions(+)
> >  create mode 100644 meta-arago-distro/recipes-extended/irqbalance/irqbalance_git.bbappend
> >
> >diff --git a/meta-arago-distro/recipes-extended/irqbalance/irqbalance_git.bbappend b/meta-arago-distro/recipes-extended/irqbalance/irqbalance_git.bbappend
> >new file mode 100644
> >index 00000000..3ba30b5d
> >--- /dev/null
> >+++ b/meta-arago-distro/recipes-extended/irqbalance/irqbalance_git.bbappend
> >@@ -0,0 +1,8 @@
> >+SRCREV = "c24ed221e9e82faf1ad22de133c3c97a0117c5d7"
> >+PV = "1.9.2"
> >+
> >+do_install_append () {
> 
> Old override syntax here and below.

Grrr, right, I got sloppy here...
diff mbox series

Patch

diff --git a/meta-arago-distro/recipes-extended/irqbalance/irqbalance_git.bbappend b/meta-arago-distro/recipes-extended/irqbalance/irqbalance_git.bbappend
new file mode 100644
index 00000000..3ba30b5d
--- /dev/null
+++ b/meta-arago-distro/recipes-extended/irqbalance/irqbalance_git.bbappend
@@ -0,0 +1,8 @@ 
+SRCREV = "c24ed221e9e82faf1ad22de133c3c97a0117c5d7"
+PV = "1.9.2"
+
+do_install_append () {
+         install -m 0644 ${S}/misc/irqbalance.service ${D}${systemd_unitdir}/system/irqbalanced.service
+}
+
+PR_append = ".arago3"