[meta-python,2/5] python3-ujson: Upgrade 5.0.0 -> 5.1.0

Message ID 20220107174730.3326962-2-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/5] python3-psutil: Upgrade 5.8.0 -> 5.9.0 | expand

Commit Message

Leon Anavi Jan. 7, 2022, 5:47 p.m. UTC
Upgrade to release 5.1.0:

- Strip debugging symbols from Linux binaries

Add INSANE_SKIP for already-stripped to avoid build errors due to
the stripped debugging symbols from Linux binaries in this release.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../{python3-ujson_5.0.0.bb => python3-ujson_5.1.0.bb}       | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-ujson_5.0.0.bb => python3-ujson_5.1.0.bb} (78%)

Comments

Khem Raj Jan. 7, 2022, 6:55 p.m. UTC | #1
On 1/7/22 9:47 AM, Leon Anavi wrote:
> Upgrade to release 5.1.0:
> 
> - Strip debugging symbols from Linux binaries
> 
> Add INSANE_SKIP for already-stripped to avoid build errors due to
> the stripped debugging symbols from Linux binaries in this release.
> 
> Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
> ---
>   .../{python3-ujson_5.0.0.bb => python3-ujson_5.1.0.bb}       | 5 ++++-
>   1 file changed, 4 insertions(+), 1 deletion(-)
>   rename meta-python/recipes-devtools/python/{python3-ujson_5.0.0.bb => python3-ujson_5.1.0.bb} (78%)
> 
> diff --git a/meta-python/recipes-devtools/python/python3-ujson_5.0.0.bb b/meta-python/recipes-devtools/python/python3-ujson_5.1.0.bb
> similarity index 78%
> rename from meta-python/recipes-devtools/python/python3-ujson_5.0.0.bb
> rename to meta-python/recipes-devtools/python/python3-ujson_5.1.0.bb
> index fb1bcd761..821eba58c 100644
> --- a/meta-python/recipes-devtools/python/python3-ujson_5.0.0.bb
> +++ b/meta-python/recipes-devtools/python/python3-ujson_5.1.0.bb
> @@ -4,7 +4,7 @@ DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pu
>   LICENSE = "BSD-3-Clause"
>   LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=10fa10456417c0252bcb8a498e498ffe"
>   
> -SRC_URI[sha256sum] = "3ff7242816b1d22c08c04c4c6db0f6ba7c16cd624ce38534c1025defa011e50e"
> +SRC_URI[sha256sum] = "a88944d2f99db71a3ca0c63d81f37e55b660edde0b07216fb65a3e46403ef004"
>   
>   inherit pypi ptest setuptools3
>   
> @@ -31,3 +31,6 @@ do_install_ptest() {
>   }
>   
>   BBCLASSEXTEND = "native nativesdk"
> +
> +# Debugging symbols have been stripped from Linux binaries since release 5.1.0
> +INSANE_SKIP:${PN} += "already-stripped"
> 

is it possible to disable this auto stripping via some build configs ?
if so that would be better for debugability to let OE do the stripping 
operation

> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#94693): https://lists.openembedded.org/g/openembedded-devel/message/94693
> Mute This Topic: https://lists.openembedded.org/mt/88266861/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta-python/recipes-devtools/python/python3-ujson_5.0.0.bb b/meta-python/recipes-devtools/python/python3-ujson_5.1.0.bb
similarity index 78%
rename from meta-python/recipes-devtools/python/python3-ujson_5.0.0.bb
rename to meta-python/recipes-devtools/python/python3-ujson_5.1.0.bb
index fb1bcd761..821eba58c 100644
--- a/meta-python/recipes-devtools/python/python3-ujson_5.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-ujson_5.1.0.bb
@@ -4,7 +4,7 @@  DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pu
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=10fa10456417c0252bcb8a498e498ffe"
 
-SRC_URI[sha256sum] = "3ff7242816b1d22c08c04c4c6db0f6ba7c16cd624ce38534c1025defa011e50e"
+SRC_URI[sha256sum] = "a88944d2f99db71a3ca0c63d81f37e55b660edde0b07216fb65a3e46403ef004"
 
 inherit pypi ptest setuptools3
 
@@ -31,3 +31,6 @@  do_install_ptest() {
 }
 
 BBCLASSEXTEND = "native nativesdk"
+
+# Debugging symbols have been stripped from Linux binaries since release 5.1.0
+INSANE_SKIP:${PN} += "already-stripped"