consolekit: depend on libx11

Submitted by Andreas Oberritter on Feb. 10, 2012, 10:04 p.m.

Details

Message ID 4F35945D.7020900@opendreambox.org
State Accepted
Commit e5c60517a22997bb966bbe21a2d7cbc99a97b42b
Headers show

Commit Message

Andreas Oberritter Feb. 10, 2012, 10:04 p.m.
* Fixes the following error at configure time:

|checking for TOOLS... no
|configure: error: Package requirements (x11 >= 1.0.0
|  glib-2.0 >= 2.14
|) were not met:
|
|No package 'x11' found

Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
---
* Note that I didn't build test this, because I'm building
  without x11. I just looked up the package of x11.pc, which
  at least in Ubuntu is libx11.

 .../recipes-support/consolekit/consolekit_0.4.5.bb |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

Patch hide | download patch | download mbox

diff --git a/meta/recipes-support/consolekit/consolekit_0.4.5.bb b/meta/recipes-support/consolekit/consolekit_0.4.5.bb
index 3ded6df..3a4b04f 100644
--- a/meta/recipes-support/consolekit/consolekit_0.4.5.bb
+++ b/meta/recipes-support/consolekit/consolekit_0.4.5.bb
@@ -13,7 +13,7 @@  POLKIT_libc-uclibc = ""
 POLKITCONF = ""
 POLKITCONF_libc-uclibc = "--disable-policykit"
 
-DEPENDS = "glib-2.0 dbus ${POLKIT} ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
+DEPENDS = "glib-2.0 dbus ${POLKIT} ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} virtual/libx11"
 RDEPENDS_${PN} += "base-files"
 
 inherit gnome

Comments

Khem Raj Feb. 11, 2012, 2:09 a.m.
On (10/02/12 23:04), Andreas Oberritter wrote:
> * Fixes the following error at configure time:
> 
> |checking for TOOLS... no
> |configure: error: Package requirements (x11 >= 1.0.0
> |  glib-2.0 >= 2.14
> |) were not met:
> |
> |No package 'x11' found
> 
> Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
> ---
> * Note that I didn't build test this, because I'm building
>   without x11. I just looked up the package of x11.pc, which
>   at least in Ubuntu is libx11.
> 
>  .../recipes-support/consolekit/consolekit_0.4.5.bb |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/meta/recipes-support/consolekit/consolekit_0.4.5.bb b/meta/recipes-support/consolekit/consolekit_0.4.5.bb
> index 3ded6df..3a4b04f 100644
> --- a/meta/recipes-support/consolekit/consolekit_0.4.5.bb
> +++ b/meta/recipes-support/consolekit/consolekit_0.4.5.bb
> @@ -13,7 +13,7 @@ POLKIT_libc-uclibc = ""
>  POLKITCONF = ""
>  POLKITCONF_libc-uclibc = "--disable-policykit"
>  
> -DEPENDS = "glib-2.0 dbus ${POLKIT} ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
> +DEPENDS = "glib-2.0 dbus ${POLKIT} ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} virtual/libx11"

should this depend on if x11 is in DISTRO_FEATURES ?

>  RDEPENDS_${PN} += "base-files"
>  
>  inherit gnome
> -- 
> 1.7.5.4
> 
> 
> _______________________________________________
> Openembedded-core mailing list
> Openembedded-core@lists.openembedded.org
> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-core
Andreas Oberritter Feb. 11, 2012, 4:16 p.m.
On 11.02.2012 03:09, Khem Raj wrote:
> On (10/02/12 23:04), Andreas Oberritter wrote:
>> * Fixes the following error at configure time:
>>
>> |checking for TOOLS... no
>> |configure: error: Package requirements (x11 >= 1.0.0
>> |  glib-2.0 >= 2.14
>> |) were not met:
>> |
>> |No package 'x11' found
>>
>> Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
>> ---
>> * Note that I didn't build test this, because I'm building
>>   without x11. I just looked up the package of x11.pc, which
>>   at least in Ubuntu is libx11.
>>
>>  .../recipes-support/consolekit/consolekit_0.4.5.bb |    2 +-
>>  1 files changed, 1 insertions(+), 1 deletions(-)
>>
>> diff --git a/meta/recipes-support/consolekit/consolekit_0.4.5.bb b/meta/recipes-support/consolekit/consolekit_0.4.5.bb
>> index 3ded6df..3a4b04f 100644
>> --- a/meta/recipes-support/consolekit/consolekit_0.4.5.bb
>> +++ b/meta/recipes-support/consolekit/consolekit_0.4.5.bb
>> @@ -13,7 +13,7 @@ POLKIT_libc-uclibc = ""
>>  POLKITCONF = ""
>>  POLKITCONF_libc-uclibc = "--disable-policykit"
>>  
>> -DEPENDS = "glib-2.0 dbus ${POLKIT} ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
>> +DEPENDS = "glib-2.0 dbus ${POLKIT} ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} virtual/libx11"
> 
> should this depend on if x11 is in DISTRO_FEATURES ?

If it was conditional, someone would have to fix consolekit first in
order to make it build without x11. This would be no problem for someone
interested in it, but it can still be done later.

>>  RDEPENDS_${PN} += "base-files"
>>  
>>  inherit gnome
>> -- 
>> 1.7.5.4
>>
>>
>> _______________________________________________
>> Openembedded-core mailing list
>> Openembedded-core@lists.openembedded.org
>> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-core
>
Saul Wold Feb. 21, 2012, 7:08 p.m.
On 02/10/2012 02:04 PM, Andreas Oberritter wrote:
> * Fixes the following error at configure time:
>
> |checking for TOOLS... no
> |configure: error: Package requirements (x11>= 1.0.0
> |  glib-2.0>= 2.14
> |) were not met:
> |
> |No package 'x11' found
>
> Signed-off-by: Andreas Oberritter<obi@opendreambox.org>
> ---
> * Note that I didn't build test this, because I'm building
>    without x11. I just looked up the package of x11.pc, which
>    at least in Ubuntu is libx11.
>
>   .../recipes-support/consolekit/consolekit_0.4.5.bb |    2 +-
>   1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/meta/recipes-support/consolekit/consolekit_0.4.5.bb b/meta/recipes-support/consolekit/consolekit_0.4.5.bb
> index 3ded6df..3a4b04f 100644
> --- a/meta/recipes-support/consolekit/consolekit_0.4.5.bb
> +++ b/meta/recipes-support/consolekit/consolekit_0.4.5.bb
> @@ -13,7 +13,7 @@ POLKIT_libc-uclibc = ""
>   POLKITCONF = ""
>   POLKITCONF_libc-uclibc = "--disable-policykit"
>
> -DEPENDS = "glib-2.0 dbus ${POLKIT} ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
> +DEPENDS = "glib-2.0 dbus ${POLKIT} ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} virtual/libx11"
>   RDEPENDS_${PN} += "base-files"
>
>   inherit gnome

Merged into OE-core

Thanks
	Sau!