[meta-oe,2/3] systemd.bbclass: depends on systemd

Submitted by Otavio Salvador on Jan. 31, 2012, 5:38 p.m.

Details

Message ID 72467639fd066bb55c32e60cec7cbb67a4a98805.1328031500.git.otavio@ossystems.com.br
State Accepted
Commit c029d4a268de1ac7076fbeb9e337e96fdb1b226d
Headers show

Commit Message

Otavio Salvador Jan. 31, 2012, 5:38 p.m.
Packages that uses the systemd class need to have systemd build
otherwise they might fail to detect systemd as available or fail to
generate rootfs.

Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
---
 meta-oe/classes/systemd.bbclass |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

Patch hide | download patch | download mbox

diff --git a/meta-oe/classes/systemd.bbclass b/meta-oe/classes/systemd.bbclass
index 2ca7bfc..094a12c 100644
--- a/meta-oe/classes/systemd.bbclass
+++ b/meta-oe/classes/systemd.bbclass
@@ -1,4 +1,4 @@ 
-DEPENDS_append = " systemd-systemctl-native"
+DEPENDS_append = " systemd systemd-systemctl-native"
 
 systemd_postinst() {
 OPTS=""