diff mbox series

[meta-arago,kirkstone/master] meta-toolchain-arago: fix internal toolchain installer install issue

Message ID 20230301143159.752566-1-dannenberg@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-arago,kirkstone/master] meta-toolchain-arago: fix internal toolchain installer install issue | expand

Commit Message

Andreas Dannenberg March 1, 2023, 2:31 p.m. UTC
When building the toolchain installer via 'bitbake -c populate_sdk ...'
the resulting toolchain installer throws an error complaining about it
can't find an 'environment-setup-*' file and hangs. The issue is caused
by how the TOOLCHAIN_HOST_TASK variable is populated by the Arago distro
layer, which must be extended via ':append', and not via '+='. See [1]
and [2] for more background on this.

[1] https://www.openembedded.org/pipermail/openembedded-core/2015-July/106931.html
[2] https://community.toradex.com/t/problem-with-angstrom-sdk-installer/5810/8

Signed-off-by: Andreas Dannenberg <dannenberg@ti.com>
---

After this patch is applied the toolchain installer installs without
issue. It even works when doing a multilib, generating two
toolschains/installers as part of the package, which is pretty cool.
I also tested that both cross toolchains actually work using a simple
file I/O test program.


$ arago-tmp-default-glibc/deploy/sdk/arago-2022.02-toolchain-2022.02.sh
-d /home/a0797059/tmp/arago-kirkstone
Arago SDK installer version 2022.02
===================================
You are about to install the SDK to
"/home/a0797059/tmp/arago-kirkstone". Proceed [Y/n]?
Extracting
SDK.....................................................................................................................................................................................................
.......................................................................................................................................................done
Setting it up...done
SDK has been successfully set up and is ready to be used.
Each time you wish to use the SDK in a new shell session, you need to
source the environment setup script e.g.
 $ . /home/a0797059/tmp/arago-kirkstone/environment-setup-aarch64-oe-linux
 $ . /home/a0797059/tmp/arago-kirkstone/environment-setup-armv7at2hf-neon-oemllib32-linux-gnueabi


 meta-arago-distro/recipes-core/images/arago-image.inc       | 2 +-
 meta-arago-extras/recipes-core/meta/meta-toolchain-arago.bb | 4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/meta-arago-distro/recipes-core/images/arago-image.inc b/meta-arago-distro/recipes-core/images/arago-image.inc
index 923bc84f..d00c1f70 100644
--- a/meta-arago-distro/recipes-core/images/arago-image.inc
+++ b/meta-arago-distro/recipes-core/images/arago-image.inc
@@ -19,7 +19,7 @@  export IMAGE_BASENAME = "arago-image"
 
 IMAGE_LINGUAS = ""
 
-TOOLCHAIN_HOST_TASK += "nativesdk-buildtools-perl-dummy"
+TOOLCHAIN_HOST_TASK:append = " nativesdk-buildtools-perl-dummy"
 SDK_PACKAGE_ARCHS += "buildtools-dummy-${SDKPKGSUFFIX}"
 
 BAD_RECOMMENDATIONS += " \
diff --git a/meta-arago-extras/recipes-core/meta/meta-toolchain-arago.bb b/meta-arago-extras/recipes-core/meta/meta-toolchain-arago.bb
index 81affa16..5c1c3ad0 100644
--- a/meta-arago-extras/recipes-core/meta/meta-toolchain-arago.bb
+++ b/meta-arago-extras/recipes-core/meta/meta-toolchain-arago.bb
@@ -1,6 +1,6 @@ 
 TOOLCHAIN_HOST_TASK ?= "nativesdk-packagegroup-sdk-host"
-TOOLCHAIN_HOST_TASK += "nativesdk-buildtools-perl-dummy"
-TOOLCHAIN_HOST_TASK += "packagegroup-cross-canadian-${MACHINE}"
+TOOLCHAIN_HOST_TASK:append = " nativesdk-buildtools-perl-dummy"
+TOOLCHAIN_HOST_TASK:append = " packagegroup-cross-canadian-${MACHINE}"
 TOOLCHAIN_TARGET_TASK ?= "packagegroup-arago-standalone-sdk-target"
 TOOLCHAIN_SUFFIX ?= "-sdk"
 TOOLCHAIN_OUTPUTNAME ?= "${SDK_NAME}-${ARMPKGARCH}-${TARGET_OS}${TOOLCHAIN_SUFFIX}"