diff mbox series

[meta-python] python3-alembic: upgrade 1.9.2 -> 1.9.4

Message ID 1677485021-11417-3-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-alembic: upgrade 1.9.2 -> 1.9.4 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 27, 2023, 8:03 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
 [bug] [mssql] Ongoing fixes for SQL Server server default comparisons under autogenerate,
 adjusting for SQL Server's collapsing of whitespace between SQL function
 arguments when reporting on a function-based server default, as well as its
 arbitrary addition of parenthesis within arguments; the approach has now
 been made more aggressive by stripping the two default strings to compare
 of all whitespace, parenthesis, and quoting characters.

 References: #1177

 [bug] [postgresql] Fixed PostgreSQL server default comparison to handle SQL expressions
 sent as text() constructs, such as text("substring('name', 1, 3)"),
 which previously would raise errors when attempting to run a server-based
 comparison.

 [bug] [autogenerate] Removed a mis-use of the
 EnvironmentContext.configure.render_item callable where the
 "server_default" renderer would be erroneously used within the server
 default comparison process, which is working against SQL expressions, not
 Python code.

 References: #1180

 [bug] [commands] Fixed regression introduced in 1.7.0 where the "config" object passed to
 the template context when running the merge() command
 programmatically failed to be correctly populated. Pull request courtesy
 Brendan Gann.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-alembic_1.9.2.bb => python3-alembic_1.9.4.bb}      | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-alembic_1.9.2.bb => python3-alembic_1.9.4.bb} (81%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-alembic_1.9.2.bb b/meta-python/recipes-devtools/python/python3-alembic_1.9.4.bb
similarity index 81%
rename from meta-python/recipes-devtools/python/python3-alembic_1.9.2.bb
rename to meta-python/recipes-devtools/python/python3-alembic_1.9.4.bb
index 0d83f86c4..7f9ac2ec9 100644
--- a/meta-python/recipes-devtools/python/python3-alembic_1.9.2.bb
+++ b/meta-python/recipes-devtools/python/python3-alembic_1.9.4.bb
@@ -4,7 +4,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=e3023b042cb6002cb398344b51c67093"
 
 inherit pypi setuptools3
 
-SRC_URI[sha256sum] = "6880dec4f28dd7bd999d2ed13fbe7c9d4337700a44d11a524c0ce0c59aaf0dbd"
+SRC_URI[sha256sum] = "4d3bd32ecdbb7bbfb48a9fe9e6d6fd6a831a1b59d03e26e292210237373e7db5"
 
 PYPI_PACKAGE = "alembic"