diff mbox series

devtool: ignore patch-fuzz errors when extracting source

Message ID 20230220182813.2785151-1-alex@linutronix.de
State Accepted, archived
Commit 7067abd31d9dd4b98ec70c1c7effbe2904797cd1
Headers show
Series devtool: ignore patch-fuzz errors when extracting source | expand

Commit Message

Alexander Kanavin Feb. 20, 2023, 6:28 p.m. UTC
So that patch fuzz issues can actually be fixed,
as extracting source with 'devtool modify' is the first step
for that.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 scripts/lib/devtool/standard.py | 1 +
 1 file changed, 1 insertion(+)

Comments

Martin Jansa Feb. 20, 2023, 6:58 p.m. UTC | #1
On Mon, Feb 20, 2023 at 07:28:13PM +0100, Alexander Kanavin wrote:
> So that patch fuzz issues can actually be fixed,
> as extracting source with 'devtool modify' is the first step
> for that.
> 
> Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> ---
>  scripts/lib/devtool/standard.py | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/scripts/lib/devtool/standard.py b/scripts/lib/devtool/standard.py
> index d64e18e179..0339d12763 100644
> --- a/scripts/lib/devtool/standard.py
> +++ b/scripts/lib/devtool/standard.py
> @@ -567,6 +567,7 @@ def _extract_source(srctree, keep_temp, devbranch, sync, config, basepath, works
>          logger.debug('writing append file %s' % appendfile)
>          with open(appendfile, 'a') as f:
>              f.write('###--- _extract_source\n')
> +            f.write('ERROR_QA:remove = "patch-fuzz"\n')

should it append it to WARN_QA so that the warning is still shown to
user while this .bbappend is acive?

>              f.write('DEVTOOL_TEMPDIR = "%s"\n' % tempdir)
>              f.write('DEVTOOL_DEVBRANCH = "%s"\n' % devbranch)
>              if not is_kernel_yocto:
> -- 
> 2.30.2
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#177450): https://lists.openembedded.org/g/openembedded-core/message/177450
> Mute This Topic: https://lists.openembedded.org/mt/97092277/3617156
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [Martin.Jansa@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alexander Kanavin Feb. 20, 2023, 7:03 p.m. UTC | #2
On Mon, 20 Feb 2023 at 19:59, Martin Jansa <martin.jansa@gmail.com> wrote:
> > @@ -567,6 +567,7 @@ def _extract_source(srctree, keep_temp, devbranch, sync, config, basepath, works
> >          logger.debug('writing append file %s' % appendfile)
> >          with open(appendfile, 'a') as f:
> >              f.write('###--- _extract_source\n')
> > +            f.write('ERROR_QA:remove = "patch-fuzz"\n')
>
> should it append it to WARN_QA so that the warning is still shown to
> user while this .bbappend is acive?

I don't think so, as patch-fuzz is a hard error now, so it's visible
just prior to running devtool. The warning would only happen once when
executing 'devtool modify' at the beginning to extract the source into
the workspace, and would just say the same thing as the error.

Alex
diff mbox series

Patch

diff --git a/scripts/lib/devtool/standard.py b/scripts/lib/devtool/standard.py
index d64e18e179..0339d12763 100644
--- a/scripts/lib/devtool/standard.py
+++ b/scripts/lib/devtool/standard.py
@@ -567,6 +567,7 @@  def _extract_source(srctree, keep_temp, devbranch, sync, config, basepath, works
         logger.debug('writing append file %s' % appendfile)
         with open(appendfile, 'a') as f:
             f.write('###--- _extract_source\n')
+            f.write('ERROR_QA:remove = "patch-fuzz"\n')
             f.write('DEVTOOL_TEMPDIR = "%s"\n' % tempdir)
             f.write('DEVTOOL_DEVBRANCH = "%s"\n' % devbranch)
             if not is_kernel_yocto: