diff mbox series

[v2,3/3] python3-pytest: set RDEPENDS globally, not just target

Message ID 20230220165529.374011-3-ross.burton@arm.com
State Accepted, archived
Commit e7980308d78e7fb8ea1568b80363c809c91c2363
Headers show
Series [v2,1/3] python3-atomicwrites: add BBCLASSEXTEND | expand

Commit Message

Ross Burton Feb. 20, 2023, 4:55 p.m. UTC
Now that we have the dependencies we can set the RDEPENDS for all builds,
not just target.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-devtools/python/python3-pytest_7.2.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-pytest_7.2.1.bb b/meta/recipes-devtools/python/python3-pytest_7.2.1.bb
index 105b76a4a64..c7610d440c1 100644
--- a/meta/recipes-devtools/python/python3-pytest_7.2.1.bb
+++ b/meta/recipes-devtools/python/python3-pytest_7.2.1.bb
@@ -11,7 +11,7 @@  DEPENDS += "python3-setuptools-scm-native"
 
 inherit update-alternatives pypi python_setuptools_build_meta
 
-RDEPENDS:${PN}:class-target += " \
+RDEPENDS:${PN} += " \
     ${PYTHON_PN}-atomicwrites \
     ${PYTHON_PN}-attrs \
     ${PYTHON_PN}-debugger \