diff mbox series

graphene: disable neon support on arm 32bits

Message ID 20230211082609.6471-1-f_l_k@t-online.de
State New
Headers show
Series graphene: disable neon support on arm 32bits | expand

Commit Message

Markus Volk Feb. 11, 2023, 8:26 a.m. UTC
From: Pablo Saavedra <psaavedra@igalia.com>

This disables neon support on arm devices only because it crashes otherwise.

Upstream-status: Reported [https://github.com/ebassi/graphene/issues/215]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-graphics/graphene/graphene_1.10.8.bb | 3 +++
 1 file changed, 3 insertions(+)

Comments

Richard Purdie Feb. 11, 2023, 9:05 a.m. UTC | #1
On Sat, 2023-02-11 at 09:26 +0100, Markus Volk wrote:
> From: Pablo Saavedra <psaavedra@igalia.com>
> 
> This disables neon support on arm devices only because it crashes otherwise.
> 
> Upstream-status: Reported [https://github.com/ebassi/graphene/issues/215]
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  meta/recipes-graphics/graphene/graphene_1.10.8.bb | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/meta/recipes-graphics/graphene/graphene_1.10.8.bb b/meta/recipes-graphics/graphene/graphene_1.10.8.bb
> index 813ff74adf..1bbe7ecca1 100644
> --- a/meta/recipes-graphics/graphene/graphene_1.10.8.bb
> +++ b/meta/recipes-graphics/graphene/graphene_1.10.8.bb
> @@ -17,6 +17,9 @@ GTKDOC_MESON_OPTION = "gtk_doc"
>  
>  EXTRA_OEMESON = "-Dinstalled_tests=false"
>  
> +# Disable ARM NEON support
> +EXTRA_OEMESON:append:arm = " -Darm_neon=false"
> +
>  FILES:${PN} += "${libdir}/graphene-1.0"
>  
>  BBCLASSEXTEND = "native nativesdk"

Can we tweak the comment to say why? Saying what it does isn't that
useful, saying why it does it helps to understand when it may be
removed in future. An example of how to crash it would be even better.
Was this just some some subset of 32 bit arm or all 32 bit arm?

Cheers,

Richard
Markus Volk Feb. 13, 2023, 9:47 a.m. UTC | #2
Am Sa, 11. Feb 2023 um 09:05:05 +0000 schrieb Richard Purdie 
<richard.purdie@linuxfoundation.org>:
> Can we tweak the comment to say why? Saying what it does isn't that
> useful, saying why it does it helps to understand when it may be
> removed in future. An example of how to crash it would be even better.
> Was this just some some subset of 32 bit arm or all 32 bit arm?
> 
> Cheers,
> 
> Richard

Hello Richard,

I'm not affected by this bug, none of my machines has it but probably  
the underlying problem is, that there are still issues with neon 
runtime detection and not all arm platforms are guaranteed to have NEON 
available. That said, maybe it would be better to add this as a 
PACKAGECONFIG, so people could at least manually enable neon support if 
they know it would be working for them?
Markus Volk Feb. 13, 2023, 10:15 a.m. UTC | #3
sent a patch for it

> maybe it would be better to add this as a PACKAGECONFIG, so people 
> could at least manually enable neon support if they know it would be 
> working for them?
Alexandre Belloni Feb. 13, 2023, 9:06 p.m. UTC | #4
On 13/02/2023 10:47:19+0100, Markus Volk wrote:
> Am Sa, 11. Feb 2023 um 09:05:05 +0000 schrieb Richard Purdie
> <richard.purdie@linuxfoundation.org>:
> > Can we tweak the comment to say why? Saying what it does isn't that
> > useful, saying why it does it helps to understand when it may be
> > removed in future. An example of how to crash it would be even better.
> > Was this just some some subset of 32 bit arm or all 32 bit arm?
> > 
> > Cheers,
> > 
> > Richard
> 
> Hello Richard,
> 
> I'm not affected by this bug, none of my machines has it but probably  the
> underlying problem is, that there are still issues with neon runtime
> detection and not all arm platforms are guaranteed to have NEON available.
> That said, maybe it would be better to add this as a PACKAGECONFIG, so
> people could at least manually enable neon support if they know it would be
> working for them?
> 

Can't we get that out of the tune?


> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#177087): https://lists.openembedded.org/g/openembedded-core/message/177087
> Mute This Topic: https://lists.openembedded.org/mt/96893757/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Markus Volk Feb. 14, 2023, 5:45 a.m. UTC | #5
Am Mo, 13. Feb 2023 um 22:06:57 +0100 schrieb Alexandre Belloni via 
lists.openembedded.org 
<alexandre.belloni=bootlin.com@lists.openembedded.org>:
> 
> Can't we get that out of the tune?

The problem I see is that we would need to know for sure what works and 
what doesn't.
diff mbox series

Patch

diff --git a/meta/recipes-graphics/graphene/graphene_1.10.8.bb b/meta/recipes-graphics/graphene/graphene_1.10.8.bb
index 813ff74adf..1bbe7ecca1 100644
--- a/meta/recipes-graphics/graphene/graphene_1.10.8.bb
+++ b/meta/recipes-graphics/graphene/graphene_1.10.8.bb
@@ -17,6 +17,9 @@  GTKDOC_MESON_OPTION = "gtk_doc"
 
 EXTRA_OEMESON = "-Dinstalled_tests=false"
 
+# Disable ARM NEON support
+EXTRA_OEMESON:append:arm = " -Darm_neon=false"
+
 FILES:${PN} += "${libdir}/graphene-1.0"
 
 BBCLASSEXTEND = "native nativesdk"