diff mbox series

[meta-ti,master] linux-bb.org: work around for too few arguments to function init_disassemble_info() error

Message ID 20230207142417.14353-1-reatmon@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,master] linux-bb.org: work around for too few arguments to function init_disassemble_info() error | expand

Commit Message

Ryan Eatmon Feb. 7, 2023, 2:24 p.m. UTC
binutils 2.39 changed the signature of init_disassemble_info(),
which now causes perf and bpftool to fail to compile.

Relevant binutils commit: [1]

There is a proper fix in development upstream[2].
This is a work-around for older kernels.

Inspired by a patch by Anton Antonov to fix this issue on meta-arm
kernels. [3]

[1] https://sourceware.org/git/?p=binutils-gdb.git;a=commitdiff;h=60a3da00bd5407f07d64dff82a4dae98230dfaac
[2] https://patchwork.kernel.org/project/netdevbpf/cover/20220801013834.156015-1-andres@anarazel.de/
[3] https://patchwork.yoctoproject.org/project/arm/patch/20220824025819.4888-1-jon.mason@arm.com/#5104

Signed-off-by: Ryan Eatmon <reatmon@ti.com>
---
 meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Denys Dmytriyenko Feb. 7, 2023, 5:30 p.m. UTC | #1
On Tue, Feb 07, 2023 at 08:24:17AM -0600, Ryan Eatmon via lists.yoctoproject.org wrote:
> binutils 2.39 changed the signature of init_disassemble_info(),
> which now causes perf and bpftool to fail to compile.
> 
> Relevant binutils commit: [1]
> 
> There is a proper fix in development upstream[2].
> This is a work-around for older kernels.
> 
> Inspired by a patch by Anton Antonov to fix this issue on meta-arm
> kernels. [3]
> 
> [1] https://sourceware.org/git/?p=binutils-gdb.git;a=commitdiff;h=60a3da00bd5407f07d64dff82a4dae98230dfaac
> [2] https://patchwork.kernel.org/project/netdevbpf/cover/20220801013834.156015-1-andres@anarazel.de/
> [3] https://patchwork.yoctoproject.org/project/arm/patch/20220824025819.4888-1-jon.mason@arm.com/#5104
> 
> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
> ---
>  meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb
> index 2e0f2448..35fb40cd 100644
> --- a/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb
> +++ b/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb
> @@ -25,7 +25,8 @@ SRCREV:k3 = "11ebcc09f32669fac8254dff56d500f86c4c2caf"
>  PV:k3 = "5.10.153+git${SRCPV}"
>  BRANCH:k3 = "5.10-arm64"
>  
> -SRC_URI = "git://git.beagleboard.org/beagleboard/linux.git;protocol=https;branch=${BRANCH}"
> +SRC_URI = "git://git.beagleboard.org/beagleboard/linux.git;protocol=https;branch=${BRANCH} \
> +           file://init_disassemble_info-signature-changes-causes-compile-failures.patch"

Did you forget to add the patch?


>  DEFCONFIG_NAME = "bb.org_defconfig"
>  KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}"
> -- 
> 2.17.1
Ryan Eatmon Feb. 7, 2023, 10:44 p.m. UTC | #2
On 2/7/2023 11:30, Denys Dmytriyenko wrote:
> On Tue, Feb 07, 2023 at 08:24:17AM -0600, Ryan Eatmon via lists.yoctoproject.org wrote:
>> binutils 2.39 changed the signature of init_disassemble_info(),
>> which now causes perf and bpftool to fail to compile.
>>
>> Relevant binutils commit: [1]
>>
>> There is a proper fix in development upstream[2].
>> This is a work-around for older kernels.
>>
>> Inspired by a patch by Anton Antonov to fix this issue on meta-arm
>> kernels. [3]
>>
>> [1] https://sourceware.org/git/?p=binutils-gdb.git;a=commitdiff;h=60a3da00bd5407f07d64dff82a4dae98230dfaac
>> [2] https://patchwork.kernel.org/project/netdevbpf/cover/20220801013834.156015-1-andres@anarazel.de/
>> [3] https://patchwork.yoctoproject.org/project/arm/patch/20220824025819.4888-1-jon.mason@arm.com/#5104
>>
>> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
>> ---
>>   meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb | 3 ++-
>>   1 file changed, 2 insertions(+), 1 deletion(-)
>>
>> diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb
>> index 2e0f2448..35fb40cd 100644
>> --- a/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb
>> +++ b/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb
>> @@ -25,7 +25,8 @@ SRCREV:k3 = "11ebcc09f32669fac8254dff56d500f86c4c2caf"
>>   PV:k3 = "5.10.153+git${SRCPV}"
>>   BRANCH:k3 = "5.10-arm64"
>>   
>> -SRC_URI = "git://git.beagleboard.org/beagleboard/linux.git;protocol=https;branch=${BRANCH}"
>> +SRC_URI = "git://git.beagleboard.org/beagleboard/linux.git;protocol=https;branch=${BRANCH} \
>> +           file://init_disassemble_info-signature-changes-causes-compile-failures.patch"
> 
> Did you forget to add the patch?

No, the patch was introduced for the linux-ti-staging back in November. 
So the patch is already in the repo, this recipe just needs to include 
it in order to compile on master.

> 
>>   DEFCONFIG_NAME = "bb.org_defconfig"
>>   KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}"
>> -- 
>> 2.17.1
diff mbox series

Patch

diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb
index 2e0f2448..35fb40cd 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb
@@ -25,7 +25,8 @@  SRCREV:k3 = "11ebcc09f32669fac8254dff56d500f86c4c2caf"
 PV:k3 = "5.10.153+git${SRCPV}"
 BRANCH:k3 = "5.10-arm64"
 
-SRC_URI = "git://git.beagleboard.org/beagleboard/linux.git;protocol=https;branch=${BRANCH}"
+SRC_URI = "git://git.beagleboard.org/beagleboard/linux.git;protocol=https;branch=${BRANCH} \
+           file://init_disassemble_info-signature-changes-causes-compile-failures.patch"
 
 DEFCONFIG_NAME = "bb.org_defconfig"
 KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}"