diff mbox series

[meta-oe] cmark: upgrade 0.30.2 -> 0.30.3

Message ID 1675768744-3871-4-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-oe] cmark: upgrade 0.30.2 -> 0.30.3 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 7, 2023, 11:19 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
  * Fix quadratic complexity bug with repeated '![[]()'.
    Resolves CVE-2023-22486. Add new pathological test.

  * Allow declarations with no space, as per spec

  * Set 'enumi*' counter correctly in LaTeX output

  * Allow '<!DOCTYPE' to be case-insensitive.
    existing spec.)

  * Fixed HTML comment scanning. Need to handle this case: '<!--> and -->'.
    Since the scanner finds the longest match, we had to
    move some of the logic outside of the scanner.

  * Fix quadratic parsing issue with repeated '<!--' (this was not
    introduced by the previous fix, and not in a released version of cmark).
    Resolves CVE-2023-22484. Add new pathological test.

  * Update HTML comment scanner to accord with commonmark/commonmark-spec#713

  * Pathological tests: half the number of repetitions, and the timeout.
    This reduces the time needed for the pathological tests.

  * Shrink 'struct cmark_node' (#446). The 'internal_offset' member is
    only used for headings and can be moved to 'struct cmark_heading'.
    This reduces the size of 'struct cmark_node' from 112 to 104 bytes on
    64-bit systems.

  * Add '-Wstrict-prototypes' and fix offending functions.

  * Fix quadratic behavior involving 'get_containing_block' (#431).
    Instead of searching for the containing block, update the tight list
    status when entering a child of a list item or exiting a list.

  * Fix 'pathological_tests.py'
    - Use a multiprocessing.Queue to actually get results from spawned
      tests processes.
    - Fix the 'allowed_failures' test.
    - Truncate actual output when printed.
    - Prepare for testing pathological behavior of the Commonmark renderer.

  * Fix source position bug with backticks

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../recipes-support/cmark/{cmark_0.30.2.bb => cmark_0.30.3.bb}  | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-oe/recipes-support/cmark/{cmark_0.30.2.bb => cmark_0.30.3.bb} (89%)
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/cmark/cmark_0.30.2.bb b/meta-oe/recipes-support/cmark/cmark_0.30.3.bb
similarity index 89%
rename from meta-oe/recipes-support/cmark/cmark_0.30.2.bb
rename to meta-oe/recipes-support/cmark/cmark_0.30.3.bb
index 6d6d3e585..6697dfe07 100644
--- a/meta-oe/recipes-support/cmark/cmark_0.30.2.bb
+++ b/meta-oe/recipes-support/cmark/cmark_0.30.3.bb
@@ -4,7 +4,7 @@  LICENSE = "BSD-2-Clause & MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=81f9cae6293cc0345a9144b78152ab62"
 
 SRC_URI = "git://github.com/commonmark/cmark.git;branch=master;protocol=https"
-SRCREV = "a8da5a2f252b96eca60ae8bada1a9ba059a38401"
+SRCREV = "5ba25ff40eba44c811f79ab6a792baf945b8307c"
 S = "${WORKDIR}/git"
 
 inherit cmake lib_package