diff mbox series

[meta-oe] extract-cert: add recipe

Message ID 20230131110231.1700882-1-jlu@pengutronix.de
State Under Review
Headers show
Series [meta-oe] extract-cert: add recipe | expand

Commit Message

Jan Lübbe Jan. 31, 2023, 11:02 a.m. UTC
The extract-cert tool is used to fetch the X.509 certificate associated
with a key from a PKCS#11 token (such as a HSM or YubiKey). This version
is derived from certs/extract-cert in the Linux kernel as a stand-alone
tool to make it available when signing other software components besides
the kernel.

Signed-off-by: Jan Luebbe <jlu@pengutronix.de>
---
 .../extract-cert/extract-cert_git.bb             | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
 create mode 100644 meta-oe/recipes-devtools/extract-cert/extract-cert_git.bb

Comments

Khem Raj Jan. 31, 2023, 3:56 p.m. UTC | #1
On Tue, Jan 31, 2023 at 3:03 AM Jan Luebbe <jlu@pengutronix.de> wrote:
>
> The extract-cert tool is used to fetch the X.509 certificate associated
> with a key from a PKCS#11 token (such as a HSM or YubiKey). This version
> is derived from certs/extract-cert in the Linux kernel as a stand-alone
> tool to make it available when signing other software components besides
> the kernel.
>
> Signed-off-by: Jan Luebbe <jlu@pengutronix.de>
> ---
>  .../extract-cert/extract-cert_git.bb             | 16 ++++++++++++++++
>  1 file changed, 16 insertions(+)
>  create mode 100644 meta-oe/recipes-devtools/extract-cert/extract-cert_git.bb
>
> diff --git a/meta-oe/recipes-devtools/extract-cert/extract-cert_git.bb b/meta-oe/recipes-devtools/extract-cert/extract-cert_git.bb
> new file mode 100644
> index 000000000000..b2007eb8214f
> --- /dev/null
> +++ b/meta-oe/recipes-devtools/extract-cert/extract-cert_git.bb
> @@ -0,0 +1,16 @@
> +SUMMARY = "small helper program to extract X.509 certificates from PKCS#11 tokens"
> +LICENSE = "LGPL-2.1-or-later"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
> +
> +DEPENDS = "openssl"
> +
> +SRC_URI = "git://git.pengutronix.de/git/extract-cert;protocol=https;branch=master;"
> +SRCREV = "d652b4e8279aef2a85f58676ab472744bafeafc9"
> +
> +PV = "0.3"

Rename the recipe to extract-cert_0.3.bb and remove the PV setting here.

> +
> +S = "${WORKDIR}/git"
> +
> +inherit meson pkgconfig
> +
> +BBCLASSEXTEND = "native nativesdk"
> --
> 2.30.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#100875): https://lists.openembedded.org/g/openembedded-devel/message/100875
> Mute This Topic: https://lists.openembedded.org/mt/96649870/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/extract-cert/extract-cert_git.bb b/meta-oe/recipes-devtools/extract-cert/extract-cert_git.bb
new file mode 100644
index 000000000000..b2007eb8214f
--- /dev/null
+++ b/meta-oe/recipes-devtools/extract-cert/extract-cert_git.bb
@@ -0,0 +1,16 @@ 
+SUMMARY = "small helper program to extract X.509 certificates from PKCS#11 tokens"
+LICENSE = "LGPL-2.1-or-later"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+DEPENDS = "openssl"
+
+SRC_URI = "git://git.pengutronix.de/git/extract-cert;protocol=https;branch=master;"
+SRCREV = "d652b4e8279aef2a85f58676ab472744bafeafc9"
+
+PV = "0.3"
+
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig
+
+BBCLASSEXTEND = "native nativesdk"