diff mbox series

[meta-oe,7/8] tesseract: Fix build with gcc13

Message ID 20230131015200.3862532-7-raj.khem@gmail.com
State New
Headers show
Series [meta-oe,1/8] zeromq: Fix build with gcc13 | expand

Commit Message

Khem Raj Jan. 31, 2023, 1:51 a.m. UTC
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 ...ild-with-gcc-13-by-including-cstdint.patch | 32 +++++++++++++++++++
 .../tesseract/tesseract_5.3.0.bb              |  2 +-
 2 files changed, 33 insertions(+), 1 deletion(-)
 create mode 100644 meta-oe/recipes-graphics/tesseract/tesseract/0001-Fix-build-with-gcc-13-by-including-cstdint.patch
diff mbox series

Patch

diff --git a/meta-oe/recipes-graphics/tesseract/tesseract/0001-Fix-build-with-gcc-13-by-including-cstdint.patch b/meta-oe/recipes-graphics/tesseract/tesseract/0001-Fix-build-with-gcc-13-by-including-cstdint.patch
new file mode 100644
index 0000000000..2978080c92
--- /dev/null
+++ b/meta-oe/recipes-graphics/tesseract/tesseract/0001-Fix-build-with-gcc-13-by-including-cstdint.patch
@@ -0,0 +1,32 @@ 
+From 2025b53de6b3d97285d7c5f80497493007c586c3 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 30 Jan 2023 11:27:07 -0800
+Subject: [PATCH] Fix build with gcc 13 by including <cstdint>
+
+gcc 13 moved some includes around and as a result <cstdint> is
+no longer transitively included [1]. Explicitly include it for
+int32_t.
+
+[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
+
+Upstream-Status: Submitted [https://github.com/tesseract-ocr/tesseract/pull/4009]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/ccutil/params.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/ccutil/params.h b/src/ccutil/params.h
+index f514d870..0f3f8743 100644
+--- a/src/ccutil/params.h
++++ b/src/ccutil/params.h
+@@ -21,6 +21,7 @@
+ 
+ #include <tesseract/export.h> // for TESS_API
+ 
++#include <cstdint>
+ #include <cstdio>
+ #include <cstring>
+ #include <string>
+-- 
+2.39.1
+
diff --git a/meta-oe/recipes-graphics/tesseract/tesseract_5.3.0.bb b/meta-oe/recipes-graphics/tesseract/tesseract_5.3.0.bb
index f791ad546b..057a7cd859 100644
--- a/meta-oe/recipes-graphics/tesseract/tesseract_5.3.0.bb
+++ b/meta-oe/recipes-graphics/tesseract/tesseract_5.3.0.bb
@@ -7,7 +7,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 SRCREV = "080da83cc51c4ef8b324a7e03146fe0bd7e0944b"
 SRC_URI = "git://github.com/${BPN}-ocr/${BPN}.git;branch=main;protocol=https \
-          "
+           file://0001-Fix-build-with-gcc-13-by-including-cstdint.patch"
 
 S = "${WORKDIR}/git"