[meta-webserver] netdata: fix for commit 8554624cc7f84e6b63b2ea4b94ee5fd2821021ca

Message ID 20211223185132.52980-1-jan.vermaete@gmail.com
State New
Headers show
Series [meta-webserver] netdata: fix for commit 8554624cc7f84e6b63b2ea4b94ee5fd2821021ca | expand

Commit Message

Jan Vermaete Dec. 23, 2021, 6:51 p.m. UTC
The previous commit was using a PACKAGECONFIG to enable or disable
the sending of anonymous data to Google Analytics.
This was giving QA issues.

Now the variable 'NETDATA_ANONYMOUS' is used to enable or disable
the opt-out.

Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com>
---
 meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb | 8 +++-----
 1 file changed, 3 insertions(+), 5 deletions(-)

Patch

diff --git a/meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb b/meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb
index 6824dd725..dbce1c432 100644
--- a/meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb
+++ b/meta-webserver/recipes-webadmin/netdata/netdata_1.32.1.bb
@@ -20,9 +20,8 @@  UPSTREAM_CHECK_URI = "https://github.com/netdata/netdata/releases"
 
 S = "${WORKDIR}/${BPN}-v${PV}"
 
-PACKAGECONFIG ??= "\
-    anonymous \
-"
+# Stop sending anonymous statistics to Google Analytics
+NETDATA_ANONYMOUS ??= "enabled"
 
 inherit pkgconfig autotools-brokensep useradd systemd
 
@@ -62,8 +61,7 @@  do_install:append() {
     sed -i -e 's,@@libdir,${libexecdir},g' ${D}${sysconfdir}/netdata/netdata.conf
     sed -i -e 's,@@datadir,${datadir},g' ${D}${sysconfdir}/netdata/netdata.conf
 
-    # Stop sending anonymous statistics to Google Analytics
-    if ${@bb.utils.contains('PACKAGECONFIG', 'anonymous', 'true', 'false', d)}; then
+    if [ "${NETDATA_ANONYMOUS}" = "enabled" ]; then
         touch ${D}${sysconfdir}/netdata/.opt-out-from-anonymous-statistics
     fi