diff mbox series

[meta-python] python3-mock: upgrade 5.0.0 -> 5.0.1

Message ID 1673940264-20487-1-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [meta-python] python3-mock: upgrade 5.0.0 -> 5.0.1 | expand

Commit Message

Mingyu Wang (Fujitsu) Jan. 17, 2023, 7:24 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
- gh-100740: Fix unittest.mock.Mock not respecting the spec for attribute names
  prefixed with assert.
- gh-100690: Mock objects which are not unsafe will now raise an AttributeError
  when accessing an attribute that matches the name of an assertion but without
  the prefix assert_, e.g. accessing called_once instead of assert_called_once.
  This is in addition to this already happening for accessing attributes with
  prefixes assert, assret, asert, aseert, and assrt.
- gh-96127: inspect.signature was raising TypeError on call with mock objects.
  Now it correctly returns (*args, **kwargs) as infered signature.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-mock_5.0.0.bb => python3-mock_5.0.1.bb}     | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-mock_5.0.0.bb => python3-mock_5.0.1.bb} (84%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-mock_5.0.0.bb b/meta-python/recipes-devtools/python/python3-mock_5.0.1.bb
similarity index 84%
rename from meta-python/recipes-devtools/python/python3-mock_5.0.0.bb
rename to meta-python/recipes-devtools/python/python3-mock_5.0.1.bb
index dcc57c22b..b916a7b4e 100644
--- a/meta-python/recipes-devtools/python/python3-mock_5.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-mock_5.0.1.bb
@@ -13,4 +13,4 @@  RDEPENDS:${PN} += "${PYTHON_PN}-prettytable \
             ${PYTHON_PN}-pep8 \
             ${PYTHON_PN}-pyflakes"
 
-SRC_URI[sha256sum] = "fd552787228eb2ab8352f270470fa93c9ad8b9cbc565c5558ee3faed8edb3853"
+SRC_URI[sha256sum] = "e3ea505c03babf7977fd21674a69ad328053d414f05e6433c30d8fa14a534a6b"