diff mbox series

[meta-gnome] webp-pixbuf-loader: add recipe

Message ID 20230115165248.5628-1-f_l_k@t-online.de
State Under Review
Headers show
Series [meta-gnome] webp-pixbuf-loader: add recipe | expand

Commit Message

Markus Volk Jan. 15, 2023, 4:52 p.m. UTC
This adds a gdk-pixbuf loader for webp images. It fixes thumbnailing and
adds support for webp in e.g. gnome-viewer (eog).
gnome-background contains lots of webp images. The default wallpaper is
set to 'adwaita-d.webp' and gnome-shell fails to load it.

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 .../webp-pixbuf-loader_0.7.bb                 | 23 +++++++++++++++++++
 1 file changed, 23 insertions(+)
 create mode 100644 meta-gnome/recipes-support/webp-pixbuf-loader/webp-pixbuf-loader_0.7.bb
diff mbox series

Patch

diff --git a/meta-gnome/recipes-support/webp-pixbuf-loader/webp-pixbuf-loader_0.7.bb b/meta-gnome/recipes-support/webp-pixbuf-loader/webp-pixbuf-loader_0.7.bb
new file mode 100644
index 000000000..17a343674
--- /dev/null
+++ b/meta-gnome/recipes-support/webp-pixbuf-loader/webp-pixbuf-loader_0.7.bb
@@ -0,0 +1,23 @@ 
+SUMMARY = "WebP GDK Pixbuf Loader library"
+HOMEPAGE = "https://github.com/aruiz/webp-pixbuf-loader"
+LICENSE = "LGPL-2.1-or-later"
+LIC_FILES_CHKSUM = "file://LICENSE.LGPL-2;md5=0d90e6d44bcf69014bfae649c75aa6ca"
+
+DEPENDS = " \
+    gdk-pixbuf \
+    libwebp \
+"
+
+inherit meson pkgconfig
+
+EXTRA_OEMESON = "-Dupdate_cache=true"
+
+SRC_URI = "git://github.com/aruiz/webp-pixbuf-loader.git;protocol=https;nobranch=1"
+
+S = "${WORKDIR}/git"
+SRCREV = "f91f79c05ff90b41774eda613dc10a2a0d996bc8"
+
+FILES:${PN} = " \
+    ${datadir}/thumbnailers/webp-pixbuf.thumbnailer \
+    ${libdir}/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-webp.so \
+"