diff mbox series

[meta-python,PATCHv2] python3-astroid: Upgrade 2.12.13 -> 2.13.2

Message ID 20230112145557.1780277-1-leon.anavi@konsulko.com
State Under Review
Headers show
Series [meta-python,PATCHv2] python3-astroid: Upgrade 2.12.13 -> 2.13.2 | expand

Commit Message

Leon Anavi Jan. 12, 2023, 2:55 p.m. UTC
Upgrade to release 2.13.2:

- Removed version conditions on typing_extensions dependency.
- Removed typing_extensions from our tests requirements as it was
  preventing issues to appear in our continuous integration.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../0001-pyproject.toml-Replace-with.patch    | 27 +++++++++++++++++++
 ...d_2.12.13.bb => python3-astroid_2.13.2.bb} | 13 ++++++---
 2 files changed, 37 insertions(+), 3 deletions(-)
 create mode 100644 meta-python/recipes-devtools/python/python3-astroid/0001-pyproject.toml-Replace-with.patch
 rename meta-python/recipes-devtools/python/{python3-astroid_2.12.13.bb => python3-astroid_2.13.2.bb} (71%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-astroid/0001-pyproject.toml-Replace-with.patch b/meta-python/recipes-devtools/python/python3-astroid/0001-pyproject.toml-Replace-with.patch
new file mode 100644
index 000000000..3e1a17be9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-astroid/0001-pyproject.toml-Replace-with.patch
@@ -0,0 +1,27 @@ 
+From 517f361ba4a6ae430acfe3b83986d32b4f811b58 Mon Sep 17 00:00:00 2001
+From: Leon Anavi <leon.anavi@konsulko.com>
+Date: Wed, 11 Jan 2023 13:56:24 +0200
+Subject: [PATCH] pyproject.toml: Replace ~= with >=
+
+Replace ~= with >= to avoid errors if the version is not exactly
+the same.
+
+Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
+---
+ pyproject.toml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index 537bca9a..a01e0d45 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -1,5 +1,5 @@
+ [build-system]
+-requires = ["setuptools~=62.6", "wheel~=0.37.1"]
++requires = ["setuptools>=62.6", "wheel>=0.37.1"]
+ build-backend = "setuptools.build_meta"
+ 
+ [project]
+-- 
+2.30.2
+
diff --git a/meta-python/recipes-devtools/python/python3-astroid_2.12.13.bb b/meta-python/recipes-devtools/python/python3-astroid_2.13.2.bb
similarity index 71%
rename from meta-python/recipes-devtools/python/python3-astroid_2.12.13.bb
rename to meta-python/recipes-devtools/python/python3-astroid_2.13.2.bb
index ca87ff013..fa22080d3 100644
--- a/meta-python/recipes-devtools/python/python3-astroid_2.12.13.bb
+++ b/meta-python/recipes-devtools/python/python3-astroid_2.13.2.bb
@@ -4,11 +4,18 @@  SECTION = "devel/python"
 LICENSE = "LGPL-2.1-only"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=a70cf540abf41acb644ac3b621b2fad1"
 
-SRC_URI[sha256sum] = "1493fe8bd3dfd73dc35bd53c9d5b6e49ead98497c47b2307662556a5692d29d7"
+SRC_URI[sha256sum] = "3bc7834720e1a24ca797fd785d77efb14f7a28ee8e635ef040b6e2d80ccb3303"
 
-inherit pypi setuptools3
+SRC_URI += " \
+    file://0001-pyproject.toml-Replace-with.patch \
+"
+
+inherit pypi python_setuptools_build_meta
 
-DEPENDS += "${PYTHON_PN}-pytest-runner-native"
+DEPENDS += "\
+    ${PYTHON_PN}-pytest-runner-native \
+    ${PYTHON_PN}-wheel-native \
+"
 
 PACKAGES =+ "${PN}-tests"