layers: set LAYERSERIES_COMPAT with honister

Submitted by Kang Kai on June 4, 2021, 1:44 a.m. | Patch ID: 179824

Details

Message ID 20210604014438.33958-1-kai.kang@windriver.com
State Master Next
Commit 4e4caec94da63bf566c635739cee7c3e537b1989
Headers show

Commit Message

Kang Kai June 4, 2021, 1:44 a.m.
From: Kai Kang <kai.kang@windriver.com>

Set LAYERSERIES_COMPAT with 'honister' which align with oe-core.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
 meta-filesystems/conf/layer.conf | 2 +-
 meta-gnome/conf/layer.conf       | 2 +-
 meta-initramfs/conf/layer.conf   | 2 +-
 meta-multimedia/conf/layer.conf  | 2 +-
 meta-networking/conf/layer.conf  | 2 +-
 meta-oe/conf/layer.conf          | 2 +-
 meta-perl/conf/layer.conf        | 2 +-
 meta-python/conf/layer.conf      | 2 +-
 meta-webserver/conf/layer.conf   | 2 +-
 meta-xfce/conf/layer.conf        | 2 +-
 10 files changed, 10 insertions(+), 10 deletions(-)

Patch hide | download patch | download mbox

diff --git a/meta-filesystems/conf/layer.conf b/meta-filesystems/conf/layer.conf
index ae93a36b4..6a9357d2a 100644
--- a/meta-filesystems/conf/layer.conf
+++ b/meta-filesystems/conf/layer.conf
@@ -15,4 +15,4 @@  LAYERVERSION_filesystems-layer = "1"
 
 LAYERDEPENDS_filesystems-layer = "core openembedded-layer"
 
-LAYERSERIES_COMPAT_filesystems-layer = " hardknott"
+LAYERSERIES_COMPAT_filesystems-layer = "honister"
diff --git a/meta-gnome/conf/layer.conf b/meta-gnome/conf/layer.conf
index ba2d59948..09b2ecf70 100644
--- a/meta-gnome/conf/layer.conf
+++ b/meta-gnome/conf/layer.conf
@@ -17,7 +17,7 @@  LAYERVERSION_gnome-layer = "1"
 
 LAYERDEPENDS_gnome-layer = "core openembedded-layer networking-layer"
 
-LAYERSERIES_COMPAT_gnome-layer = " hardknott"
+LAYERSERIES_COMPAT_gnome-layer = "honister"
 
 SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += "\
   faenza-icon-theme->gdk-pixbuf \
diff --git a/meta-initramfs/conf/layer.conf b/meta-initramfs/conf/layer.conf
index d1d669373..11dd43178 100644
--- a/meta-initramfs/conf/layer.conf
+++ b/meta-initramfs/conf/layer.conf
@@ -16,7 +16,7 @@  BBFILE_PATTERN_meta-initramfs := "^${LAYERDIR}/"
 BBFILE_PRIORITY_meta-initramfs = "8"
 LAYERDEPENDS_meta-initramfs = "core"
 
-LAYERSERIES_COMPAT_meta-initramfs = " hardknott"
+LAYERSERIES_COMPAT_meta-initramfs = "honister"
 
 SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \
   dracut->virtual/kernel \
diff --git a/meta-multimedia/conf/layer.conf b/meta-multimedia/conf/layer.conf
index 6d3de7c11..5a17a5048 100644
--- a/meta-multimedia/conf/layer.conf
+++ b/meta-multimedia/conf/layer.conf
@@ -31,4 +31,4 @@  LAYERVERSION_multimedia-layer = "1"
 
 LAYERDEPENDS_multimedia-layer = "core meta-python"
 
-LAYERSERIES_COMPAT_multimedia-layer = " hardknott"
+LAYERSERIES_COMPAT_multimedia-layer = "honister"
diff --git a/meta-networking/conf/layer.conf b/meta-networking/conf/layer.conf
index 968b21601..67fcda3d9 100644
--- a/meta-networking/conf/layer.conf
+++ b/meta-networking/conf/layer.conf
@@ -17,7 +17,7 @@  LAYERDEPENDS_networking-layer = "core"
 LAYERDEPENDS_networking-layer += "openembedded-layer"
 LAYERDEPENDS_networking-layer += "meta-python"
 
-LAYERSERIES_COMPAT_networking-layer = " hardknott"
+LAYERSERIES_COMPAT_networking-layer = "honister"
 
 LICENSE_PATH += "${LAYERDIR}/licenses"
 
diff --git a/meta-oe/conf/layer.conf b/meta-oe/conf/layer.conf
index d3aeaba3d..2f0a49e22 100644
--- a/meta-oe/conf/layer.conf
+++ b/meta-oe/conf/layer.conf
@@ -42,7 +42,7 @@  LAYERVERSION_openembedded-layer = "1"
 
 LAYERDEPENDS_openembedded-layer = "core"
 
-LAYERSERIES_COMPAT_openembedded-layer = " hardknott"
+LAYERSERIES_COMPAT_openembedded-layer = "honister"
 
 LICENSE_PATH += "${LAYERDIR}/licenses"
 
diff --git a/meta-perl/conf/layer.conf b/meta-perl/conf/layer.conf
index 87bb91f61..6a2dd7ff9 100644
--- a/meta-perl/conf/layer.conf
+++ b/meta-perl/conf/layer.conf
@@ -15,4 +15,4 @@  LAYERVERSION_perl-layer = "1"
 
 LAYERDEPENDS_perl-layer = "core openembedded-layer"
 
-LAYERSERIES_COMPAT_perl-layer = " hardknott"
+LAYERSERIES_COMPAT_perl-layer = "honister"
diff --git a/meta-python/conf/layer.conf b/meta-python/conf/layer.conf
index ab66ffd8e..ffad953f9 100644
--- a/meta-python/conf/layer.conf
+++ b/meta-python/conf/layer.conf
@@ -14,6 +14,6 @@  LAYERVERSION_meta-python = "1"
 
 LAYERDEPENDS_meta-python = "core (>= 12) openembedded-layer"
 
-LAYERSERIES_COMPAT_meta-python = " hardknott"
+LAYERSERIES_COMPAT_meta-python = "honister"
 
 LICENSE_PATH += "${LAYERDIR}/licenses"
diff --git a/meta-webserver/conf/layer.conf b/meta-webserver/conf/layer.conf
index 7bb497892..46d5a872a 100644
--- a/meta-webserver/conf/layer.conf
+++ b/meta-webserver/conf/layer.conf
@@ -17,7 +17,7 @@  LAYERVERSION_webserver = "1"
 
 LAYERDEPENDS_webserver = "core openembedded-layer"
 
-LAYERSERIES_COMPAT_webserver = " hardknott"
+LAYERSERIES_COMPAT_webserver = "honister"
 
 LICENSE_PATH += "${LAYERDIR}/licenses"
 
diff --git a/meta-xfce/conf/layer.conf b/meta-xfce/conf/layer.conf
index b1240b06e..81e7dc5ad 100644
--- a/meta-xfce/conf/layer.conf
+++ b/meta-xfce/conf/layer.conf
@@ -19,7 +19,7 @@  LAYERDEPENDS_xfce-layer += "multimedia-layer"
 LAYERDEPENDS_xfce-layer += "meta-python"
 LAYERDEPENDS_xfce-layer += "networking-layer"
 
-LAYERSERIES_COMPAT_xfce-layer = " hardknott"
+LAYERSERIES_COMPAT_xfce-layer = "honister"
 
 SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += "\
   openzone->gdk-pixbuf \

Comments

Martin Jansa June 4, 2021, 8:52 a.m.
On Fri, Jun 4, 2021 at 3:44 AM kai <kai.kang@windriver.com> wrote:

> From: Kai Kang <kai.kang@windriver.com>
>
> Set LAYERSERIES_COMPAT with 'honister' which align with oe-core.
>
>
I think it's bad practice to claim honister support this early in its
development cycle. It won't happen with well-maintained layers like
meta-oe, but if some less frequently updated layer sets the compatibility
with honister now and then doesn't get necessary updates to stay compatible
with honister in next 4 months, then whole purpose of LAYERSERIES_COMPAT
will get broken just by claiming the compatibility too soon (without even
knowing what final honister will contain).

Changing it after release freeze in oe-core seems much better time to do it.

The same does apply on the meta-qt5 PR you've sent today
https://github.com/meta-qt5/meta-qt5/pull/416/commits

Cheers,
-=-=-=-=-=-=-=-=-=-=-=-
Links: You receive all messages sent to this group.
View/Reply Online (#91723): https://lists.openembedded.org/g/openembedded-devel/message/91723
Mute This Topic: https://lists.openembedded.org/mt/83299354/3617530
Group Owner: openembedded-devel+owner@lists.openembedded.org
Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [oe-patchwork@oe-patch.openembedded.org]
-=-=-=-=-=-=-=-=-=-=-=-
Kang Kai June 4, 2021, 9:25 a.m.
On 6/4/21 4:52 PM, Martin Jansa wrote:
> On Fri, Jun 4, 2021 at 3:44 AM kai <kai.kang@windriver.com 
> <mailto:kai.kang@windriver.com>> wrote:
>
>     From: Kai Kang <kai.kang@windriver.com
>     <mailto:kai.kang@windriver.com>>
>
>     Set LAYERSERIES_COMPAT with 'honister' which align with oe-core.
>
>
> I think it's bad practice to claim honister support this early in its 
> development cycle. It won't happen with well-maintained layers like 
> meta-oe, but if some less frequently updated layer sets the 
> compatibility with honister now and then doesn't get necessary updates 
> to stay compatible with honister in next 4 months, then whole purpose 
> of LAYERSERIES_COMPAT will get broken just by claiming the 
> compatibility too soon (without even knowing what final honister will 
> contain).
>
> Changing it after release freeze in oe-core seems much better time to 
> do it.
>
> The same does apply on the meta-qt5 PR you've sent today 
> https://github.com/meta-qt5/meta-qt5/pull/416/commits 
> <https://urldefense.com/v3/__https://github.com/meta-qt5/meta-qt5/pull/416/commits__;!!AjveYdw8EvQ!Kd76LvM-JcgNBu85RB8Bu2U6MF7jgfI31fh0o1hXL0VPVFMaEEBpol_tM3o5gwAD5A$>
>
> Cheers,

Got it. Thanks very much.

I've comment on the meta-qt5 PR that too long strings in 
LAYERSERIES_COMPAT will cause layer index complains:

WARNING: YPCompatibleVersion.name: dunfell gatesgarth hardknott: length 
28 exceeds maximum (25), truncating

So what is policy to keep old codenames in LAYERSERIES_COMPAT? IsĀ  that 
ok to keep latest 2(hardknott and honister), please?

Regards,
Martin Jansa June 7, 2021, 8:21 a.m.
Then I believe layer index should be fixed to support longer values, there
are layers which are compatible with multiple releases and it works fine
with bitbake/oe-core, layer index parsing shouldn't be more strict than the
mechanism which is using these variables.

On Fri, Jun 4, 2021 at 11:26 AM Kai <kai.kang@windriver.com> wrote:

> On 6/4/21 4:52 PM, Martin Jansa wrote:
>
> On Fri, Jun 4, 2021 at 3:44 AM kai <kai.kang@windriver.com> wrote:
>
>> From: Kai Kang <kai.kang@windriver.com>
>>
>> Set LAYERSERIES_COMPAT with 'honister' which align with oe-core.
>>
>>
> I think it's bad practice to claim honister support this early in its
> development cycle. It won't happen with well-maintained layers like
> meta-oe, but if some less frequently updated layer sets the compatibility
> with honister now and then doesn't get necessary updates to stay compatible
> with honister in next 4 months, then whole purpose of LAYERSERIES_COMPAT
> will get broken just by claiming the compatibility too soon (without even
> knowing what final honister will contain).
>
> Changing it after release freeze in oe-core seems much better time to do
> it.
>
> The same does apply on the meta-qt5 PR you've sent today
> https://github.com/meta-qt5/meta-qt5/pull/416/commits
> <https://urldefense.com/v3/__https://github.com/meta-qt5/meta-qt5/pull/416/commits__;!!AjveYdw8EvQ!Kd76LvM-JcgNBu85RB8Bu2U6MF7jgfI31fh0o1hXL0VPVFMaEEBpol_tM3o5gwAD5A$>
>
> Cheers,
>
> Got it. Thanks very much.
>
> I've comment on the meta-qt5 PR that too long strings in
> LAYERSERIES_COMPAT will cause layer index complains:
>
> WARNING: YPCompatibleVersion.name: dunfell gatesgarth hardknott: length 28
> exceeds maximum (25), truncating
>
> So what is policy to keep old codenames in LAYERSERIES_COMPAT? Is  that ok
> to keep latest 2(hardknott and honister), please?
>
> Regards,
>
> --
> Kai Kang
> Wind River Linux
>
>
-=-=-=-=-=-=-=-=-=-=-=-
Links: You receive all messages sent to this group.
View/Reply Online (#91753): https://lists.openembedded.org/g/openembedded-devel/message/91753
Mute This Topic: https://lists.openembedded.org/mt/83299354/3617530
Group Owner: openembedded-devel+owner@lists.openembedded.org
Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [oe-patchwork@oe-patch.openembedded.org]
-=-=-=-=-=-=-=-=-=-=-=-