diff mbox series

[meta-python,1/2] devtools: add new recipe for reedsolo

Message ID 20230109-esptool-v1-1-938893bfd362@theobroma-systems.com
State Under Review
Headers show
Series add recipe for esptool and its dependencies | expand

Commit Message

Quentin Schulz Jan. 9, 2023, 5:02 p.m. UTC
reedsolo is a pure-Python Reed Solomon encoder/decoder.
It is required by esptool which will be added in the next commit.
This adds a recipe for the Python module.

Cc: Quentin Schulz <foss+yocto@0leil.net>
Signed-off-by: Quentin Schulz <quentin.schulz@theobroma-systems.com>
---
 .../python3-reedsolo/python3-reedsolo_1.6.1.bb                 | 10 ++++++++++
 1 file changed, 10 insertions(+)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python3-reedsolo/python3-reedsolo_1.6.1.bb b/meta-python/recipes-devtools/python3-reedsolo/python3-reedsolo_1.6.1.bb
new file mode 100644
index 0000000000..51651f3bcf
--- /dev/null
+++ b/meta-python/recipes-devtools/python3-reedsolo/python3-reedsolo_1.6.1.bb
@@ -0,0 +1,10 @@ 
+SUMMARY = "Pure-Python Reed Solomon encoder/decoder"
+HOMEPAGE = "https://github.com/tomerfiliba/reedsolomon"
+LICENSE = "MIT-0 | Unlicense"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ffde61aeb8917e70e0257e0a4b6d103c"
+
+SRC_URI[sha256sum] = "a7ce6b0efad8df491a70b87b6ab3543e751f7700dc4ac0b12081a456ef634f5d"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "python3-core"