[meta-tensorflow,25/25] update LIMITATION.md

Submitted by Hongxu Jia on Dec. 16, 2020, 1:08 p.m. | Patch ID: 178930

Details

Message ID 20201216130822.28476-26-hongxu.jia@windriver.com
State New
Headers show

Commit Message

Hongxu Jia Dec. 16, 2020, 1:08 p.m.
Target arch only supports 32 bit arm and 32 bit x86, 64 bit arm and
64 bit x86. BSP (MACHINE) incluced in above archs should be supported.

Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
---
 LIMITATION.md | 20 +++++++++-----------
 1 file changed, 9 insertions(+), 11 deletions(-)

Patch hide | download patch | download mbox

diff --git a/LIMITATION.md b/LIMITATION.md
index deda0ad..3c69100 100644
--- a/LIMITATION.md
+++ b/LIMITATION.md
@@ -1,21 +1,19 @@ 
 # Limitation
 ```
-* Bazel build takes lots of time, since it like bitbake which has own rules
-  and builds everything from scratch. Currently bazel could not reuse Yocto
-  DEPENDS/RDEPENDS.
+* Target arch only supports 32 bit arm and 32 bit x86, 64 bit arm and
+  64 bit x86. BSP (MACHINE) incluced in above archs should be supported.
+
+* Bazel build takes lots of time, it has own rules and builds everything
+  from scratch. Currently bazel could not reuse Yocto DEPENDS/RDEPENDS.
 
 * In order to run tensorflow cases in a reasonable time, although it builds
-  successfully on qemuarm, qemuarm64, qemumips, qemumips64, qemux86 and
-  qemux86-64, only qemux86-64 with kvm for runtime test.
+  successfully on qemuarm, qemuarm64, qemux86 and qemux86-64, only qemux86-64
+  with kvm for runtime test.
 
-* It failed to use pre-build model to do predict/inference on big-endian platform
-  (such as qemumips), since upstream does not support big-endian very well
+* It failed to use pre-build model to do predict/inference on big-endian
+  platform, since upstream does not support big-endian very well
   https://github.com/tensorflow/tensorflow/issues/16364
 
-* Do not support 32-bit powerpc (qemuppc) since BoringSSL does not support it.
-  (BoringSSL is a fork of OpenSSL used to implement cryptography and TLS across
-  most of Google's products)
-
 * If host(build system) is not x86_64, please add meta-java to BBLAYERS in
   conf/bblayers.conf (git://git.yoctoproject.org/meta-java)
 ```