diff mbox series

[meta-oe,3/4] concurrencykit: Update to 0.7.0

Message ID 20230107030700.1371576-3-raj.khem@gmail.com
State New
Headers show
Series [meta-oe,1/4] libtraceevent: Move plugins into package of its own | expand

Commit Message

Khem Raj Jan. 7, 2023, 3:06 a.m. UTC
Enable riscv as it is supported now

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 ...mpoiler-detection-logic-for-cross-co.patch | 89 +++++++++++++++++++
 .../concurrencykit/concurrencykit/cross.patch | 62 -------------
 .../concurrencykit/concurrencykit_git.bb      | 10 +--
 3 files changed, 93 insertions(+), 68 deletions(-)
 create mode 100644 meta-oe/recipes-devtools/concurrencykit/concurrencykit/0001-configure-Fix-compoiler-detection-logic-for-cross-co.patch
 delete mode 100644 meta-oe/recipes-devtools/concurrencykit/concurrencykit/cross.patch
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/concurrencykit/concurrencykit/0001-configure-Fix-compoiler-detection-logic-for-cross-co.patch b/meta-oe/recipes-devtools/concurrencykit/concurrencykit/0001-configure-Fix-compoiler-detection-logic-for-cross-co.patch
new file mode 100644
index 0000000000..57a587b39e
--- /dev/null
+++ b/meta-oe/recipes-devtools/concurrencykit/concurrencykit/0001-configure-Fix-compoiler-detection-logic-for-cross-co.patch
@@ -0,0 +1,89 @@ 
+From e1dcd27e816520bdabc69511d90c4a2ebc242831 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 6 Jan 2023 18:51:34 -0800
+Subject: [PATCH] configure: Fix compoiler detection logic for
+ cross-compilation
+
+We can not run binaries during cross compile, so poke at compiler to
+figure out if it is clang or gcc, for OE we do not have other compilers
+in opensource world if there are we can extend this logic
+
+Upstream-Status: Inappropriate [OE-Specific]
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ configure | 56 ++++++++++++++++---------------------------------------
+ 1 file changed, 16 insertions(+), 40 deletions(-)
+
+diff --git a/configure b/configure
+index 9066abb..e382e61 100755
+--- a/configure
++++ b/configure
+@@ -661,48 +661,24 @@ if test "$PROFILE"; then
+ fi
+ 
+ printf "Finding suitable compiler........"
+-if test ! -x "${CC}"; then
+-	CC=`pathsearch "${CC:-cc}"`
+-	if test -z "$CC" -o ! -x "$CC"; then
+-		CC=`pathsearch "${CC:-gcc}"`
+-	fi
++if test -z "$CC"; then
++  if test ! -x "${CC}"; then
++	  CC=`pathsearch "${CC:-cc}"`
++	  if test -z "$CC" -o ! -x "$CC"; then
++		  CC=`pathsearch "${CC:-gcc}"`
++	  fi
++  fi
++  assert "$CC" "not found"
++fi
++if `$CC --version | grep gcc >& /dev/null`; then
++  COMPILER=gcc
++elif `$CC --version | grep clang >& /dev/null`; then
++  COMPILER=clang
++else
++  COMPILER="not found"
+ fi
+-assert "$CC" "not found"
+-
+-cat << EOF > .1.c
+-#include <stdio.h>
+-int main(void) {
+-#if defined(_WIN32)
+-#if defined(__MINGW64__)
+-	puts("mingw64");
+-	return (0);
+-#elif defined(__MINGW32__) && (__MINGW32_MAJOR_VERSION >= 3)
+-	puts("mingw32");
+-	return (0);
+-#else
+-	return (1);
+-#endif /* __MINGW32__ && __MINGW32_MAJOR_VERSION >= 3 */
+-#elif defined(__clang__) && (__clang_major__ >= 3)
+-	puts("clang");
+-	return (0);
+-#elif defined(__SUNPRO_C) && (__SUNPRO_C >= 0x5110)
+-	puts("suncc");
+-	return (0);
+-#elif defined(__GNUC__) && (__GNUC__ >= 4)
+-	puts("gcc");
+-	return (0);
+-#else
+-	return (1);
+-#endif
+-}
+-EOF
+-
+-$CC -o .1 .1.c
+-COMPILER=`./.1 2> /dev/null`
+-r=$?
+-rm -f .1.c .1
+ 
+-if test "$r" -ne 0; then
++if $COMPILER = "not found"; then
+ 	assert "" "update compiler"
+ else
+ 	echo "success [$CC]"
+-- 
+2.39.0
+
diff --git a/meta-oe/recipes-devtools/concurrencykit/concurrencykit/cross.patch b/meta-oe/recipes-devtools/concurrencykit/concurrencykit/cross.patch
deleted file mode 100644
index 9e5058f2ca..0000000000
--- a/meta-oe/recipes-devtools/concurrencykit/concurrencykit/cross.patch
+++ /dev/null
@@ -1,62 +0,0 @@ 
-From ab0eec78382bd00ce533aec2c84fd50c1733033d Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sat, 5 Jan 2013 19:42:51 -0800
-
----
- configure | 32 ++++++++++++++++++--------------
- 1 file changed, 18 insertions(+), 14 deletions(-)
-
-diff --git a/configure b/configure
-index 76c2812..78ce2ff 100755
---- a/configure
-+++ b/configure
-@@ -535,14 +535,18 @@ else
- 	GZIP_SUFFIX=".gz"
- fi
- 
--printf "Finding suitable compiler........"
--CC=`pathsearch "${CC:-cc}"`
--if test -z "$CC" -o ! -x "$CC"; then
--	CC=`pathsearch "${CC:-gcc}"`
-+if test -z "$CC"; then
-+	printf "Finding suitable compiler........"
-+	CC=`pathsearch "${CC:-cc}"`
-+	if test -z "$CC" -o ! -x "$CC"; then
-+		CC=`pathsearch "${CC:-gcc}"`
-+	fi
- fi
- assert "$CC" "not found"
- 
--cat << EOF > .1.c
-+if test -z "$COMPILER"; then
-+
-+	cat << EOF > .1.c
- #include <stdio.h>
- int main(void) {
- #if defined(_WIN32)
-@@ -569,16 +573,16 @@ int main(void) {
- #endif
- }
- EOF
-+	$CC -o .1 .1.c
-+	COMPILER=`./.1`
-+	r=$?
-+	rm -f .1.c .1
- 
--$CC -o .1 .1.c
--COMPILER=`./.1`
--r=$?
--rm -f .1.c .1
--
--if test "$r" -ne 0; then
--	assert "" "update compiler"
--else
--	echo "success [$CC]"
-+	if test "$r" -ne 0; then
-+		assert "" "update compiler"
-+	else
-+		echo "success [$CC]"
-+	fi
- fi
- 
- if test "$COMPILER" = "suncc"; then
diff --git a/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb b/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb
index 0018064119..cb65250e9a 100644
--- a/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb
+++ b/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb
@@ -7,16 +7,15 @@  LICENSE = "BSD-2-Clause & Apache-2.0"
 HOMEPAGE = "http://concurrencykit.org"
 SECTION = "base"
 
-PV = "0.5.1+git${SRCPV}"
-SRCREV = "f97d3da5c375ac2fc5a9173cdd36cb828915a2e1"
+PV = "0.7.0+git${SRCPV}"
+SRCREV = "6e8e5bec2e2f8cef2072a68579cbb07ababf3331"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=a0b24c1a8f9ad516a297d055b0294231"
 SRC_URI = "git://github.com/concurrencykit/ck.git;branch=master;protocol=https \
-           file://cross.patch \
-"
+           file://0001-configure-Fix-compoiler-detection-logic-for-cross-co.patch"
 
 S = "${WORKDIR}/git"
 
-COMPATIBLE_HOST = "(arm|aarch64|i.86|x86_64|powerpc|powerpc64).*-linux*"
+COMPATIBLE_HOST = "(arm|aarch64|i.86|x86_64|powerpc|powerpc64|riscv32|riscv64).*-linux*"
 
 inherit autotools-brokensep
 
@@ -26,7 +25,6 @@  PLAT ?= "${HOST_ARCH}"
 
 do_configure () {
     export PLATFORM=${PLAT}
-    export COMPILER='gcc'
     ${S}/configure \
     --prefix=${prefix} \
     --includedir=${includedir} \