[meta-arm,2/6] arm/edk2-firware: don't handle obsolete GCC releases

Submitted by Ross Burton on Oct. 20, 2020, 4 p.m. | Patch ID: 177358

Details

Message ID 20201020160049.473237-2-ross.burton@arm.com
State New
Headers show

Commit Message

Ross Burton Oct. 20, 2020, 4 p.m.
There's no point in handling GCC cross compilers that are before version 5, as
GCC 5 came out in 2017 and is obsolete now.

Change-Id: I650ee44c433f70004d20c0219310ddbd4028addb
Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta-arm/recipes-bsp/uefi/edk2-firmware_git.bb | 12 +-----------
 1 file changed, 1 insertion(+), 11 deletions(-)

Patch hide | download patch | download mbox

diff --git a/meta-arm/recipes-bsp/uefi/edk2-firmware_git.bb b/meta-arm/recipes-bsp/uefi/edk2-firmware_git.bb
index ee8f523..74924b4 100644
--- a/meta-arm/recipes-bsp/uefi/edk2-firmware_git.bb
+++ b/meta-arm/recipes-bsp/uefi/edk2-firmware_git.bb
@@ -52,17 +52,7 @@  export CONF_PATH           = "${WORKSPACE}/Conf"
 
 export BTOOLS_PATH = "${EDK_TOOLS_PATH}/BinWrappers/PosixLike"
 
-python __anonymous() {
-    # If GCC Version is greater than 4 then pass GCC5
-    # set GCC5 by default
-    d.setVar('GCC_VER', 'GCC5')
-
-    # Otherwise pass the corresponding version
-    G = d.getVar('GCCVERSION',True).split(".")
-    gcc_vlist = ['1', '2', '3', '4']
-    if G[0] in gcc_vlist:
-        d.setVar('GCC_VER', 'GCC'+G[0])
-}
+GCC_VER ?= "GCC5"
 
 do_compile() {
     sed -i -e 's:-I \.\.:-I \.\. ${BUILD_CFLAGS} :' ${EDK_TOOLS_PATH}/Source/C/Makefiles/header.makefile