diff mbox series

[03/77] ethtool: upgrade 6.0 -> 6.1

Message ID 20230104110548.2537259-3-alex@linutronix.de
State New
Headers show
Series [01/77] glib-2.0: upgrade 2.74.3 -> 2.74.4 | expand

Commit Message

Alexander Kanavin Jan. 4, 2023, 11:04 a.m. UTC
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 .../0001-marvell.c-define-_GNU_SOURCE.patch   | 26 +++++++++++++++++++
 .../ethtool/avoid_parallel_tests.patch        |  6 ++---
 .../{ethtool_6.0.bb => ethtool_6.1.bb}        |  3 ++-
 3 files changed, 31 insertions(+), 4 deletions(-)
 create mode 100644 meta/recipes-extended/ethtool/ethtool/0001-marvell.c-define-_GNU_SOURCE.patch
 rename meta/recipes-extended/ethtool/{ethtool_6.0.bb => ethtool_6.1.bb} (90%)

Comments

Khem Raj Jan. 4, 2023, 6:09 p.m. UTC | #1
On 1/4/23 3:04 AM, Alexander Kanavin wrote:
> Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> ---
>   .../0001-marvell.c-define-_GNU_SOURCE.patch   | 26 +++++++++++++++++++
>   .../ethtool/avoid_parallel_tests.patch        |  6 ++---
>   .../{ethtool_6.0.bb => ethtool_6.1.bb}        |  3 ++-
>   3 files changed, 31 insertions(+), 4 deletions(-)
>   create mode 100644 meta/recipes-extended/ethtool/ethtool/0001-marvell.c-define-_GNU_SOURCE.patch
>   rename meta/recipes-extended/ethtool/{ethtool_6.0.bb => ethtool_6.1.bb} (90%)
> 
> diff --git a/meta/recipes-extended/ethtool/ethtool/0001-marvell.c-define-_GNU_SOURCE.patch b/meta/recipes-extended/ethtool/ethtool/0001-marvell.c-define-_GNU_SOURCE.patch
> new file mode 100644
> index 0000000000..f0d4c54596
> --- /dev/null
> +++ b/meta/recipes-extended/ethtool/ethtool/0001-marvell.c-define-_GNU_SOURCE.patch
> @@ -0,0 +1,26 @@
> +From 01835ce20f0605f1458365e679137ea65c26aa48 Mon Sep 17 00:00:00 2001
> +From: Alexander Kanavin <alex@linutronix.de>
> +Date: Mon, 2 Jan 2023 13:45:46 +0100
> +Subject: [PATCH] marvell.c: define _GNU_SOURCE
> +
> +Otherwise u_int32_t is not defined under musl C library.
> +
> +Upstream-Status: Submitted [by email to mkubecek@suse.cz]
> +Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> +---
> + marvell.c | 2 ++
> + 1 file changed, 2 insertions(+)
> +
> +diff --git a/marvell.c b/marvell.c
> +index d3d570e..86f1d46 100644
> +--- a/marvell.c
> ++++ b/marvell.c
> +@@ -5,6 +5,8 @@
> +  *  Stephen Hemminger <shemminger@osdl.org>
> +  */
> +
> ++#define _GNU_SOURCE

It is probably better to replace u_int32_t with uint32_t from stdint.h 
instead which is more portable than u_int32_t moreover using _GNU_SOURCE 
feature macro is also not needed.

> ++
> + #include <stdio.h>
> +
> + #include "internal.h"
> diff --git a/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch b/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch
> index c3cefbb5e6..4994369682 100644
> --- a/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch
> +++ b/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch
> @@ -1,4 +1,4 @@
> -From dea90ab711acad251b5d8536c534409979ea8be4 Mon Sep 17 00:00:00 2001
> +From 0d066a901292e6a44ff7bc7ee16f99dd2ba4ea15 Mon Sep 17 00:00:00 2001
>   From: Tudor Florea <tudor.florea@enea.com>
>   Date: Wed, 28 May 2014 18:59:54 +0200
>   Subject: [PATCH] ethtool: use serial-tests config needed by ptest.
> @@ -15,11 +15,11 @@ Upstream-Status: Inappropriate
>    1 file changed, 1 insertion(+), 1 deletion(-)
>   
>   diff --git a/configure.ac b/configure.ac
> -index 89d0e70..ab2be9c 100644
> +index 3eb4e7b..ee5c72f 100644
>   --- a/configure.ac
>   +++ b/configure.ac
>   @@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
> - AC_INIT(ethtool, 6.0, netdev@vger.kernel.org)
> + AC_INIT(ethtool, 6.1, netdev@vger.kernel.org)
>    AC_PREREQ(2.52)
>    AC_CONFIG_SRCDIR([ethtool.c])
>   -AM_INIT_AUTOMAKE([gnu subdir-objects])
> diff --git a/meta/recipes-extended/ethtool/ethtool_6.0.bb b/meta/recipes-extended/ethtool/ethtool_6.1.bb
> similarity index 90%
> rename from meta/recipes-extended/ethtool/ethtool_6.0.bb
> rename to meta/recipes-extended/ethtool/ethtool_6.1.bb
> index 8f36520b00..2b9bbe69db 100644
> --- a/meta/recipes-extended/ethtool/ethtool_6.0.bb
> +++ b/meta/recipes-extended/ethtool/ethtool_6.1.bb
> @@ -9,9 +9,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
>   SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
>              file://run-ptest \
>              file://avoid_parallel_tests.patch \
> +           file://0001-marvell.c-define-_GNU_SOURCE.patch \
>              "
>   
> -SRC_URI[sha256sum] = "f2168e2b45d7e58ed5b76e5533fd607ca0720c9e631f4271bfe997bf72330796"
> +SRC_URI[sha256sum] = "1d03f1ce324fbd95591191c42ac0c4c9cc721e067b929083a20a46c4b4731436"
>   
>   UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/"
>   
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#175388): https://lists.openembedded.org/g/openembedded-core/message/175388
> Mute This Topic: https://lists.openembedded.org/mt/96047870/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alexander Kanavin Jan. 4, 2023, 8:06 p.m. UTC | #2
On Wed, 4 Jan 2023 at 19:09, Khem Raj <raj.khem@gmail.com> wrote:
> > +diff --git a/marvell.c b/marvell.c
> > +index d3d570e..86f1d46 100644
> > +--- a/marvell.c
> > ++++ b/marvell.c
> > +@@ -5,6 +5,8 @@
> > +  *  Stephen Hemminger <shemminger@osdl.org>
> > +  */
> > +
> > ++#define _GNU_SOURCE
>
> It is probably better to replace u_int32_t with uint32_t from stdint.h
> instead which is more portable than u_int32_t moreover using _GNU_SOURCE
> feature macro is also not needed.

Hello Michal,

this would be perhaps a better fix than the patch I sent.

Alex
Alexander Kanavin Jan. 9, 2023, 7:51 a.m. UTC | #3
On Wed, 4 Jan 2023 at 21:07, Alexander Kanavin via
lists.openembedded.org <alex.kanavin=gmail.com@lists.openembedded.org>
wrote:
> > It is probably better to replace u_int32_t with uint32_t from stdint.h
> > instead which is more portable than u_int32_t moreover using _GNU_SOURCE
> > feature macro is also not needed.
>
> Hello Michal,
>
> this would be perhaps a better fix than the patch I sent.

I made a patch for this and sent it.

Alex
diff mbox series

Patch

diff --git a/meta/recipes-extended/ethtool/ethtool/0001-marvell.c-define-_GNU_SOURCE.patch b/meta/recipes-extended/ethtool/ethtool/0001-marvell.c-define-_GNU_SOURCE.patch
new file mode 100644
index 0000000000..f0d4c54596
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool/0001-marvell.c-define-_GNU_SOURCE.patch
@@ -0,0 +1,26 @@ 
+From 01835ce20f0605f1458365e679137ea65c26aa48 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex@linutronix.de>
+Date: Mon, 2 Jan 2023 13:45:46 +0100
+Subject: [PATCH] marvell.c: define _GNU_SOURCE
+
+Otherwise u_int32_t is not defined under musl C library.
+
+Upstream-Status: Submitted [by email to mkubecek@suse.cz]
+Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+---
+ marvell.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/marvell.c b/marvell.c
+index d3d570e..86f1d46 100644
+--- a/marvell.c
++++ b/marvell.c
+@@ -5,6 +5,8 @@
+  *  Stephen Hemminger <shemminger@osdl.org>
+  */
+ 
++#define _GNU_SOURCE
++
+ #include <stdio.h>
+ 
+ #include "internal.h"
diff --git a/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch b/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch
index c3cefbb5e6..4994369682 100644
--- a/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch
+++ b/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch
@@ -1,4 +1,4 @@ 
-From dea90ab711acad251b5d8536c534409979ea8be4 Mon Sep 17 00:00:00 2001
+From 0d066a901292e6a44ff7bc7ee16f99dd2ba4ea15 Mon Sep 17 00:00:00 2001
 From: Tudor Florea <tudor.florea@enea.com>
 Date: Wed, 28 May 2014 18:59:54 +0200
 Subject: [PATCH] ethtool: use serial-tests config needed by ptest.
@@ -15,11 +15,11 @@  Upstream-Status: Inappropriate
  1 file changed, 1 insertion(+), 1 deletion(-)
 
 diff --git a/configure.ac b/configure.ac
-index 89d0e70..ab2be9c 100644
+index 3eb4e7b..ee5c72f 100644
 --- a/configure.ac
 +++ b/configure.ac
 @@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
- AC_INIT(ethtool, 6.0, netdev@vger.kernel.org)
+ AC_INIT(ethtool, 6.1, netdev@vger.kernel.org)
  AC_PREREQ(2.52)
  AC_CONFIG_SRCDIR([ethtool.c])
 -AM_INIT_AUTOMAKE([gnu subdir-objects])
diff --git a/meta/recipes-extended/ethtool/ethtool_6.0.bb b/meta/recipes-extended/ethtool/ethtool_6.1.bb
similarity index 90%
rename from meta/recipes-extended/ethtool/ethtool_6.0.bb
rename to meta/recipes-extended/ethtool/ethtool_6.1.bb
index 8f36520b00..2b9bbe69db 100644
--- a/meta/recipes-extended/ethtool/ethtool_6.0.bb
+++ b/meta/recipes-extended/ethtool/ethtool_6.1.bb
@@ -9,9 +9,10 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
 SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
            file://run-ptest \
            file://avoid_parallel_tests.patch \
+           file://0001-marvell.c-define-_GNU_SOURCE.patch \
            "
 
-SRC_URI[sha256sum] = "f2168e2b45d7e58ed5b76e5533fd607ca0720c9e631f4271bfe997bf72330796"
+SRC_URI[sha256sum] = "1d03f1ce324fbd95591191c42ac0c4c9cc721e067b929083a20a46c4b4731436"
 
 UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/"