diff mbox series

[meta-ti,master/kirkstone] meta-ti-bsp: Add am57xx.inc allowing use of SoC name over full EVM name

Message ID 20230103190011.10208-1-afd@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,master/kirkstone] meta-ti-bsp: Add am57xx.inc allowing use of SoC name over full EVM name | expand

Commit Message

Andrew Davis Jan. 3, 2023, 7 p.m. UTC
In many spots we have to use the full EVM name for each EVM using the
AM57x SoC leading to missed features on some EVMs. Add the am57xx name
so we can generically add for AM57x.

Signed-off-by: Andrew Davis <afd@ti.com>
---
 meta-ti-bsp/conf/machine/am57xx-evm.conf               | 2 +-
 meta-ti-bsp/conf/machine/beagle-x15.conf               | 2 +-
 meta-ti-bsp/conf/machine/include/am57xx.inc            | 5 +++++
 meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb  | 5 ++---
 meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb | 5 ++---
 meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb | 6 ++----
 meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb     | 5 ++---
 meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc   | 3 +--
 meta-ti-bsp/recipes-ti/ipc/ti-ipc-common.inc           | 2 +-
 9 files changed, 17 insertions(+), 18 deletions(-)
 create mode 100644 meta-ti-bsp/conf/machine/include/am57xx.inc

Comments

Denys Dmytriyenko Jan. 5, 2023, 11:34 p.m. UTC | #1
On Tue, Jan 03, 2023 at 01:00:11PM -0600, Andrew Davis via lists.yoctoproject.org wrote:
> In many spots we have to use the full EVM name for each EVM using the
> AM57x SoC leading to missed features on some EVMs. Add the am57xx name
> so we can generically add for AM57x.
> 
> Signed-off-by: Andrew Davis <afd@ti.com>

Reviewed-by: Denys Dmytriyenko <denys@konsulko.com>


> ---
>  meta-ti-bsp/conf/machine/am57xx-evm.conf               | 2 +-
>  meta-ti-bsp/conf/machine/beagle-x15.conf               | 2 +-
>  meta-ti-bsp/conf/machine/include/am57xx.inc            | 5 +++++
>  meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb  | 5 ++---
>  meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb | 5 ++---
>  meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb | 6 ++----
>  meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb     | 5 ++---
>  meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc   | 3 +--
>  meta-ti-bsp/recipes-ti/ipc/ti-ipc-common.inc           | 2 +-
>  9 files changed, 17 insertions(+), 18 deletions(-)
>  create mode 100644 meta-ti-bsp/conf/machine/include/am57xx.inc
> 
> diff --git a/meta-ti-bsp/conf/machine/am57xx-evm.conf b/meta-ti-bsp/conf/machine/am57xx-evm.conf
> index e320477b..9fbff7c6 100644
> --- a/meta-ti-bsp/conf/machine/am57xx-evm.conf
> +++ b/meta-ti-bsp/conf/machine/am57xx-evm.conf
> @@ -2,7 +2,7 @@
>  #@NAME: AM57xx EVM
>  #@DESCRIPTION: Machine configuration for the TI AM57xx EVM
>  
> -require conf/machine/include/dra7xx.inc
> +require conf/machine/include/am57xx.inc
>  
>  MACHINE_FEATURES += "touchscreen"
>  
> diff --git a/meta-ti-bsp/conf/machine/beagle-x15.conf b/meta-ti-bsp/conf/machine/beagle-x15.conf
> index beb0d892..00b8c410 100644
> --- a/meta-ti-bsp/conf/machine/beagle-x15.conf
> +++ b/meta-ti-bsp/conf/machine/beagle-x15.conf
> @@ -2,7 +2,7 @@
>  #@NAME: BeagleBoard X15
>  #@DESCRIPTION: Machine configuration for the BeagleBoard X15
>  
> -require conf/machine/include/dra7xx.inc
> +require conf/machine/include/am57xx.inc
>  
>  KERNEL_DEVICETREE_PREFIX = "am57xx-beagle-x15"
>  
> diff --git a/meta-ti-bsp/conf/machine/include/am57xx.inc b/meta-ti-bsp/conf/machine/include/am57xx.inc
> new file mode 100644
> index 00000000..6c52883b
> --- /dev/null
> +++ b/meta-ti-bsp/conf/machine/include/am57xx.inc
> @@ -0,0 +1,5 @@
> +require conf/machine/include/omap-a15.inc
> +SOC_FAMILY:append = ":dra7xx"
> +SOC_FAMILY:append = ":am57xx"
> +
> +MACHINE_FEATURES += "pci"
> diff --git a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
> index 9ccce938..4f298a2c 100644
> --- a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
> +++ b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
> @@ -6,7 +6,7 @@ PR = "${INC_PR}.0"
>  
>  CLEANBROKEN = "1"
>  
> -COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm"
> +COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx"
>  
>  PACKAGE_ARCH = "${MACHINE_ARCH}"
>  
> @@ -15,8 +15,7 @@ S = "${WORKDIR}/git"
>  TARGET = ""
>  TARGET:ti33x = "am335x-pru0-prueth-fw.elf am335x-pru1-prueth-fw.elf"
>  TARGET:ti43x = "am437x-pru0-prueth-fw.elf am437x-pru1-prueth-fw.elf"
> -TARGET:am57xx-evm = "am57xx-pru0-prueth-fw.elf am57xx-pru1-prueth-fw.elf"
> -TARGET:am57xx-hs-evm = "am57xx-pru0-prueth-fw.elf am57xx-pru1-prueth-fw.elf"
> +TARGET:am57xx = "am57xx-pru0-prueth-fw.elf am57xx-pru1-prueth-fw.elf"
>  
>  do_install() {
>  	install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss
> diff --git a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb
> index 4ffd13aa..69ccb31a 100644
> --- a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb
> +++ b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb
> @@ -7,7 +7,7 @@ PR = "${INC_PR}.0"
>  
>  CLEANBROKEN = "1"
>  
> -COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm"
> +COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx"
>  
>  PACKAGE_ARCH = "${MACHINE_ARCH}"
>  
> @@ -16,8 +16,7 @@ S = "${WORKDIR}/git"
>  TARGET = ""
>  TARGET:ti33x = "am335x-pru0-pruhsr-fw.elf am335x-pru1-pruhsr-fw.elf"
>  TARGET:ti43x = "am437x-pru0-pruhsr-fw.elf am437x-pru1-pruhsr-fw.elf"
> -TARGET:am57xx-evm = "am57xx-pru0-pruhsr-fw.elf am57xx-pru1-pruhsr-fw.elf"
> -TARGET:am57xx-hs-evm = "am57xx-pru0-pruhsr-fw.elf am57xx-pru1-pruhsr-fw.elf"
> +TARGET:am57xx = "am57xx-pru0-pruhsr-fw.elf am57xx-pru1-pruhsr-fw.elf"
>  
>  do_install() {
>  	install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss
> diff --git a/meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb b/meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb
> index 23c422dd..f774db58 100644
> --- a/meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb
> +++ b/meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb
> @@ -7,7 +7,7 @@ PR = "${INC_PR}.0"
>  
>  CLEANBROKEN = "1"
>  
> -COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm"
> +COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx"
>  
>  PACKAGE_ARCH = "${MACHINE_ARCH}"
>  
> @@ -16,9 +16,7 @@ S = "${WORKDIR}/git"
>  TARGET = ""
>  TARGET:ti33x = "am335x-pru0-pruprp-fw.elf am335x-pru1-pruprp-fw.elf"
>  TARGET:ti43x = "am437x-pru0-pruprp-fw.elf am437x-pru1-pruprp-fw.elf"
> -TARGET:am57xx-evm = "am57xx-pru0-pruprp-fw.elf am57xx-pru1-pruprp-fw.elf"
> -TARGET:am57xx-hs-evm = "am57xx-pru0-pruprp-fw.elf am57xx-pru1-pruprp-fw.elf"
> -
> +TARGET:am57xx = "am57xx-pru0-pruprp-fw.elf am57xx-pru1-pruprp-fw.elf"
>  
>  do_install() {
>  	install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss
> diff --git a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb
> index 8d784768..5b38a048 100644
> --- a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb
> +++ b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb
> @@ -6,7 +6,7 @@ PR = "${INC_PR}.0"
>  
>  CLEANBROKEN = "1"
>  
> -COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm"
> +COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx"
>  
>  PACKAGE_ARCH = "${MACHINE_ARCH}"
>  
> @@ -15,8 +15,7 @@ S = "${WORKDIR}/git"
>  TARGET = ""
>  TARGET:ti33x = "am335x-pru0-prusw-fw.elf am335x-pru1-prusw-fw.elf"
>  TARGET:ti43x = "am437x-pru0-prusw-fw.elf am437x-pru1-prusw-fw.elf"
> -TARGET:am57xx-evm = "am57xx-pru0-prusw-fw.elf am57xx-pru1-prusw-fw.elf"
> -TARGET:am57xx-hs-evm = "am57xx-pru0-prusw-fw.elf am57xx-pru1-prusw-fw.elf"
> +TARGET:am57xx = "am57xx-pru0-prusw-fw.elf am57xx-pru1-prusw-fw.elf"
>  
>  do_install() {
>  	install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss
> diff --git a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
> index 54e6fdc6..808a4766 100644
> --- a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
> +++ b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
> @@ -12,8 +12,7 @@ RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:dra7xx = " vpdma-fw"
>  RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:dra7xx = " goodix-fw"
>  
>  # Add run-time dependency for PRU Ethernet firmware to the rootfs
> -RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am57xx-evm = " prueth-fw prusw-fw pruhsr-fw pruprp-fw"
> -RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am57xx-hs-evm = " prueth-fw prusw-fw pruhsr-fw pruprp-fw"
> +RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am57xx = " prueth-fw prusw-fw pruhsr-fw pruprp-fw"
>  RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti43x = " prueth-fw pruhsr-fw pruprp-fw"
>  RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti33x = " prueth-fw pruhsr-fw pruprp-fw"
>  RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am65xx = " prueth-fw-am65x"
> diff --git a/meta-ti-bsp/recipes-ti/ipc/ti-ipc-common.inc b/meta-ti-bsp/recipes-ti/ipc/ti-ipc-common.inc
> index 4962a3ec..ec1e71be 100644
> --- a/meta-ti-bsp/recipes-ti/ipc/ti-ipc-common.inc
> +++ b/meta-ti-bsp/recipes-ti/ipc/ti-ipc-common.inc
> @@ -9,4 +9,4 @@ PLATFORM = "UNKNOWN"
>  PLATFORM:dra7xx = "DRA7XX"
>  PLATFORM:omapl138 = "OMAPL138"
>  
> -ALT_PLATFORM:am57xx-evm = "AM572X AM571X"
> +ALT_PLATFORM:am57xx = "AM572X AM571X"
> -- 
> 2.38.1
>
diff mbox series

Patch

diff --git a/meta-ti-bsp/conf/machine/am57xx-evm.conf b/meta-ti-bsp/conf/machine/am57xx-evm.conf
index e320477b..9fbff7c6 100644
--- a/meta-ti-bsp/conf/machine/am57xx-evm.conf
+++ b/meta-ti-bsp/conf/machine/am57xx-evm.conf
@@ -2,7 +2,7 @@ 
 #@NAME: AM57xx EVM
 #@DESCRIPTION: Machine configuration for the TI AM57xx EVM
 
-require conf/machine/include/dra7xx.inc
+require conf/machine/include/am57xx.inc
 
 MACHINE_FEATURES += "touchscreen"
 
diff --git a/meta-ti-bsp/conf/machine/beagle-x15.conf b/meta-ti-bsp/conf/machine/beagle-x15.conf
index beb0d892..00b8c410 100644
--- a/meta-ti-bsp/conf/machine/beagle-x15.conf
+++ b/meta-ti-bsp/conf/machine/beagle-x15.conf
@@ -2,7 +2,7 @@ 
 #@NAME: BeagleBoard X15
 #@DESCRIPTION: Machine configuration for the BeagleBoard X15
 
-require conf/machine/include/dra7xx.inc
+require conf/machine/include/am57xx.inc
 
 KERNEL_DEVICETREE_PREFIX = "am57xx-beagle-x15"
 
diff --git a/meta-ti-bsp/conf/machine/include/am57xx.inc b/meta-ti-bsp/conf/machine/include/am57xx.inc
new file mode 100644
index 00000000..6c52883b
--- /dev/null
+++ b/meta-ti-bsp/conf/machine/include/am57xx.inc
@@ -0,0 +1,5 @@ 
+require conf/machine/include/omap-a15.inc
+SOC_FAMILY:append = ":dra7xx"
+SOC_FAMILY:append = ":am57xx"
+
+MACHINE_FEATURES += "pci"
diff --git a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
index 9ccce938..4f298a2c 100644
--- a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
+++ b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
@@ -6,7 +6,7 @@  PR = "${INC_PR}.0"
 
 CLEANBROKEN = "1"
 
-COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm"
+COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
@@ -15,8 +15,7 @@  S = "${WORKDIR}/git"
 TARGET = ""
 TARGET:ti33x = "am335x-pru0-prueth-fw.elf am335x-pru1-prueth-fw.elf"
 TARGET:ti43x = "am437x-pru0-prueth-fw.elf am437x-pru1-prueth-fw.elf"
-TARGET:am57xx-evm = "am57xx-pru0-prueth-fw.elf am57xx-pru1-prueth-fw.elf"
-TARGET:am57xx-hs-evm = "am57xx-pru0-prueth-fw.elf am57xx-pru1-prueth-fw.elf"
+TARGET:am57xx = "am57xx-pru0-prueth-fw.elf am57xx-pru1-prueth-fw.elf"
 
 do_install() {
 	install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss
diff --git a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb
index 4ffd13aa..69ccb31a 100644
--- a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb
+++ b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb
@@ -7,7 +7,7 @@  PR = "${INC_PR}.0"
 
 CLEANBROKEN = "1"
 
-COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm"
+COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
@@ -16,8 +16,7 @@  S = "${WORKDIR}/git"
 TARGET = ""
 TARGET:ti33x = "am335x-pru0-pruhsr-fw.elf am335x-pru1-pruhsr-fw.elf"
 TARGET:ti43x = "am437x-pru0-pruhsr-fw.elf am437x-pru1-pruhsr-fw.elf"
-TARGET:am57xx-evm = "am57xx-pru0-pruhsr-fw.elf am57xx-pru1-pruhsr-fw.elf"
-TARGET:am57xx-hs-evm = "am57xx-pru0-pruhsr-fw.elf am57xx-pru1-pruhsr-fw.elf"
+TARGET:am57xx = "am57xx-pru0-pruhsr-fw.elf am57xx-pru1-pruhsr-fw.elf"
 
 do_install() {
 	install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss
diff --git a/meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb b/meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb
index 23c422dd..f774db58 100644
--- a/meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb
+++ b/meta-ti-bsp/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb
@@ -7,7 +7,7 @@  PR = "${INC_PR}.0"
 
 CLEANBROKEN = "1"
 
-COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm"
+COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
@@ -16,9 +16,7 @@  S = "${WORKDIR}/git"
 TARGET = ""
 TARGET:ti33x = "am335x-pru0-pruprp-fw.elf am335x-pru1-pruprp-fw.elf"
 TARGET:ti43x = "am437x-pru0-pruprp-fw.elf am437x-pru1-pruprp-fw.elf"
-TARGET:am57xx-evm = "am57xx-pru0-pruprp-fw.elf am57xx-pru1-pruprp-fw.elf"
-TARGET:am57xx-hs-evm = "am57xx-pru0-pruprp-fw.elf am57xx-pru1-pruprp-fw.elf"
-
+TARGET:am57xx = "am57xx-pru0-pruprp-fw.elf am57xx-pru1-pruprp-fw.elf"
 
 do_install() {
 	install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss
diff --git a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb
index 8d784768..5b38a048 100644
--- a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb
+++ b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb
@@ -6,7 +6,7 @@  PR = "${INC_PR}.0"
 
 CLEANBROKEN = "1"
 
-COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm"
+COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
@@ -15,8 +15,7 @@  S = "${WORKDIR}/git"
 TARGET = ""
 TARGET:ti33x = "am335x-pru0-prusw-fw.elf am335x-pru1-prusw-fw.elf"
 TARGET:ti43x = "am437x-pru0-prusw-fw.elf am437x-pru1-prusw-fw.elf"
-TARGET:am57xx-evm = "am57xx-pru0-prusw-fw.elf am57xx-pru1-prusw-fw.elf"
-TARGET:am57xx-hs-evm = "am57xx-pru0-prusw-fw.elf am57xx-pru1-prusw-fw.elf"
+TARGET:am57xx = "am57xx-pru0-prusw-fw.elf am57xx-pru1-prusw-fw.elf"
 
 do_install() {
 	install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss
diff --git a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
index 54e6fdc6..808a4766 100644
--- a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
+++ b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
@@ -12,8 +12,7 @@  RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:dra7xx = " vpdma-fw"
 RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:dra7xx = " goodix-fw"
 
 # Add run-time dependency for PRU Ethernet firmware to the rootfs
-RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am57xx-evm = " prueth-fw prusw-fw pruhsr-fw pruprp-fw"
-RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am57xx-hs-evm = " prueth-fw prusw-fw pruhsr-fw pruprp-fw"
+RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am57xx = " prueth-fw prusw-fw pruhsr-fw pruprp-fw"
 RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti43x = " prueth-fw pruhsr-fw pruprp-fw"
 RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti33x = " prueth-fw pruhsr-fw pruprp-fw"
 RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am65xx = " prueth-fw-am65x"
diff --git a/meta-ti-bsp/recipes-ti/ipc/ti-ipc-common.inc b/meta-ti-bsp/recipes-ti/ipc/ti-ipc-common.inc
index 4962a3ec..ec1e71be 100644
--- a/meta-ti-bsp/recipes-ti/ipc/ti-ipc-common.inc
+++ b/meta-ti-bsp/recipes-ti/ipc/ti-ipc-common.inc
@@ -9,4 +9,4 @@  PLATFORM = "UNKNOWN"
 PLATFORM:dra7xx = "DRA7XX"
 PLATFORM:omapl138 = "OMAPL138"
 
-ALT_PLATFORM:am57xx-evm = "AM572X AM571X"
+ALT_PLATFORM:am57xx = "AM572X AM571X"