[2/2] poky: add preferred version for linux-yocto-rt

Submitted by Bruce Ashfield on Aug. 26, 2020, 3:11 a.m. | Patch ID: 175679

Details

Message ID 20200826031151.6605-2-bruce.ashfield@gmail.com
State New
Headers show

Commit Message

Bruce Ashfield Aug. 26, 2020, 3:11 a.m.
From: Bruce Ashfield <bruce.ashfield@gmail.com>

As a step towards getting more testing on -rt, we should explicitly
set the preferred version for linux-yocto-rt.

Newly introduced kernels lag in -rt support (as we wait for upstream
projects), so we don't want the version to always be the latest by
default.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---
 meta-poky/conf/distro/poky.conf | 1 +
 1 file changed, 1 insertion(+)

Patch hide | download patch | download mbox

diff --git a/meta-poky/conf/distro/poky.conf b/meta-poky/conf/distro/poky.conf
index 826f0d633a..b89dc5c1d9 100644
--- a/meta-poky/conf/distro/poky.conf
+++ b/meta-poky/conf/distro/poky.conf
@@ -22,6 +22,7 @@  POKY_DEFAULT_EXTRA_RRECOMMENDS = "kernel-module-af-packet"
 DISTRO_FEATURES ?= "${DISTRO_FEATURES_DEFAULT} ${POKY_DEFAULT_DISTRO_FEATURES}"
 
 PREFERRED_VERSION_linux-yocto ?= "5.8%"
+PREFERRED_VERSION_linux-yocto-rt ?= "5.4%"
 
 SDK_NAME = "${DISTRO}-${TCLIBC}-${SDKMACHINE}-${IMAGE_BASENAME}-${TUNE_PKGARCH}-${MACHINE}"
 SDKPATH = "/opt/${DISTRO}/${SDK_VERSION}"