diff mbox series

stress-ng: Do not enforce gold linker

Message ID 20230103073111.1586416-1-raj.khem@gmail.com
State Accepted, archived
Commit 089cc4b036e370bf82973ca6ced038578e4682cf
Headers show
Series stress-ng: Do not enforce gold linker | expand

Commit Message

Khem Raj Jan. 3, 2023, 7:31 a.m. UTC
This can then be controlled by yocto environment through LDFLAGS if
needed since we support multiple linkers and distro policy may want a
different linker, moreover gold fails on ppc32 to link since its missing

Fixes errors like below on ppc/gold + clang

/usr/lib/clang/15.0.6/lib/linux/libclang_rt.builtins-powerpc.a(mulsc3.c.o): unsupported -mbss-plt code

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-extended/stress-ng/stress-ng_0.15.01.bb | 2 ++
 1 file changed, 2 insertions(+)

Comments

Alexander Kanavin Jan. 3, 2023, 7:52 a.m. UTC | #1
Can this be made a patch and submitted upstream? Patching like that
with sed is prone to silent regressions.

Alex

On Tue, 3 Jan 2023 at 08:31, Khem Raj <raj.khem@gmail.com> wrote:
>
> This can then be controlled by yocto environment through LDFLAGS if
> needed since we support multiple linkers and distro policy may want a
> different linker, moreover gold fails on ppc32 to link since its missing
>
> Fixes errors like below on ppc/gold + clang
>
> /usr/lib/clang/15.0.6/lib/linux/libclang_rt.builtins-powerpc.a(mulsc3.c.o): unsupported -mbss-plt code
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  meta/recipes-extended/stress-ng/stress-ng_0.15.01.bb | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/meta/recipes-extended/stress-ng/stress-ng_0.15.01.bb b/meta/recipes-extended/stress-ng/stress-ng_0.15.01.bb
> index 38fd6698b3..72893e7893 100644
> --- a/meta/recipes-extended/stress-ng/stress-ng_0.15.01.bb
> +++ b/meta/recipes-extended/stress-ng/stress-ng_0.15.01.bb
> @@ -23,6 +23,8 @@ EXTRA_OEMAKE = "VERBOSE=1"
>  do_configure() {
>      mkdir -p configs
>      touch configs/HAVE_APPARMOR
> +    # Disable forcing gold linker
> +    sed -i -e '/LD_GOLD/{N;d;}' ${S}/Makefile.config
>      oe_runmake makeconfig
>  }
>
> --
> 2.39.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#175334): https://lists.openembedded.org/g/openembedded-core/message/175334
> Mute This Topic: https://lists.openembedded.org/mt/96024589/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-extended/stress-ng/stress-ng_0.15.01.bb b/meta/recipes-extended/stress-ng/stress-ng_0.15.01.bb
index 38fd6698b3..72893e7893 100644
--- a/meta/recipes-extended/stress-ng/stress-ng_0.15.01.bb
+++ b/meta/recipes-extended/stress-ng/stress-ng_0.15.01.bb
@@ -23,6 +23,8 @@  EXTRA_OEMAKE = "VERBOSE=1"
 do_configure() {
     mkdir -p configs
     touch configs/HAVE_APPARMOR
+    # Disable forcing gold linker
+    sed -i -e '/LD_GOLD/{N;d;}' ${S}/Makefile.config
     oe_runmake makeconfig
 }