diff mbox series

[meta-gnome,1/2] gnome-online-accounts: Fix build race seen on musl systems

Message ID 20221231173417.3502417-1-raj.khem@gmail.com
State New
Headers show
Series [meta-gnome,1/2] gnome-online-accounts: Fix build race seen on musl systems | expand

Commit Message

Khem Raj Dec. 31, 2022, 5:34 p.m. UTC
Backport a patch to fix correct use of dependency object

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 ...se-the-appropriate-dependency-object.patch | 35 +++++++++++++++++++
 .../gnome-online-accounts_3.46.0.bb           |  1 +
 2 files changed, 36 insertions(+)
 create mode 100644 meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts/0001-build-Use-the-appropriate-dependency-object.patch
diff mbox series

Patch

diff --git a/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts/0001-build-Use-the-appropriate-dependency-object.patch b/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts/0001-build-Use-the-appropriate-dependency-object.patch
new file mode 100644
index 0000000000..838ca1a7d4
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts/0001-build-Use-the-appropriate-dependency-object.patch
@@ -0,0 +1,35 @@ 
+From 06240574626eb21af37cf7dde5bf81e892dff467 Mon Sep 17 00:00:00 2001
+From: Emmanuele Bassi <ebassi@gnome.org>
+Date: Wed, 5 Oct 2022 22:15:37 +0100
+Subject: [PATCH] build: Use the appropriate dependency object
+
+Just using `link_with` will not ensure that the GOA web extension shared
+module is properly built against libgoa-backend and libgoa; the
+generated headers must be transitively available by the time we build
+the shared module.
+
+Fixes: #226
+Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/gnome-online-accounts/-/commit/fe86bfb0271735c8130367c46536b08dad5c20d8]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/goabackend/meson.build | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/src/goabackend/meson.build b/src/goabackend/meson.build
+index f5382b3..865b2d2 100644
+--- a/src/goabackend/meson.build
++++ b/src/goabackend/meson.build
+@@ -157,9 +157,8 @@ libgoa_web_extension = shared_module(
+   'goawebextension',
+   libgoawebextension_sources,
+   include_directories: common_incs + [goa_inc],
+-  dependencies: deps,
++  dependencies: [deps, libgoa_backend_dep],
+   c_args: cflags,
+-  link_with: libgoa_backend,
+   install: true,
+   install_dir: join_paths(goa_pkglibdir, 'web-extensions')
+ )
+-- 
+2.39.0
+
diff --git a/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts_3.46.0.bb b/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts_3.46.0.bb
index 80cf4969cd..ce02a507da 100644
--- a/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts_3.46.0.bb
+++ b/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts_3.46.0.bb
@@ -8,6 +8,7 @@  inherit gnomebase gsettings gobject-introspection gtk-icon-cache vala features_c
 
 DEPENDS = "gtk+3 gtk+3-native gdk-pixbuf dbus json-glib libxml2 webkitgtk glib-2.0 rest libsecret"
 
+SRC_URI += "file://0001-build-Use-the-appropriate-dependency-object.patch"
 SRC_URI[archive.sha256sum] = "5e7859ce4858a6b99d3995ed70527d66e297bb90bbf75ec8780fe9da22c1fcaa"
 
 PACKAGECONFIG_SOUP ?= "soup3"