diff mbox series

[meta-oe,2/2] mozjs-102: Disable mozilla stackwalk on musl

Message ID 20221230220533.2614883-2-raj.khem@gmail.com
State New
Headers show
Series [meta-networking,1/2] vsftpd_3.0.5.bb: Define _LARGEFILE64_SOURCE on musl | expand

Commit Message

Khem Raj Dec. 30, 2022, 10:05 p.m. UTC
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../mozjs-102/musl-disable-stackwalk.patch     | 18 ++++++++++++++++++
 .../mozjs/mozjs-102_102.5.0.bb                 |  1 +
 2 files changed, 19 insertions(+)
 create mode 100644 meta-oe/recipes-extended/mozjs/mozjs-102/musl-disable-stackwalk.patch
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/mozjs/mozjs-102/musl-disable-stackwalk.patch b/meta-oe/recipes-extended/mozjs/mozjs-102/musl-disable-stackwalk.patch
new file mode 100644
index 0000000000..a3ba469a41
--- /dev/null
+++ b/meta-oe/recipes-extended/mozjs/mozjs-102/musl-disable-stackwalk.patch
@@ -0,0 +1,18 @@ 
+Musl does not have stack unwinder like glibc therefore
+we can not assume that its always available on musl, we
+do need to check for target environment as well which
+could be musl or glibc.
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/mozglue/misc/StackWalk.cpp
++++ b/mozglue/misc/StackWalk.cpp
+@@ -44,7 +44,7 @@ using namespace mozilla;
+ #  define MOZ_STACKWALK_SUPPORTS_MACOSX 0
+ #endif
+ 
+-#if (defined(linux) &&                                            \
++#if (defined(linux) && defined(__GLIBC__) &&                      \
+      ((defined(__GNUC__) && (defined(__i386) || defined(PPC))) || \
+       defined(HAVE__UNWIND_BACKTRACE)))
+ #  define MOZ_STACKWALK_SUPPORTS_LINUX 1
diff --git a/meta-oe/recipes-extended/mozjs/mozjs-102_102.5.0.bb b/meta-oe/recipes-extended/mozjs/mozjs-102_102.5.0.bb
index a4d88a340a..d38ae10b87 100644
--- a/meta-oe/recipes-extended/mozjs/mozjs-102_102.5.0.bb
+++ b/meta-oe/recipes-extended/mozjs/mozjs-102_102.5.0.bb
@@ -14,6 +14,7 @@  SRC_URI = "https://archive.mozilla.org/pub/firefox/releases/${PV}esr/source/fire
            file://0001-util.configure-fix-one-occasionally-reproduced-confi.patch \
            file://0001-rewrite-cargo-host-linker-in-python3.patch  \
            file://py-3.11.patch \
+           file://musl-disable-stackwalk.patch \
            "
 SRC_URI[sha256sum] = "017dd44b1285913f477074802707a4c76ed1a28270ec5a327bbb76574cc057d8"