diff mbox series

musl: Update to latest on tip of trunk

Message ID 20221229071310.4111511-1-raj.khem@gmail.com
State Accepted, archived
Commit 3b27f6356a3bf0138da0c3dcd87aa8e4a93ae56b
Headers show
Series musl: Update to latest on tip of trunk | expand

Commit Message

Khem Raj Dec. 29, 2022, 7:13 a.m. UTC
Brings following changes

* f47a8cdd ldso: fix invalid early references to extern-linkage libc.page_size
* 377218cb pthread_atfork: fix return value on malloc failure
* 29e43191 fix double-processing of DT_RELR relocations in ldso relocating itself
* b50eb8c3 fix strverscmp comparison of digit sequence with non-digits
* ad5dcd39 fix async thread cancellation stack alignment
* 8f925945 fix return value of gethostby{name[2],addr} with no result but no error
* 63402be2 clean up dns_parse_callback
* 0a7b4323 dns response handling: don't treat too many addresses as an error
* 41603c77 dns response handling: ignore presence of wrong-type RRs
* cf76df0e fix missing synchronization of pthread TSD keys with MT-fork
* 5ff3eea9 fgets: avoid arithmetic overflow when n==INT_MIN is passed
* d8f35e29 fix AS-safety of close when aio is in use and fd map is expanded
* 26c76a90 fix use of uninitialized dummy_fut in aio_suspend
* aebd6a36 fix potential deadlock between multithreaded fork and aio
* d64148a8 fix potential unsynchronized access to killlock state at thread exit
* 36b72cd6 fix potential deadlock in dlerror buffer handling at thread exit
* 833a4691 configure: disable TBAA optimization because most compilers are buggy
* e6e82132 disable MADV_FREE usage in mallocng
* 25e6fee2 remove LFS64 programming interfaces (macro-only) from _GNU_SOURCE
* 246f1c81 remove LFS64 symbol aliases; replace with dynamic linker remapping
* dec8f0a4 dns query core: detect udp truncation at recv time
* 8c408937 getaddrinfo dns lookup: use larger answer buffer to handle long CNAMEs
* 759bf785 arpa/nameser.h: update RR types list
* 51d4669f dns: implement tcp fallback in __res_msend query core
* e2e95176 res_send: use a temp buffer if caller's buffer is under 512 bytes
* c87d75f2 adapt res_msend DNS query core for working with multiple sockets
* 85050ac5 getaddrinfo: add EAI_NODATA error code to distinguish NODATA vs NxDomain

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-core/musl/musl_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Richard Purdie Dec. 29, 2022, 11:10 p.m. UTC | #1
On Wed, 2022-12-28 at 23:13 -0800, Khem Raj wrote:
> Brings following changes
> 
> * f47a8cdd ldso: fix invalid early references to extern-linkage libc.page_size
> * 377218cb pthread_atfork: fix return value on malloc failure
> * 29e43191 fix double-processing of DT_RELR relocations in ldso relocating itself
> * b50eb8c3 fix strverscmp comparison of digit sequence with non-digits
> * ad5dcd39 fix async thread cancellation stack alignment
> * 8f925945 fix return value of gethostby{name[2],addr} with no result but no error
> * 63402be2 clean up dns_parse_callback
> * 0a7b4323 dns response handling: don't treat too many addresses as an error
> * 41603c77 dns response handling: ignore presence of wrong-type RRs
> * cf76df0e fix missing synchronization of pthread TSD keys with MT-fork
> * 5ff3eea9 fgets: avoid arithmetic overflow when n==INT_MIN is passed
> * d8f35e29 fix AS-safety of close when aio is in use and fd map is expanded
> * 26c76a90 fix use of uninitialized dummy_fut in aio_suspend
> * aebd6a36 fix potential deadlock between multithreaded fork and aio
> * d64148a8 fix potential unsynchronized access to killlock state at thread exit
> * 36b72cd6 fix potential deadlock in dlerror buffer handling at thread exit
> * 833a4691 configure: disable TBAA optimization because most compilers are buggy
> * e6e82132 disable MADV_FREE usage in mallocng
> * 25e6fee2 remove LFS64 programming interfaces (macro-only) from _GNU_SOURCE
> * 246f1c81 remove LFS64 symbol aliases; replace with dynamic linker remapping
> * dec8f0a4 dns query core: detect udp truncation at recv time
> * 8c408937 getaddrinfo dns lookup: use larger answer buffer to handle long CNAMEs
> * 759bf785 arpa/nameser.h: update RR types list
> * 51d4669f dns: implement tcp fallback in __res_msend query core
> * e2e95176 res_send: use a temp buffer if caller's buffer is under 512 bytes
> * c87d75f2 adapt res_msend DNS query core for working with multiple sockets
> * 85050ac5 getaddrinfo: add EAI_NODATA error code to distinguish NODATA vs NxDomain
> 
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  meta/recipes-core/musl/musl_git.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
> index a72d87ea6f..7749495ec6 100644
> --- a/meta/recipes-core/musl/musl_git.bb
> +++ b/meta/recipes-core/musl/musl_git.bb
> @@ -4,7 +4,7 @@
>  require musl.inc
>  inherit linuxloader
>  
> -SRCREV = "dc9285ad1dc19349c407072cc48ba70dab86de45"
> +SRCREV = "f47a8cdd250d9163fcfb39bf4e9d813957c0b187"
>  
>  BASEVER = "1.2.3"
>  

I tested this with your 3 musl patches and it showed a few issues:

https://autobuilder.yoctoproject.org/typhoon/#/builders/64/builds/6421
https://autobuilder.yoctoproject.org/typhoon/#/builders/45/builds/6439

Cheers,

Richard
Khem Raj Dec. 30, 2022, 9:14 p.m. UTC | #2
On Thu, Dec 29, 2022 at 3:10 PM Richard Purdie
<richard.purdie@linuxfoundation.org> wrote:
>
> On Wed, 2022-12-28 at 23:13 -0800, Khem Raj wrote:
> > Brings following changes
> >
> > * f47a8cdd ldso: fix invalid early references to extern-linkage libc.page_size
> > * 377218cb pthread_atfork: fix return value on malloc failure
> > * 29e43191 fix double-processing of DT_RELR relocations in ldso relocating itself
> > * b50eb8c3 fix strverscmp comparison of digit sequence with non-digits
> > * ad5dcd39 fix async thread cancellation stack alignment
> > * 8f925945 fix return value of gethostby{name[2],addr} with no result but no error
> > * 63402be2 clean up dns_parse_callback
> > * 0a7b4323 dns response handling: don't treat too many addresses as an error
> > * 41603c77 dns response handling: ignore presence of wrong-type RRs
> > * cf76df0e fix missing synchronization of pthread TSD keys with MT-fork
> > * 5ff3eea9 fgets: avoid arithmetic overflow when n==INT_MIN is passed
> > * d8f35e29 fix AS-safety of close when aio is in use and fd map is expanded
> > * 26c76a90 fix use of uninitialized dummy_fut in aio_suspend
> > * aebd6a36 fix potential deadlock between multithreaded fork and aio
> > * d64148a8 fix potential unsynchronized access to killlock state at thread exit
> > * 36b72cd6 fix potential deadlock in dlerror buffer handling at thread exit
> > * 833a4691 configure: disable TBAA optimization because most compilers are buggy
> > * e6e82132 disable MADV_FREE usage in mallocng
> > * 25e6fee2 remove LFS64 programming interfaces (macro-only) from _GNU_SOURCE
> > * 246f1c81 remove LFS64 symbol aliases; replace with dynamic linker remapping
> > * dec8f0a4 dns query core: detect udp truncation at recv time
> > * 8c408937 getaddrinfo dns lookup: use larger answer buffer to handle long CNAMEs
> > * 759bf785 arpa/nameser.h: update RR types list
> > * 51d4669f dns: implement tcp fallback in __res_msend query core
> > * e2e95176 res_send: use a temp buffer if caller's buffer is under 512 bytes
> > * c87d75f2 adapt res_msend DNS query core for working with multiple sockets
> > * 85050ac5 getaddrinfo: add EAI_NODATA error code to distinguish NODATA vs NxDomain
> >
> > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > ---
> >  meta/recipes-core/musl/musl_git.bb | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
> > index a72d87ea6f..7749495ec6 100644
> > --- a/meta/recipes-core/musl/musl_git.bb
> > +++ b/meta/recipes-core/musl/musl_git.bb
> > @@ -4,7 +4,7 @@
> >  require musl.inc
> >  inherit linuxloader
> >
> > -SRCREV = "dc9285ad1dc19349c407072cc48ba70dab86de45"
> > +SRCREV = "f47a8cdd250d9163fcfb39bf4e9d813957c0b187"
> >
> >  BASEVER = "1.2.3"
> >
>
> I tested this with your 3 musl patches and it showed a few issues:
>
> https://autobuilder.yoctoproject.org/typhoon/#/builders/64/builds/6421
> https://autobuilder.yoctoproject.org/typhoon/#/builders/45/builds/6439
>

I have sent fixes for all the build failures seen in these two builds.

Thanks
-Khem
Nicolas Dechesne Jan. 5, 2023, 7:57 a.m. UTC | #3
On Fri, Dec 30, 2022 at 10:14 PM Khem Raj <raj.khem@gmail.com> wrote:

> On Thu, Dec 29, 2022 at 3:10 PM Richard Purdie
> <richard.purdie@linuxfoundation.org> wrote:
> >
> > On Wed, 2022-12-28 at 23:13 -0800, Khem Raj wrote:
> > > Brings following changes
> > >
> > > * f47a8cdd ldso: fix invalid early references to extern-linkage
> libc.page_size
> > > * 377218cb pthread_atfork: fix return value on malloc failure
> > > * 29e43191 fix double-processing of DT_RELR relocations in ldso
> relocating itself
> > > * b50eb8c3 fix strverscmp comparison of digit sequence with non-digits
> > > * ad5dcd39 fix async thread cancellation stack alignment
> > > * 8f925945 fix return value of gethostby{name[2],addr} with no result
> but no error
> > > * 63402be2 clean up dns_parse_callback
> > > * 0a7b4323 dns response handling: don't treat too many addresses as an
> error
> > > * 41603c77 dns response handling: ignore presence of wrong-type RRs
> > > * cf76df0e fix missing synchronization of pthread TSD keys with MT-fork
> > > * 5ff3eea9 fgets: avoid arithmetic overflow when n==INT_MIN is passed
> > > * d8f35e29 fix AS-safety of close when aio is in use and fd map is
> expanded
> > > * 26c76a90 fix use of uninitialized dummy_fut in aio_suspend
> > > * aebd6a36 fix potential deadlock between multithreaded fork and aio
> > > * d64148a8 fix potential unsynchronized access to killlock state at
> thread exit
> > > * 36b72cd6 fix potential deadlock in dlerror buffer handling at thread
> exit
> > > * 833a4691 configure: disable TBAA optimization because most compilers
> are buggy
> > > * e6e82132 disable MADV_FREE usage in mallocng
> > > * 25e6fee2 remove LFS64 programming interfaces (macro-only) from
> _GNU_SOURCE
> > > * 246f1c81 remove LFS64 symbol aliases; replace with dynamic linker
> remapping
> > > * dec8f0a4 dns query core: detect udp truncation at recv time
> > > * 8c408937 getaddrinfo dns lookup: use larger answer buffer to handle
> long CNAMEs
> > > * 759bf785 arpa/nameser.h: update RR types list
> > > * 51d4669f dns: implement tcp fallback in __res_msend query core
> > > * e2e95176 res_send: use a temp buffer if caller's buffer is under 512
> bytes
> > > * c87d75f2 adapt res_msend DNS query core for working with multiple
> sockets
> > > * 85050ac5 getaddrinfo: add EAI_NODATA error code to distinguish
> NODATA vs NxDomain
> > >
> > > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > > ---
> > >  meta/recipes-core/musl/musl_git.bb | 2 +-
> > >  1 file changed, 1 insertion(+), 1 deletion(-)
> > >
> > > diff --git a/meta/recipes-core/musl/musl_git.bb
> b/meta/recipes-core/musl/musl_git.bb
> > > index a72d87ea6f..7749495ec6 100644
> > > --- a/meta/recipes-core/musl/musl_git.bb
> > > +++ b/meta/recipes-core/musl/musl_git.bb
> > > @@ -4,7 +4,7 @@
> > >  require musl.inc
> > >  inherit linuxloader
> > >
> > > -SRCREV = "dc9285ad1dc19349c407072cc48ba70dab86de45"
> > > +SRCREV = "f47a8cdd250d9163fcfb39bf4e9d813957c0b187"
> > >
> > >  BASEVER = "1.2.3"
> > >
> >
> > I tested this with your 3 musl patches and it showed a few issues:
> >
> > https://autobuilder.yoctoproject.org/typhoon/#/builders/64/builds/6421
> > https://autobuilder.yoctoproject.org/typhoon/#/builders/45/builds/6439
> >
>
> I have sent fixes for all the build failures seen in these two builds.
>

I am getting other failures since this patch was merged (
https://github.com/ndechesne/meta-qcom/actions/workflows/daily.yml). When
building e2fsprog for arm 32 bit targets. A snippet of the build log is:

| arm-poky-linux-musleabi-gcc  -mthumb -mfpu=neon-vfpv4 -mfloat-abi=hard
-mcpu=cortex-a15 -fstack-protector-strong  -O2 -D_FORTIFY_SOURCE=2 -Wformat
-Wformat-security -Werror=format-security
--sysroot=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/recipe-sysroot
-I. -I../../lib -I../../../git/lib  -O2 -pipe -g
-feliminate-unused-debug-types
-fmacro-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/git=/usr/src/debug/e2fsprogs/1.46.5-r0
 -fdebug-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/git=/usr/src/debug/e2fsprogs/1.46.5-r0
 -fmacro-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/build=/usr/src/debug/e2fsprogs/1.46.5-r0
 -fdebug-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/build=/usr/src/debug/e2fsprogs/1.46.5-r0
 -fdebug-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/recipe-sysroot=
 -fmacro-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/recipe-sysroot=
 -fdebug-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/recipe-sysroot-native=
 -pthread  -DHAVE_CONFIG_H  -c ../../../git/lib/ext2fs/lookup.c -o lookup.o
| ../../../git/lib/ext2fs/llseek.c:70:22: error: expected declaration
specifiers or '...' before '_llseek'
|    70 | static _syscall5(int,_llseek,unsigned int,fd,unsigned
long,offset_high,
|       |                      ^~~~~~~
| ../../../git/lib/ext2fs/llseek.c:70:43: error: unknown type name 'fd'
|    70 | static _syscall5(int,_llseek,unsigned int,fd,unsigned
long,offset_high,
|       |                                           ^~
| ../../../git/lib/ext2fs/llseek.c:70:60: error: unknown type name
'offset_high'
|    70 | static _syscall5(int,_llseek,unsigned int,fd,unsigned
long,offset_high,
|       |
 ^~~~~~~~~~~
| ../../../git/lib/ext2fs/llseek.c:71:33: error: unknown type name
'offset_low'; did you mean 'offsetof'?
|    71 |                  unsigned long, offset_low,ext2_loff_t *,result,
|       |                                 ^~~~~~~~~~
|       |                                 offsetof
| ../../../git/lib/ext2fs/llseek.c:71:58: error: unknown type name 'result'
|    71 |                  unsigned long, offset_low,ext2_loff_t *,result,
|       |                                                          ^~~~~~
| ../../../git/lib/ext2fs/llseek.c:72:32: error: unknown type name 'origin'
|    72 |                  unsigned int, origin);
|       |                                ^~~~~~
| ../../../git/lib/ext2fs/llseek.c:67:12: warning: '_llseek' used but never
defined
|    67 | static int _llseek (unsigned int, unsigned long,
|       |            ^~~~~~~
| make[2]: *** [Makefile:689: llseek.o] Error 1

The last known good build was with
acef849931c5ab14ede40c2ea01a22027e34a335, first failure was caught with
64625155eca8399f403b992ec536897f75956baa (both are Poky tree sha).


> Thanks
> -Khem
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#175178):
> https://lists.openembedded.org/g/openembedded-core/message/175178
> Mute This Topic: https://lists.openembedded.org/mt/95933622/1279857
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> nicolas.dechesne@linaro.org]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Khem Raj Jan. 6, 2023, 12:45 a.m. UTC | #4
On Wed, Jan 4, 2023 at 11:57 PM Nicolas Dechesne
<nicolas.dechesne@linaro.org> wrote:
>
>
>
> On Fri, Dec 30, 2022 at 10:14 PM Khem Raj <raj.khem@gmail.com> wrote:
>>
>> On Thu, Dec 29, 2022 at 3:10 PM Richard Purdie
>> <richard.purdie@linuxfoundation.org> wrote:
>> >
>> > On Wed, 2022-12-28 at 23:13 -0800, Khem Raj wrote:
>> > > Brings following changes
>> > >
>> > > * f47a8cdd ldso: fix invalid early references to extern-linkage libc.page_size
>> > > * 377218cb pthread_atfork: fix return value on malloc failure
>> > > * 29e43191 fix double-processing of DT_RELR relocations in ldso relocating itself
>> > > * b50eb8c3 fix strverscmp comparison of digit sequence with non-digits
>> > > * ad5dcd39 fix async thread cancellation stack alignment
>> > > * 8f925945 fix return value of gethostby{name[2],addr} with no result but no error
>> > > * 63402be2 clean up dns_parse_callback
>> > > * 0a7b4323 dns response handling: don't treat too many addresses as an error
>> > > * 41603c77 dns response handling: ignore presence of wrong-type RRs
>> > > * cf76df0e fix missing synchronization of pthread TSD keys with MT-fork
>> > > * 5ff3eea9 fgets: avoid arithmetic overflow when n==INT_MIN is passed
>> > > * d8f35e29 fix AS-safety of close when aio is in use and fd map is expanded
>> > > * 26c76a90 fix use of uninitialized dummy_fut in aio_suspend
>> > > * aebd6a36 fix potential deadlock between multithreaded fork and aio
>> > > * d64148a8 fix potential unsynchronized access to killlock state at thread exit
>> > > * 36b72cd6 fix potential deadlock in dlerror buffer handling at thread exit
>> > > * 833a4691 configure: disable TBAA optimization because most compilers are buggy
>> > > * e6e82132 disable MADV_FREE usage in mallocng
>> > > * 25e6fee2 remove LFS64 programming interfaces (macro-only) from _GNU_SOURCE
>> > > * 246f1c81 remove LFS64 symbol aliases; replace with dynamic linker remapping
>> > > * dec8f0a4 dns query core: detect udp truncation at recv time
>> > > * 8c408937 getaddrinfo dns lookup: use larger answer buffer to handle long CNAMEs
>> > > * 759bf785 arpa/nameser.h: update RR types list
>> > > * 51d4669f dns: implement tcp fallback in __res_msend query core
>> > > * e2e95176 res_send: use a temp buffer if caller's buffer is under 512 bytes
>> > > * c87d75f2 adapt res_msend DNS query core for working with multiple sockets
>> > > * 85050ac5 getaddrinfo: add EAI_NODATA error code to distinguish NODATA vs NxDomain
>> > >
>> > > Signed-off-by: Khem Raj <raj.khem@gmail.com>
>> > > ---
>> > >  meta/recipes-core/musl/musl_git.bb | 2 +-
>> > >  1 file changed, 1 insertion(+), 1 deletion(-)
>> > >
>> > > diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
>> > > index a72d87ea6f..7749495ec6 100644
>> > > --- a/meta/recipes-core/musl/musl_git.bb
>> > > +++ b/meta/recipes-core/musl/musl_git.bb
>> > > @@ -4,7 +4,7 @@
>> > >  require musl.inc
>> > >  inherit linuxloader
>> > >
>> > > -SRCREV = "dc9285ad1dc19349c407072cc48ba70dab86de45"
>> > > +SRCREV = "f47a8cdd250d9163fcfb39bf4e9d813957c0b187"
>> > >
>> > >  BASEVER = "1.2.3"
>> > >
>> >
>> > I tested this with your 3 musl patches and it showed a few issues:
>> >
>> > https://autobuilder.yoctoproject.org/typhoon/#/builders/64/builds/6421
>> > https://autobuilder.yoctoproject.org/typhoon/#/builders/45/builds/6439
>> >
>>
>> I have sent fixes for all the build failures seen in these two builds.
>
>
> I am getting other failures since this patch was merged (https://github.com/ndechesne/meta-qcom/actions/workflows/daily.yml). When building e2fsprog for arm 32 bit targets. A snippet of the build log is:
>
> | arm-poky-linux-musleabi-gcc  -mthumb -mfpu=neon-vfpv4 -mfloat-abi=hard -mcpu=cortex-a15 -fstack-protector-strong  -O2 -D_FORTIFY_SOURCE=2 -Wformat -Wformat-security -Werror=format-security --sysroot=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/recipe-sysroot -I. -I../../lib -I../../../git/lib  -O2 -pipe -g -feliminate-unused-debug-types -fmacro-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/git=/usr/src/debug/e2fsprogs/1.46.5-r0  -fdebug-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/git=/usr/src/debug/e2fsprogs/1.46.5-r0  -fmacro-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/build=/usr/src/debug/e2fsprogs/1.46.5-r0  -fdebug-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/build=/usr/src/debug/e2fsprogs/1.46.5-r0  -fdebug-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/recipe-sysroot=  -fmacro-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/recipe-sysroot=  -fdebug-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/recipe-sysroot-native=  -pthread  -DHAVE_CONFIG_H  -c ../../../git/lib/ext2fs/lookup.c -o lookup.o
> | ../../../git/lib/ext2fs/llseek.c:70:22: error: expected declaration specifiers or '...' before '_llseek'
> |    70 | static _syscall5(int,_llseek,unsigned int,fd,unsigned long,offset_high,
> |       |                      ^~~~~~~
> | ../../../git/lib/ext2fs/llseek.c:70:43: error: unknown type name 'fd'
> |    70 | static _syscall5(int,_llseek,unsigned int,fd,unsigned long,offset_high,
> |       |                                           ^~
> | ../../../git/lib/ext2fs/llseek.c:70:60: error: unknown type name 'offset_high'
> |    70 | static _syscall5(int,_llseek,unsigned int,fd,unsigned long,offset_high,
> |       |                                                            ^~~~~~~~~~~
> | ../../../git/lib/ext2fs/llseek.c:71:33: error: unknown type name 'offset_low'; did you mean 'offsetof'?
> |    71 |                  unsigned long, offset_low,ext2_loff_t *,result,
> |       |                                 ^~~~~~~~~~
> |       |                                 offsetof
> | ../../../git/lib/ext2fs/llseek.c:71:58: error: unknown type name 'result'
> |    71 |                  unsigned long, offset_low,ext2_loff_t *,result,
> |       |                                                          ^~~~~~
> | ../../../git/lib/ext2fs/llseek.c:72:32: error: unknown type name 'origin'
> |    72 |                  unsigned int, origin);
> |       |                                ^~~~~~
> | ../../../git/lib/ext2fs/llseek.c:67:12: warning: '_llseek' used but never defined
> |    67 | static int _llseek (unsigned int, unsigned long,
> |       |            ^~~~~~~
> | make[2]: *** [Makefile:689: llseek.o] Error 1
>
> The last known good build was with acef849931c5ab14ede40c2ea01a22027e34a335, first failure was caught with 64625155eca8399f403b992ec536897f75956baa (both are Poky tree sha).
>

Interesting, it compiled ok for qemuarm and also for rpi4(32bit), I
will try to reproduce it here.

>>
>> Thanks
>> -Khem
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#175178): https://lists.openembedded.org/g/openembedded-core/message/175178
>> Mute This Topic: https://lists.openembedded.org/mt/95933622/1279857
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [nicolas.dechesne@linaro.org]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Nicolas Dechesne Jan. 6, 2023, 7:32 a.m. UTC | #5
On Fri, Jan 6, 2023 at 1:45 AM Khem Raj <raj.khem@gmail.com> wrote:

> On Wed, Jan 4, 2023 at 11:57 PM Nicolas Dechesne
> <nicolas.dechesne@linaro.org> wrote:
> >
> >
> >
> > On Fri, Dec 30, 2022 at 10:14 PM Khem Raj <raj.khem@gmail.com> wrote:
> >>
> >> On Thu, Dec 29, 2022 at 3:10 PM Richard Purdie
> >> <richard.purdie@linuxfoundation.org> wrote:
> >> >
> >> > On Wed, 2022-12-28 at 23:13 -0800, Khem Raj wrote:
> >> > > Brings following changes
> >> > >
> >> > > * f47a8cdd ldso: fix invalid early references to extern-linkage
> libc.page_size
> >> > > * 377218cb pthread_atfork: fix return value on malloc failure
> >> > > * 29e43191 fix double-processing of DT_RELR relocations in ldso
> relocating itself
> >> > > * b50eb8c3 fix strverscmp comparison of digit sequence with
> non-digits
> >> > > * ad5dcd39 fix async thread cancellation stack alignment
> >> > > * 8f925945 fix return value of gethostby{name[2],addr} with no
> result but no error
> >> > > * 63402be2 clean up dns_parse_callback
> >> > > * 0a7b4323 dns response handling: don't treat too many addresses as
> an error
> >> > > * 41603c77 dns response handling: ignore presence of wrong-type RRs
> >> > > * cf76df0e fix missing synchronization of pthread TSD keys with
> MT-fork
> >> > > * 5ff3eea9 fgets: avoid arithmetic overflow when n==INT_MIN is
> passed
> >> > > * d8f35e29 fix AS-safety of close when aio is in use and fd map is
> expanded
> >> > > * 26c76a90 fix use of uninitialized dummy_fut in aio_suspend
> >> > > * aebd6a36 fix potential deadlock between multithreaded fork and aio
> >> > > * d64148a8 fix potential unsynchronized access to killlock state at
> thread exit
> >> > > * 36b72cd6 fix potential deadlock in dlerror buffer handling at
> thread exit
> >> > > * 833a4691 configure: disable TBAA optimization because most
> compilers are buggy
> >> > > * e6e82132 disable MADV_FREE usage in mallocng
> >> > > * 25e6fee2 remove LFS64 programming interfaces (macro-only) from
> _GNU_SOURCE
> >> > > * 246f1c81 remove LFS64 symbol aliases; replace with dynamic linker
> remapping
> >> > > * dec8f0a4 dns query core: detect udp truncation at recv time
> >> > > * 8c408937 getaddrinfo dns lookup: use larger answer buffer to
> handle long CNAMEs
> >> > > * 759bf785 arpa/nameser.h: update RR types list
> >> > > * 51d4669f dns: implement tcp fallback in __res_msend query core
> >> > > * e2e95176 res_send: use a temp buffer if caller's buffer is under
> 512 bytes
> >> > > * c87d75f2 adapt res_msend DNS query core for working with multiple
> sockets
> >> > > * 85050ac5 getaddrinfo: add EAI_NODATA error code to distinguish
> NODATA vs NxDomain
> >> > >
> >> > > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> >> > > ---
> >> > >  meta/recipes-core/musl/musl_git.bb | 2 +-
> >> > >  1 file changed, 1 insertion(+), 1 deletion(-)
> >> > >
> >> > > diff --git a/meta/recipes-core/musl/musl_git.bb
> b/meta/recipes-core/musl/musl_git.bb
> >> > > index a72d87ea6f..7749495ec6 100644
> >> > > --- a/meta/recipes-core/musl/musl_git.bb
> >> > > +++ b/meta/recipes-core/musl/musl_git.bb
> >> > > @@ -4,7 +4,7 @@
> >> > >  require musl.inc
> >> > >  inherit linuxloader
> >> > >
> >> > > -SRCREV = "dc9285ad1dc19349c407072cc48ba70dab86de45"
> >> > > +SRCREV = "f47a8cdd250d9163fcfb39bf4e9d813957c0b187"
> >> > >
> >> > >  BASEVER = "1.2.3"
> >> > >
> >> >
> >> > I tested this with your 3 musl patches and it showed a few issues:
> >> >
> >> >
> https://autobuilder.yoctoproject.org/typhoon/#/builders/64/builds/6421
> >> >
> https://autobuilder.yoctoproject.org/typhoon/#/builders/45/builds/6439
> >> >
> >>
> >> I have sent fixes for all the build failures seen in these two builds.
> >
> >
> > I am getting other failures since this patch was merged (
> https://github.com/ndechesne/meta-qcom/actions/workflows/daily.yml). When
> building e2fsprog for arm 32 bit targets. A snippet of the build log is:
> >
> > | arm-poky-linux-musleabi-gcc  -mthumb -mfpu=neon-vfpv4 -mfloat-abi=hard
> -mcpu=cortex-a15 -fstack-protector-strong  -O2 -D_FORTIFY_SOURCE=2 -Wformat
> -Wformat-security -Werror=format-security
> --sysroot=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/recipe-sysroot
> -I. -I../../lib -I../../../git/lib  -O2 -pipe -g
> -feliminate-unused-debug-types
> -fmacro-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/git=/usr/src/debug/e2fsprogs/1.46.5-r0
> -fdebug-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/git=/usr/src/debug/e2fsprogs/1.46.5-r0
> -fmacro-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/build=/usr/src/debug/e2fsprogs/1.46.5-r0
> -fdebug-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/build=/usr/src/debug/e2fsprogs/1.46.5-r0
> -fdebug-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/recipe-sysroot=
> -fmacro-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/recipe-sysroot=
> -fdebug-prefix-map=/oe/build/tmp/work/cortexa15t2hf-neon-vfpv4-poky-linux-musleabi/e2fsprogs/1.46.5-r0/recipe-sysroot-native=
> -pthread  -DHAVE_CONFIG_H  -c ../../../git/lib/ext2fs/lookup.c -o lookup.o
> > | ../../../git/lib/ext2fs/llseek.c:70:22: error: expected declaration
> specifiers or '...' before '_llseek'
> > |    70 | static _syscall5(int,_llseek,unsigned int,fd,unsigned
> long,offset_high,
> > |       |                      ^~~~~~~
> > | ../../../git/lib/ext2fs/llseek.c:70:43: error: unknown type name 'fd'
> > |    70 | static _syscall5(int,_llseek,unsigned int,fd,unsigned
> long,offset_high,
> > |       |                                           ^~
> > | ../../../git/lib/ext2fs/llseek.c:70:60: error: unknown type name
> 'offset_high'
> > |    70 | static _syscall5(int,_llseek,unsigned int,fd,unsigned
> long,offset_high,
> > |       |
> ^~~~~~~~~~~
> > | ../../../git/lib/ext2fs/llseek.c:71:33: error: unknown type name
> 'offset_low'; did you mean 'offsetof'?
> > |    71 |                  unsigned long, offset_low,ext2_loff_t
> *,result,
> > |       |                                 ^~~~~~~~~~
> > |       |                                 offsetof
> > | ../../../git/lib/ext2fs/llseek.c:71:58: error: unknown type name
> 'result'
> > |    71 |                  unsigned long, offset_low,ext2_loff_t
> *,result,
> > |       |                                                          ^~~~~~
> > | ../../../git/lib/ext2fs/llseek.c:72:32: error: unknown type name
> 'origin'
> > |    72 |                  unsigned int, origin);
> > |       |                                ^~~~~~
> > | ../../../git/lib/ext2fs/llseek.c:67:12: warning: '_llseek' used but
> never defined
> > |    67 | static int _llseek (unsigned int, unsigned long,
> > |       |            ^~~~~~~
> > | make[2]: *** [Makefile:689: llseek.o] Error 1
> >
> > The last known good build was with
> acef849931c5ab14ede40c2ea01a22027e34a335, first failure was caught with
> 64625155eca8399f403b992ec536897f75956baa (both are Poky tree sha).
> >
>
> Interesting, it compiled ok for qemuarm and also for rpi4(32bit), I
> will try to reproduce it here.
>

I am seeing the same problem in my poky/qemuarm CI:
https://ci.linaro.org/job/lt-qcom-poky-master/604/DISTRO=poky,MACHINE=qemuarm,TCLIBC=musl/console

Note that both meta-qcom and poky/qemu are using the Linaro Tux cloud
infrastructure to build.. I will try a local build as well.


>
> >>
> >> Thanks
> >> -Khem
> >>
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >> Links: You receive all messages sent to this group.
> >> View/Reply Online (#175178):
> https://lists.openembedded.org/g/openembedded-core/message/175178
> >> Mute This Topic: https://lists.openembedded.org/mt/95933622/1279857
> >> Group Owner: openembedded-core+owner@lists.openembedded.org
> >> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> nicolas.dechesne@linaro.org]
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >>
>
diff mbox series

Patch

diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index a72d87ea6f..7749495ec6 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -4,7 +4,7 @@ 
 require musl.inc
 inherit linuxloader
 
-SRCREV = "dc9285ad1dc19349c407072cc48ba70dab86de45"
+SRCREV = "f47a8cdd250d9163fcfb39bf4e9d813957c0b187"
 
 BASEVER = "1.2.3"